Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st February 2010, 04:56
khamikaze khamikaze is offline
Junior Member
 
Join Date: Feb 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default [OpenFiler / HA] Heartbeat can not activate LVM volume: open file descriptors

[ [OpenFiler / HA] Heartbeat can not activate LVM volume: open file descriptors ]

gilly05 and other folks,

This guide is great:

Installing and Configuring Openfiler with DRBD and Heartbeat

http://www.howtoforge.com/installing...-and-heartbeat

Unfortunately I have not suceeded to make DRBD and Heartbeat to work with OpenFiler 2.3.

I think DRBD is working fine, as far as syncing the my chosen partitions.
However Heartbeat does not seem to be able to mount / activate correctly the LVM volume that I configured for DRBD.
It complains about "open file descriptors", like this:

ERROR: File descriptor 4 left open File descriptor 5 left open File descriptor 6 left open File descriptor 7 left open File descriptor 8 left open File descriptor 9 left open File descriptor 10 left open File descriptor 12 left open
ERROR: Generic error

I can get more details shortly.

Anyways.

Are there any other guides more recent / revised / updated in order to set up HA (DRBD and Heartbeat) in OpenFiler 2.3?


Thanks,


Tags: openfiler , linux , ha , drbd , heartbeat , lvm , high availability,
Reply With Quote
Sponsored Links
  #2  
Old 1st February 2010, 12:51
padonker padonker is offline
Member
 
Join Date: Apr 2009
Posts: 30
Thanks: 2
Thanked 1 Time in 1 Post
Default

Don't bother, nobody will help you or reply to your questions.
The how-to is filled with remarks and questions...no replies.
Too bad, because it is a good article.
Reply With Quote
  #3  
Old 1st February 2010, 14:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by khamikaze View Post
I think DRBD is working fine, as far as syncing the my chosen partitions.
However Heartbeat does not seem to be able to mount / activate correctly the LVM volume that I configured for DRBD.
It complains about "open file descriptors", like this:

ERROR: File descriptor 4 left open File descriptor 5 left open File descriptor 6 left open File descriptor 7 left open File descriptor 8 left open File descriptor 9 left open File descriptor 10 left open File descriptor 12 left open
ERROR: Generic error
Are there any errors in your logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 1st February 2010, 14:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by padonker View Post
Don't bother, nobody will help you or reply to your questions.
The how-to is filled with remarks and questions...no replies.
Too bad, because it is a good article.
Thanks for the helpful comment. You might have noticed the following sentence above the comment section:
Quote:
Please do not use the comment function to ask for help!
If you need assistance, please use the forum!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 1st February 2010, 15:14
padonker padonker is offline
Member
 
Join Date: Apr 2009
Posts: 30
Thanks: 2
Thanked 1 Time in 1 Post
Default

Dont want to start a flame war, but there are a whole lot of questions here on this forum that are unanswered, especially about the OF howto.
I too am looking for answers...
Reply With Quote
  #6  
Old 1st February 2010, 16:27
khamikaze khamikaze is offline
Junior Member
 
Join Date: Feb 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default ha-log messages

Gentlemen,

Here are my actual ha-log errors / messages:

ResourceManager[28062]: 2010/01/29_15:36:26 debug: /etc/ha.d/resource.d/IPaddr 192.168.100.10/24 start done. RC=0
ResourceManager[28062]: 2010/01/29_15:36:26 info: Running /etc/ha.d/resource.d/drbddisk start
ResourceManager[28062]: 2010/01/29_15:36:26 debug: Starting /etc/ha.d/resource.d/drbddisk start
ResourceManager[28062]: 2010/01/29_15:36:26 debug: /etc/ha.d/resource.d/drbddisk start done. RC=0
File descriptor 4 left open
File descriptor 5 left open
File descriptor 6 left open
File descriptor 7 left open
File descriptor 8 left open
File descriptor 9 left open
File descriptor 10 left open
File descriptor 12 left open
Using volume group(s) on command line
Finding volume group "vg02drbd1"
Wiping cache of LVM-capable devices
LVM[28483]: 2010/01/29_15:36:26 INFO: LVM Volume vg02drbd1 is offline
LVM[28472]: 2010/01/29_15:36:26 INFO: Resource is stopped
ResourceManager[28062]: 2010/01/29_15:36:26 info: Running /etc/ha.d/resource.d/LVM vg02drbd1 start
ResourceManager[28062]: 2010/01/29_15:36:26 debug: Starting /etc/ha.d/resource.d/LVM vg02drbd1 start
LVM[28538]: 2010/01/29_15:36:26 INFO: Activating volume group vg02drbd1
LVM[28538]: 2010/01/29_15:36:26 INFO: File descriptor 4 left open File descriptor 5 left open File descriptor 6 left open File descriptor 7 left open File descriptor 8 left open File descriptor 9 left open File descriptor 10 left open File descriptor 12 left open Device '/dev/drbd1' has been left open. Reading all physical volumes. This may take a while... Found volume group "vg01" using metadata type lvm2 Found volume group "vg02drbd1" using metadata type lvm2
LVM[28538]: 2010/01/29_15:36:26 INFO: File descriptor 4 left open File descriptor 5 left open File descriptor 6 left open File descriptor
7 left open File descriptor 8 left open File descriptor 9 left open File descriptor 10 left open File descriptor 12 left open 0 logical volume(s) in volume group "vg02drbd1" now active
File descriptor 4 left open
File descriptor 5 left open
File descriptor 6 left open
File descriptor 7 left open
File descriptor 8 left open
File descriptor 9 left open
File descriptor 10 left open
File descriptor 12 left open
Using volume group(s) on command line
Finding volume group "vg02drbd1"
LVM[28538]: 2010/01/29_15:36:27 ERROR: LVM: vg02drbd1 did not activate correctly
LVM[28527]: 2010/01/29_15:36:27 ERROR: Generic error
ERROR: Generic error
ResourceManager[28062]: 2010/01/29_15:36:27 debug: /etc/ha.d/resource.d/LVM vg02drbd1 start done. RC=1
ResourceManager[28062]: 2010/01/29_15:36:27 ERROR: Return code 1 from /etc/ha.d/resource.d/LVM
ResourceManager[28062]: 2010/01/29_15:36:27 CRIT: Giving up resources due to failure of LVM::vg02drbd1
ResourceManager[28062]: 2010/01/29_15:36:27 info: Releasing resource group: filer01a MailTo::admin@acme.com::ClusterFailover IPaddr::192.168.100.10/24 drbddisk:: LVM::vg02drbd1 Filesystem::/dev/drbd0::/cluster_metadata::ext3::defaults,noatime MakeMounts iscsi-target rsync acpid openfiler
ResourceManager[28062]: 2010/01/29_15:36:27 info: Running /etc/init.d/openfiler stop


Any thoughts?
Reply With Quote
  #7  
Old 2nd February 2010, 15:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Does this still happen after a reboot?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 2nd February 2010, 15:19
khamikaze khamikaze is offline
Junior Member
 
Join Date: Feb 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes.

However, as Heartbeat is not being able to mount the LVM partition, DRBD starts to degrade and at some point I ended up in split brain situation.

So, yesterday I created 2 VMs to test this out as well.
In this VM setup, I did not use LVM and I did an "conary updateall" before anything.
I got that working.

But...
When I went back to my original setup, where I have multiple bonding interfaces, the newest kernel of OpenFiler (2.6.29 xxx) is now giving hard times, kernel panic, etc, etc:

https://forums.openfiler.com/viewtop...d=19267#p19267

So I do not if I should try to fix the bonding in the new kernel or LVM in the old one...

Thoughts?
Reply With Quote
  #9  
Old 2nd February 2010, 15:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
 
Default

Quote:
Originally Posted by padonker View Post
Dont want to start a flame war, but there are a whole lot of questions here on this forum that are unanswered, especially about the OF howto.
I too am looking for answers...
Till and I each spend at least two hours every day in this forum, trying to help people, even on weekends, and there are a few other great guys who try to do the same. This is time that is not getting paid, that we could spend with our families or friends, but no, we are trying to help other people. Of course there are unanswered threads in this forum, but it's just not possible for us to answer all questions - be it that we don't know the answer or be it that there are too many questions for us to handle. Maybe the picture would be different if only a small percentage of the people that ask questions here would also give back by answering other people's questions if they know the answer - but obviously, only very few people give back - sad, but that's the way it is. Anyway, people are trying to help other people for free, so you can't expect an answer, but you should be grateful if you get one. Period.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
drbd, heartbeat, high availability, lvm, openfiler

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 7 26th June 2014 14:33
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 13:21
Mail System doesnt work! crichton Installation/Configuration 3 17th September 2007 23:49
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 16:05
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 22:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.