Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 24th January 2010, 22:57
mooxe mooxe is offline
Junior Member
 
Join Date: Jan 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Apache Log File + Webalizer - Bytes Transferred

Gentlemen,

A strange problem with the Apache logs here. No amount of searching has come by an explanation for me.

I am requesting a file that is 34585356 bytes. I cancel the download when it reaches just 100kb. Apache logs this as...


124.128.195.146 - - [24/Jan/2010:16:18:49 -0500] "GET /downloads/CC5/overlord/CC5_Overlord_EliteCommand_v1.4_submod.zip HTTP/1.1" 200 34585356 "-" "Mozilla/5.0 (compatible; MSIE 6.0; Windows NT 5.0)"

When Webalizer reads this, its counted as a full 32megabyte download, when in fact I cancelled at 100kb. Happens for all files, so the data Webalizer displays in totals, are the totals of all files ever hit and completely downloaded.

I am guessing its Apache's problem. Apache should be logging how many bytes were transferred rather than just inputting the exact file size. How do I do this?
Reply With Quote
Sponsored Links
 

Bookmarks

Tags
webalizer apache

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
webalizer: Error: Can't open log file /var/www/web34/log/web.log (symlink) olasamuelson Installation/Configuration 5 13th January 2010 11:06
sarg issue while generating reports for squid mail4vij Server Operation 3 31st December 2009 13:12
problem with upgrade to 2.2.34 brianetilley Installation/Configuration 14 11th November 2009 17:22
Spamsnake - Problem with spamassassin, FuzzyOcr and MySQL debuguser HOWTO-Related Questions 6 16th September 2008 18:37
spamassasin/clamAV not working Daisy Installation/Configuration 32 15th February 2007 00:09


All times are GMT +2. The time now is 11:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.