Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 24th January 2010, 19:10
KaiserGimmel KaiserGimmel is offline
Junior Member
 
Join Date: Oct 2009
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
Default [Solved]Maildrop: unable to open mailbox

Hello,

yesterday I did a big misstake - i added the unstable sources to the sources.lst (to update my mumble server) and my apt-auto updater did a complete update of my server tonight. Its a debian lenny machine. With the old setup everything worked fine

The Problem is now that maildrop cant deliver new emails to the maildir:

Quote:
Jan 24 17:54:33 torchwood postfix/pipe[17056]: 37ACA19CE099: to=<xxx@xxx.com>, relay=maildrop, delay=0.06, delay
s=0.03/0.01/0/0.03, dsn=4.3.0, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Unable to open mailbox. )
I didnt alter the permission and they are still correct. vmail is the owner of the /var/vmail folder.

I tried to deliver a recent mail to the maildir:

Quote:
maildrop -V9 -d xxx@xxx.xxx < /var/vmail/xxx/xxx/.Archives.2010/cur/1262701017.M786815P10300V0000000000000801I00000000 01BE213A_1.torchwood\,S\=19707\:2\,S

...
.mailfilter(5): LOGNAME=""
.mailfilter(6): EXTENSION=""
.mailfilter(7): RECIPIENT=""
.mailfilter(8): USER=""
.mailfilter(9): HOST=""
...
maildrop: Delivering to /var/vmail///.
maildrop: Unable to open mailbox.
I think the Recipient User and Host are not passed in correctly - dont know how to fix this.
My mercurial tells me that the master.cf is not altered - but for a overview:

Quote:
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
body_checks = regexp:/etc/postfix/body_checks
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
header_checks = regexp:/etc/postfix/header_checks
html_directory = /usr/share/doc/postfix/html
inet_interfaces = all
mailbox_size_limit = 0
message_size_limit = 0
mime_header_checks = regexp:/etc/postfix/mime_header_checks
mydestination = torchwood.xxx.xxx, localhost, localhost.localdomain
myhostname = torchwood.xxx.xxx
mynetworks = 127.0.0.0/8 [::1]/128
myorigin = /etc/mailname
nested_header_checks = regexp:/etc/postfix/nested_header_checks
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
readme_directory = /usr/share/doc/postfix
receive_override_options = no_address_mappings
recipient_delimiter = +
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relayhost =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_transport = maildrop
virtual_uid_maps = static:5000
The mysql settings work - same again nothing altered.

Anyone here can give me a clue how to fix this mess?
Would really appreciate it!
Cheers
Max

Last edited by KaiserGimmel; 25th January 2010 at 10:57. Reason: solved
Reply With Quote
Sponsored Links
 

Bookmarks

Tags
lenny, mailbox, maildrop, update

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Forbidden 403; Samba access; config of maildeamon fawkes Installation/Configuration 4 14th January 2010 18:16
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
libWand.so.10 error Taxick Installation/Configuration 8 3rd May 2009 01:27
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 06:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.