Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 17th January 2010, 15:53
IzaKamakazi IzaKamakazi is offline
Junior Member
 
Join Date: Jan 2010
Location: Wales UK
Posts: 17
Thanks: 1
Thanked 1 Time in 1 Post
Send a message via MSN to IzaKamakazi
Default

Hi Falko,

If I comment out the lines as suggested I get an extra directory - izabay.co.uk.

I can now reach my default page from this addrress:

http://www.izabay.co.uk/izabay.co.uk/web/

Hope that helps.

Thanks
Kam.
Reply With Quote
Sponsored Links
  #12  
Old 18th January 2010, 15:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

I can't access your site - I get this error: "The server at www.izabay.co.uk is taking too long to respond."
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 18th January 2010, 18:58
IzaKamakazi IzaKamakazi is offline
Junior Member
 
Join Date: Jan 2010
Location: Wales UK
Posts: 17
Thanks: 1
Thanked 1 Time in 1 Post
Send a message via MSN to IzaKamakazi
Default

Sorry Falko, it was turned off as it is no use until it is working correctly.

It is up and running now.

Thanks Kam.
Reply With Quote
  #14  
Old 19th January 2010, 15:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Can you try this?
Code:
a2dissite default
/etc/init.d/apache2 restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 19th January 2010, 20:10
IzaKamakazi IzaKamakazi is offline
Junior Member
 
Join Date: Jan 2010
Location: Wales UK
Posts: 17
Thanks: 1
Thanked 1 Time in 1 Post
Send a message via MSN to IzaKamakazi
Default

Hi Again,

Here is the results of the code:

Code:
kamakazi@server:~$ a2dissite default
Could not remove /etc/apache2/sites-enabled/000-default: Permission denied
kamakazi@server:~$ /etc/init.d/apache2 restart
 * Restarting web server apache2                                                Warning: DocumentRoot [/var/www/ispconfig/] does not exist
Warning: DocumentRoot [/usr/local/ispconfig/interface/web/] does not exist
[Tue Jan 19 18:52:36 2010] [warn] NameVirtualHost 82.13.2.79:443 has no VirtualHosts
Warning: DocumentRoot [/var/www/ispconfig/] does not exist
Warning: DocumentRoot [/usr/local/ispconfig/interface/web/] does not exist
[Tue Jan 19 18:52:36 2010] [warn] NameVirtualHost 82.13.2.79:443 has no VirtualHosts
(13)Permission denied: make_sock: could not bind to address [::]:80
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
                                                                         [fail]
kamakazi@server:~$ sudo a2dissite default
[sudo] password for kamakazi: 
Site default disabled.
Run '/etc/init.d/apache2 reload' to activate new configuration!
kamakazi@server:~$ /etc/init.d/apache2 restart
 * Restarting web server apache2                                                Warning: DocumentRoot [/var/www/ispconfig/] does not exist
Warning: DocumentRoot [/usr/local/ispconfig/interface/web/] does not exist
[Tue Jan 19 18:53:20 2010] [warn] NameVirtualHost 82.13.2.79:443 has no VirtualHosts
[Tue Jan 19 18:53:20 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
Warning: DocumentRoot [/var/www/ispconfig/] does not exist
Warning: DocumentRoot [/usr/local/ispconfig/interface/web/] does not exist
[Tue Jan 19 18:53:20 2010] [warn] NameVirtualHost 82.13.2.79:443 has no VirtualHosts
[Tue Jan 19 18:53:20 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
(13)Permission denied: make_sock: could not bind to address [::]:80
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
                                                                         [fail]
kamakazi@server:~$
This is what I now get when trying to access the site:
Code:
Access forbidden!

You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

If you think this is a server error, please contact the webmaster.
Error 403
www.izabay.co.uk
Tue Jan 19 19:07:41 2010
Apache/2.2.12 (Ubuntu)
.

I also tried un commenting the izabay.co.uk.vhost that we modified earlier in the thread but the results were the same.

Many Thanks Kam.
Reply With Quote
  #16  
Old 20th January 2010, 11:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
Default

You have to run the commands that falko posted as root user.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #17  
Old 20th January 2010, 19:04
IzaKamakazi IzaKamakazi is offline
Junior Member
 
Join Date: Jan 2010
Location: Wales UK
Posts: 17
Thanks: 1
Thanked 1 Time in 1 Post
Send a message via MSN to IzaKamakazi
Default

Hi Till,

Thanks for letting me know that it should have been from root, you may I have guessed I'm new to all this.

Here is the code as root user:
Code:
kamakazi@server:~$ su
Password: 
root@server:/home/kamakazi# a2dissite default
Site default already disabled
root@server:/home/kamakazi# /etc/init.d/apache2 restart
 * Restarting web server apache2                                                [Wed Jan 20 18:01:18 2010] [warn] NameVirtualHost 82.13.2.79:443 has no VirtualHosts
[Wed Jan 20 18:01:18 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
 ... waiting .[Wed Jan 20 18:01:20 2010] [warn] NameVirtualHost 82.13.2.79:443 has no VirtualHosts
[Wed Jan 20 18:01:20 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
                                                                         [ OK ]
You have mail in /var/mail/root
root@server:/home/kamakazi#
Thanks again guys, sorry this is taking so much of your time.

Kam.
Reply With Quote
  #18  
Old 22nd January 2010, 14:29
IzaKamakazi IzaKamakazi is offline
Junior Member
 
Join Date: Jan 2010
Location: Wales UK
Posts: 17
Thanks: 1
Thanked 1 Time in 1 Post
Send a message via MSN to IzaKamakazi
Default

Any ideas guys?

Thanks Kam
Reply With Quote
  #19  
Old 22nd January 2010, 14:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
 
Default

The output above is ok. The default site was already disabled.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problems receiving mails Amorphous Installation/Configuration 2 15th October 2009 11:04
mail - 8080 - couple of others clemens General 9 6th June 2009 10:27
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 8th May 2009 23:00
Web Hosting Only For Individual Domains bails Installation/Configuration 2 19th August 2008 16:35
Spamassassin not working hairydog2 General 7 12th July 2008 21:15


All times are GMT +2. The time now is 09:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.