Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 18th January 2010, 00:50
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,786
Thanks: 840
Thanked 5,611 Times in 4,422 Posts
Default

Sendmail is the name of the postfix sendmail wrapper an part of every postfix configuration, os the log lines are ok.

The output of the postf´conf commands is ok.

Please post the output of:

netstat -tap | grep smtp

and the content of the /etc/hosts file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #12  
Old 18th January 2010, 00:52
aurasdoom aurasdoom is offline
Junior Member
 
Join Date: Jan 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here it is:
Code:
# netstat -tap | grep smtp
getnameinfo failed
getnameinfo failed
getnameinfo failed
getnameinfo failed
# cat /etc/hosts
127.0.0.1 localhost.localdomain localhost
# Auto-generated hostname. Please do not remove this comment.
93.115.250.113 wip.ro  wip wip
Reply With Quote
  #13  
Old 18th January 2010, 01:37
aurasdoom aurasdoom is offline
Junior Member
 
Join Date: Jan 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

About the before squirrelmail problem it seemed that postfix was stopped, silly me

Here's the log now:
Quote:
Jan 18 02:34:16 wip sendmail[27868]: o0HNYGHB027868: Authentication-Warning: wip.ro: apache set sender to auras@wip.ro using -f
Jan 18 02:34:16 wip sendmail[27868]: o0HNYGHB027868: from=auras@wip.ro, size=507, class=0, nrcpts=1, msgid=<51298.79.118.174.214.1263771256.squirrel@wi p.ro>, relay=apache@localhost
Jan 18 02:34:16 wip postfix/smtpd[28183]: connect from localhost.localdomain[127.0.0.1]
Jan 18 02:34:16 wip sendmail[27868]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Jan 18 02:34:16 wip postfix/smtpd[28183]: B31111BCD133: client=localhost.localdomain[127.0.0.1]
Jan 18 02:34:16 wip postfix/cleanup[28424]: B31111BCD133: message-id=<51298.79.118.174.214.1263771256.squirrel@wip.r o>
Jan 18 02:34:16 wip postfix/qmgr[17570]: B31111BCD133: from=<auras@wip.ro.ro>, size=906, nrcpt=1 (queue active)
Jan 18 02:34:16 wip sendmail[27868]: o0HNYGHB027868: to=auras@wip.ro, ctladdr=auras@wip.ro (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30507, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as B31111BCD133)
Jan 18 02:34:16 wip postfix/smtpd[28183]: disconnect from localhost.localdomain[127.0.0.1]
Jan 18 02:34:18 wip amavis[22020]: (22020-01) (!!)WARN: all primary virus scanners failed, considering backups
Jan 18 02:34:26 wip postfix/smtpd[16163]: connect from unknown[127.0.0.1]
Jan 17 23:34:26 wip postfix/smtpd[16163]: 9012D1BCD134: client=localhost.localdomain[127.0.0.1]
Jan 18 02:34:26 wip postfix/cleanup[28424]: 9012D1BCD134: message-id=<51298.79.118.174.214.1263771256.squirrel@wip.r o>
Jan 18 02:34:26 wip postfix/qmgr[17570]: 9012D1BCD134: from=<auras@wip.ro.ro>, size=1310, nrcpt=1 (queue active)
Jan 18 02:34:26 wip amavis[22020]: (22020-01) Passed CLEAN, MYNETS LOCAL [127.0.0.1] [79.118.174.214] <auras@wip.ro.ro> -> <auras@wip.ro.ro>, Message-ID: <51298.79.118.174.214.1263771256.squirrel@wip.ro >, mail_id: ddd2U8ncP1RM, Hits: 1.944, size: 906, queued_as: 9012D1BCD134, 9861 ms
Jan 18 02:34:26 wip postfix/smtp[28482]: B31111BCD133: to=<auras@wip.ro.ro>, relay=127.0.0.1[127.0.0.1]:10024, delay=10, delays=0.19/0.01/0.05/9.8, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=22020-01, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 9012D1BCD134)
Jan 18 02:34:26 wip postfix/qmgr[17570]: B31111BCD133: removed
Jan 18 02:34:26 wip postfix/smtp[17859]: 9012D1BCD134: to=<auras@wip.ro.ro>, relay=wip.ro.ro[87.106.16.229]:25, delay=0.28, delays=0.03/0/0.18/0.07, dsn=5.0.0, status=bounced (host wip.ro.ro[87.106.16.229] said: 553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1) (in reply to RCPT TO command))
Jan 18 02:34:26 wip postfix/cleanup[28424]: DB0651BCD139: message-id=<20100117233426.DB0651BCD139@ns1.wip.ro>
Jan 18 02:34:26 wip postfix/bounce[17459]: 9012D1BCD134: sender non-delivery notification: DB0651BCD139
Jan 18 02:34:26 wip postfix/qmgr[17570]: DB0651BCD139: from=<>, size=3247, nrcpt=1 (queue active)
Jan 18 02:34:26 wip postfix/qmgr[17570]: 9012D1BCD134: removed
Jan 18 02:34:27 wip postfix/smtp[17922]: DB0651BCD139: to=<auras@wip.ro.ro>, relay=wip.ro.ro[87.106.16.229]:25, delay=0.14, delays=0.01/0/0.09/0.03, dsn=5.0.0, status=bounced (host wip.ro.ro[87.106.16.229] said: 553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1) (in reply to RCPT TO command))
Jan 18 02:34:27 wip postfix/qmgr[17570]: DB0651BCD139: removed
And no, I didn't write the TLD twice when sending the mail.
Reply With Quote
  #14  
Old 18th January 2010, 03:41
aurasdoom aurasdoom is offline
Junior Member
 
Join Date: Jan 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Another bug I found when using SMTP SASL authentication.
I tried to authenticat with something like emailuser@mydomain.com and it's password but SASL queries the mysql users table like this:
Quote:
81 Query SELECT password FROM mail_user WHERE email = 'emailuser'
81 Query SELECT password FROM mail_user WHERE email = 'emailuser'
And I don't imagine why not because it's setup like this:
Quote:
# cat smtpd.conf
pwcheck_method: saslauthd
mech_list: plain login
saslauthd_path: /var/spool/postfix/var/run/saslauthd/mux
allow_plaintext: true
auxprop_plugin: mysql
sql_hostnames: localhost
sql_user: ispconfig
sql_passwd: ***
sql_database: dbispconfig
sql_select: select password from mail_user where email = '%u'
Emphasis on what I have bolded. Shouldn't it check for the full emailuser@mydomain.com ?

I've even changed it to %u@%d and it still queries without the domain. This is madness

Last edited by aurasdoom; 18th January 2010 at 03:48.
Reply With Quote
  #15  
Old 18th January 2010, 10:46
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,786
Thanks: 840
Thanked 5,611 Times in 4,422 Posts
Default

There is no problem with sasl according to the log files and I told you already that sasl is not even involved in receiving the emails! Do not change anything in the sasl files, it will just cause more problems. If the setup works on then thousands of servers with the exact files that are in the ispconfig installer, it will work on your server too. We just have to figure out where your server is configured wrong and when you change the working default files of ispconfig, we can stop right here as we will not find the problem then.

According to the mail log file, your server forwards the email to the server 87.106.16.229. Is this the IP of the local server?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 18th January 2010, 13:05
aurasdoom aurasdoom is offline
Junior Member
 
Join Date: Jan 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

M.. no. I sent the email to auras at wip.ro (my server) but somehow postfix (or squirrelmail) decided to send it to auras at wip.ro.ro and that's where that ip came from.

Last edited by aurasdoom; 18th January 2010 at 13:11.
Reply With Quote
  #17  
Old 19th January 2010, 12:23
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,786
Thanks: 840
Thanked 5,611 Times in 4,422 Posts
Default

Please check the settings in squirrelmail under otions and make sure that you have set a correct sender address there.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #18  
Old 19th January 2010, 13:25
aurasdoom aurasdoom is offline
Junior Member
 
Join Date: Jan 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I reran php -q update.php to remake the configuration files and smtpd authentication now works which it didn't before.

But receiving emails still doesn't work. The same problem: unknown user "xxxxxx"

I'm posting these again, maybe someone knows what's wrong with postfix:

Quote:
Jan 19 14:46:41 wip postfix/smtpd[1990]: connect from mail-fx0-f215.google.com[209.85.220.215]
Jan 19 14:46:41 wip postfix/trivial-rewrite[26080]: warning: do not list domain wip.ro in BOTH mydestination and virtual_mailbox_domains
Jan 19 14:46:41 wip postfix/smtpd[1990]: 9FC721BCD14D: client=mail-fx0-f215.google.com[209.85.220.215]
Jan 19 14:46:41 wip postfix/cleanup[26090]: 9FC721BCD14D: message-id=<7BCDA7B4-1453-41BD-A698-47E81FCA58B1@gmail.com>
Jan 19 14:46:41 wip postfix/qmgr[13386]: 9FC721BCD14D: from=<aurasd@gmail.com>, size=2011, nrcpt=1 (queue active)
Jan 19 14:46:41 wip amavis[16195]: (16195-05) (!!)WARN: all primary virus scanners failed, considering backups
Jan 19 11:46:49 wip postfix/smtpd[26151]: connect from unknown[127.0.0.1]
Jan 19 14:46:49 wip postfix/trivial-rewrite[26080]: warning: do not list domain wip.ro in BOTH mydestination and virtual_mailbox_domains
Jan 19 11:46:49 wip postfix/smtpd[26151]: 5C3BA1BCD151: client=mail-fx0-f215.google.com[209.85.220.215]
Jan 19 14:46:49 wip postfix/cleanup[26090]: 5C3BA1BCD151: message-id=<7BCDA7B4-1453-41BD-A698-47E81FCA58B1@gmail.com>
Jan 19 14:46:49 wip postfix/qmgr[13386]: 5C3BA1BCD151: from=<aurasd@gmail.com>, size=2401, nrcpt=1 (queue active)
Jan 19 11:46:49 wip postfix/smtpd[26151]: disconnect from unknown[127.0.0.1]
Jan 19 14:46:49 wip postfix/trivial-rewrite[26080]: warning: do not list domain wip.ro in BOTH mydestination and virtual_mailbox_domains
Jan 19 14:46:49 wip amavis[16195]: (16195-05) Passed CLEAN, [209.85.220.215] [79.118.174.214] <aurasd@gmail.com> -> <auras@wip.ro>, Message-ID: <7BCDA7B4-1453-41BD-A698-47E81FCA58B1@gmail.com>, mail_id: yZzgMR-hrW4W, Hits: 4.833, size: 2011, queued_as: 5C3BA1BCD151, dkim_id=@gmail.com,aurasd@gmail.com, 7727 ms
Jan 19 11:46:49 wip postfix/smtp[26096]: 9FC721BCD14D: to=<auras@wip.ro>, relay=127.0.0.1[127.0.0.1]:10024, delay=7.8, delays=0.1/0/0/7.7, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=16195-05, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 5C3BA1BCD151)
Jan 19 14:46:49 wip postfix/qmgr[13386]: 9FC721BCD14D: removed
Jan 19 14:46:49 wip postfix/local[26153]: 5C3BA1BCD151: to=<auras@wip.ro>, relay=local, delay=0.08, delays=0.07/0/0/0.01, dsn=5.1.1, status=bounced (unknown user: "auras")
It's checking wrong. It should check for auras @ wip.ro.

Quote:
SELECT domain FROM mail_domain WHERE domain='gmail.com' and active = 'y' and server_id = 1
SELECT domain FROM mail_transport WHERE domain='gmail.com' and active = 'y' and server_id = 1
SELECT domain FROM mail_transport WHERE domain='com' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='aurasd@gmail.com' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='gmail.com' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='.com' and active = 'y' and server_id = 1
SELECT domain FROM mail_domain WHERE domain='wip.ro' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='auras@wip.ro' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='wip.ro' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='.ro' and active = 'y' and server_id = 1
SELECT access FROM mail_access WHERE source='mail-fx0-f215.google.com' and type = 'client' and active = 'y'
SELECT access FROM mail_access WHERE source='google.com' and type = 'client' and active = 'y'
SELECT access FROM mail_access WHERE source='com' and type = 'client' and active = 'y'
SELECT access FROM mail_access WHERE source='209.85.220.215' and type = 'client' and active = 'y'
SELECT access FROM mail_access WHERE source='209.85.220' and type = 'client' and active = 'y'
SELECT access FROM mail_access WHERE source='209.85' and type = 'client' and active = 'y'
SELECT access FROM mail_access WHERE source='209' and type = 'client' and active = 'y'
SELECT access FROM mail_access WHERE source='aurasd@gmail.com' and type = 'sender' and active = 'y' and server_id = 1
SELECT access FROM mail_access WHERE source='gmail.com' and type = 'sender' and active = 'y' and server_id = 1
SELECT access FROM mail_access WHERE source='com' and type = 'sender' and active = 'y' and server_id = 1
SELECT access FROM mail_access WHERE source='aurasd@' and type = 'sender' and active = 'y' and server_id = 1
SELECT access FROM mail_access WHERE source='auras@wip.ro' and type = 'recipient' and active = 'y' and server_id = 1
SELECT access FROM mail_access WHERE source='wip.ro' and type = 'recipient' and active = 'y' and server_id = 1
SELECT destination FROM mail_forwarding WHERE source='auras@wip.ro' and active = 'y' and server_id = 1
SELECT email FROM mail_user WHERE email='auras@wip.ro' and postfix = 'y' and server_id = 1
SELECT domain FROM mail_domain WHERE domain='gmail.com' and active = 'y' and server_id = 1
SELECT domain FROM mail_transport WHERE domain='gmail.com' and active = 'y' and server_id = 1
SELECT domain FROM mail_transport WHERE domain='com' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='aurasd@gmail.com' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='gmail.com' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='.com' and active = 'y' and server_id = 1
SELECT domain FROM mail_domain WHERE domain='wip.ro' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='auras@wip.ro' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='wip.ro' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='.ro' and active = 'y' and server_id = 1
SELECT destination FROM mail_forwarding WHERE source='auras@wip.ro' and active = 'y' and server_id = 1
SELECT email FROM mail_user WHERE email='auras@wip.ro' and postfix = 'y' and server_id = 1
SELECT domain FROM mail_domain WHERE domain='wip.ro' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='auras@wip.ro' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='wip.ro' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='.ro' and active = 'y' and server_id = 1
SELECT destination FROM mail_forwarding WHERE source='aurasd@gmail.com' and active = 'y' and server_id = 1
SELECT email FROM mail_user WHERE email='aurasd@gmail.com' and postfix = 'y' and server_id = 1
SELECT destination FROM mail_forwarding WHERE source='@gmail.com' and active = 'y' and server_id = 1
SELECT email FROM mail_user WHERE email='@gmail.com' and postfix = 'y' and server_id = 1
SELECT domain FROM mail_domain WHERE domain='gmail.com' and active = 'y' and server_id = 1
SELECT domain FROM mail_transport WHERE domain='gmail.com' and active = 'y' and server_id = 1
SELECT domain FROM mail_transport WHERE domain='com' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='aurasd@gmail.com' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='gmail.com' and active = 'y' and server_id = 1
SELECT transport FROM mail_transport WHERE domain='.com' and active = 'y' and server_id = 1
Quote:
# authtest -s smtp auras@wip.ro
Authentication succeeded.

Authenticated: auras@wip.ro (uid 5000, gid 5000)
Home Directory: /var/vmail
Maildir: /var/vmail/wip.ro/auras
Quota: 0
Encrypted Password: $1$NRkCEp@A$0EQbEfeZVGE8xFZqgc2XB1
Cleartext Password: (none)
Options: disableimap=0,disablepop3=0
Someone with centos 5.4 can please post their postfix/sasl configuration?


Aaaand yes, I found the solution:
Jan 19 14:46:41 wip postfix/trivial-rewrite[26080]: warning: do not list domain wip.ro in BOTH mydestination and virtual_mailbox_domains

Thanks all, and sorry for the fuss

Last edited by aurasdoom; 19th January 2010 at 13:59.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
email forward problem createch General 5 10th December 2008 15:14
'Salutatory Email for Clients' wrong CP and manual URL greenpete Installation/Configuration 4 23rd March 2008 20:12
Debian Sarge, ISPConfig, perfect setup followed, email can't login! Zoon Installation/Configuration 3 12th February 2006 21:58
Email Setup Question g8rbait Server Operation 4 4th December 2005 12:41
Postfix or email server setup matrich Server Operation 3 24th November 2005 23:26


All times are GMT +2. The time now is 18:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.