#1  
Old 13th January 2010, 11:44
repa2 repa2 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default Trouble with Bayes

Hi,

i installed my system with the following howto:
http://www.howtoforge.com/the-perfec...ubuntu-8.04-p5

i'm in the section BAYES to SQL conversion now, but it doesn't run...

After i run

Quote:
spamassassin -x -D -p /etc/MailScanner/spam.assassin.prefs.conf --lint

i get the follwing:
Quote:
[7643] dbg: bayes: using username: bayes
[7643] dbg: bayes: database connection established
[7643] dbg: bayes: found bayes db version 3
[7643] dbg: bayes: unable to initialize database for bayes user, aborting!
instead of

Quote:
debug: bayes: Database connection established
debug: bayes: found bayes db version 3
debug: bayes: Using userid: 2

any ideas?
Reply With Quote
Sponsored Links
  #2  
Old 13th January 2010, 13:42
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

Use sa-learn to get both spam and ham tokens into the database.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 13th January 2010, 13:55
repa2 repa2 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i ran an sa-learn --sync without error. in the database is only one entry with the version number...

is there a sample database i can import with ham and spam?
Reply With Quote
  #4  
Old 13th January 2010, 13:57
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 154 Times in 151 Posts
Default

Get the starter databases from here. http://www.fsl.com/support/
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #5  
Old 13th January 2010, 14:37
repa2 repa2 is offline
Junior Member
 
Join Date: Jan 2010
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

cool, that was it!

thank you very much man!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mailscanner SA Bayes Permissions klausengelmann Server Operation 12 15th July 2011 11:46
Postfix problem and few questions Gimly Installation/Configuration 12 7th July 2009 17:27
DNS Trouble wowwen Installation/Configuration 1 18th June 2008 19:53
Ethereal Trouble mcrosby Installation/Configuration 8 25th June 2006 04:50
Mail trouble web-worlds Installation/Configuration 15 27th January 2006 11:45


All times are GMT +2. The time now is 04:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.