Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st December 2009, 14:19
savago savago is offline
Member
 
Join Date: May 2008
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to savago
Default PHP Warning

[Mon Dec 21 15:15:47 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Dec 21 15:15:47 2009] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 21 15:15:47 2009] [notice] Digest: done
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/php_mapscript.so' - /usr/lib/php/modules/php_mapscript.so: undefined symbol: php_gd_gdImageCopy in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/pdo_dblib.so' - /usr/lib/php/modules/pdo_dblib.so: undefined symbol: php_pdo_register_driver in Unknown on line 0
[Mon Dec 21 15:15:47 2009] [notice] Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/1.0.0-fips-beta4 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations


httpd -e DEBUG
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module auth_basic_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module auth_digest_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module authn_file_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module authn_alias_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module authn_anon_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module authn_dbm_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module authn_default_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module authz_host_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module authz_user_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module authz_owner_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module authz_groupfile_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module authz_dbm_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module authz_default_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module ldap_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module authnz_ldap_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module include_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module log_config_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module logio_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module env_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module ext_filter_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module mime_magic_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module expires_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module deflate_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module headers_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module usertrack_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module setenvif_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module mime_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module dav_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module status_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module autoindex_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module info_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module dav_fs_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module vhost_alias_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module negotiation_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module dir_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module actions_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module speling_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module userdir_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module alias_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module rewrite_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module proxy_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module proxy_balancer_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module proxy_ftp_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module proxy_http_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module proxy_connect_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module cache_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module suexec_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module disk_cache_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module cgi_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module perl_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module php5_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module proxy_ajp_module
[Mon Dec 21 15:18:56 2009] [debug] mod_so.c(246): loaded module ssl_module
[Mon Dec 21 15:18:56 2009] [warn] NameVirtualHost 11.22.33.44:80 has no VirtualHosts
(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs


httpd -t
[Mon Dec 21 15:19:33 2009] [warn] NameVirtualHost 11.22.33.44:80 has no VirtualHosts
Syntax OK
Reply With Quote
Sponsored Links
  #2  
Old 22nd December 2009, 15:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Which tutorial (URL) did you use to set up this server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd December 2009, 18:03
savago savago is offline
Member
 
Join Date: May 2008
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to savago
Default

Quote:
Originally Posted by falko View Post
Which tutorial (URL) did you use to set up this server?
The Perfect Server - Fedora 12 x86_64 [ISPConfig 2]
Reply With Quote
  #4  
Old 23rd December 2009, 13:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Not sure why this is happening, but you can comment out the modules php_mapscript.so and pdo_dblib.so in your php.ini (/etc/php.ini) and restart Apache.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd December 2009, 15:14
savago savago is offline
Member
 
Join Date: May 2008
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to savago
Default

Quote:
Originally Posted by falko View Post
Not sure why this is happening, but you can comment out the modules php_mapscript.so and pdo_dblib.so in your php.ini (/etc/php.ini) and restart Apache.

There is nothing about php_mapscript.so and pdo_dblib.so in /etc/php.ini.
Reply With Quote
  #6  
Old 24th December 2009, 15:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Can you post the modules section of your php.ini?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 26th December 2009, 10:47
savago savago is offline
Member
 
Join Date: May 2008
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to savago
Default

Quote:
Originally Posted by falko View Post
Can you post the modules section of your php.ini?
Ok, This is my php.ini
Attached Files
File Type: txt php.ini.txt (67.5 KB, 273 views)

Last edited by savago; 26th December 2009 at 10:50.
Reply With Quote
  #8  
Old 26th December 2009, 22:13
alderinks alderinks is offline
Junior Member
 
Join Date: Dec 2009
Location: Indianapolis, IN
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
Default Found it!!

While surfing for the exact same problem with squirrelmail and Fedora 12 I found this post:

"Nevermind, I found the answer:
fedora has multiple .ini files that load its php extensions.
Adding the 'extension=php_mapscript.so' line to the gd.ini file in
'/etc/php.d' directory solved the problem."

This fixed my issue as well.

Hope that helps!!
Reply With Quote
The Following User Says Thank You to alderinks For This Useful Post:
falko (27th December 2009)
  #9  
Old 4th January 2010, 11:40
savago savago is offline
Member
 
Join Date: May 2008
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to savago
Default

Quote:
Originally Posted by alderinks View Post
While surfing for the exact same problem with squirrelmail and Fedora 12 I found this post:

"Nevermind, I found the answer:
fedora has multiple .ini files that load its php extensions.
Adding the 'extension=php_mapscript.so' line to the gd.ini file in
'/etc/php.d' directory solved the problem."

This fixed my issue as well.

Hope that helps!!
Not working by me.
Reply With Quote
  #10  
Old 5th January 2010, 12:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
 
Default

Did you restart Apache?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help setting up domainpop with postfix kameelperdza Installation/Configuration 6 15th June 2009 07:49
cyrus-sasl won't install on my ubuntu9.04 kameelperdza Installation/Configuration 1 13th June 2009 10:28
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
[Postfix] Quota doesn't work krzysiek HOWTO-Related Questions 8 2nd March 2009 15:57
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 11:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.