#11  
Old 23rd December 2009, 11:51
matrixn matrixn is offline
Member
 
Join Date: Jul 2008
Location: Ramnicu Valcea, Valcea, Romania
Posts: 47
Thanks: 6
Thanked 2 Times in 2 Posts
Send a message via Yahoo to matrixn
Default

i dont have a mail.log (i have opensuse 11.1)

Code:
deviantway:/var/log # ls -l | grep mail
drwxr-x--- 2 root   mail        4096 Dec 22 00:29 exim
-rw-r----- 1 root   root     1951768 Dec 23 12:50 mail
-rw-r----- 1 root   root       37533 Dec 23 12:46 mail.err
-rw-r----- 1 root   root      934972 Dec 23 12:50 mail.info
-rw-r----- 1 root   root      531364 Dec 23 12:50 mail.warn
very strange thing... i made the connection manually in thunderbird 3 and aparently the smtp is working.. but the account wizard tester from Mozilla thunderbird 3 seems is not able to connect via smtp...

here is a log from file /var/log/mail when i was sending a message via smtp with thunderbird 3

Code:
Dec 23 12:50:01 deviantway postfix/smtpd[31242]: disconnect from linux-jc1n[127.0.0.1]
Dec 23 12:53:11 deviantway postfix/smtpd[31537]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Dec 23 12:53:22 deviantway postfix/smtpd[31161]: disconnect from unknown[86.126.112.22]
Dec 23 12:53:23 deviantway postfix/anvil[30313]: statistics: max connection rate 2/60s for (smtp:86.126.112.22) at Dec 23 12:49:39
Dec 23 12:53:23 deviantway postfix/anvil[30313]: statistics: max connection count 1 for (smtp:86.126.112.22) at Dec 23 12:46:10
Dec 23 12:53:23 deviantway postfix/anvil[30313]: statistics: max cache size 3 at Dec 23 12:46:28
Dec 23 12:53:27 deviantway postfix/smtpd[31537]: warning: 86.126.112.22: hostname 86-126-112-22.rdsnet.ro verification failed: Name or service not known
Dec 23 12:53:27 deviantway postfix/smtpd[31537]: connect from unknown[86.126.112.22]
Dec 23 12:53:27 deviantway postfix/smtpd[31537]: 35F755E3F4: client=unknown[86.126.112.22], sasl_method=PLAIN, sasl_username=webmaster@deviantway.ro
Dec 23 12:53:27 deviantway postfix/cleanup[31558]: 35F755E3F4: message-id=<4B31F695.4060401@deviantway.ro>
Dec 23 12:53:27 deviantway postfix/qmgr[29021]: 35F755E3F4: from=<webmaster@deviantway.ro>, size=638998, nrcpt=1 (queue active)
Dec 23 12:53:27 deviantway postfix/smtpd[31537]: disconnect from unknown[86.126.112.22]
Dec 23 12:53:28 deviantway amavis[12812]: (12812-05) (!!)WARN: all primary virus scanners failed, considering backups
Dec 23 12:53:44 deviantway postfix/smtpd[31568]: connect from unknown[127.0.0.1]
Dec 23 12:53:44 deviantway postfix/smtpd[31568]: 687BC5E400: client=unknown[127.0.0.1]
Dec 23 12:53:44 deviantway postfix/cleanup[31558]: 687BC5E400: message-id=<4B31F695.4060401@deviantway.ro>
Dec 23 12:53:44 deviantway postfix/qmgr[29021]: 687BC5E400: from=<webmaster@deviantway.ro>, size=639440, nrcpt=1 (queue active)
Dec 23 10:53:44 deviantway postfix/smtpd[31568]: disconnect from unknown[127.0.0.1]
Dec 23 12:53:44 deviantway amavis[12812]: (12812-05) Passed CLEAN, [86.126.112.22] [86.126.112.22] <webmaster@deviantway.ro> -> <matrixn1985@yahoo.com>, Message-ID: <4B31F695.4060401@deviantway.ro>, mail_id: hMylc+4KsYTT, Hits: 0.01, size: 638998, queued_as: 687BC5E400, 16717 ms
Dec 23 12:53:44 deviantway postfix/smtp[31562]: 35F755E3F4: to=<matrixn1985@yahoo.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=17, delays=0.7/0.03/0/17, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 687BC5E400)
Dec 23 12:53:44 deviantway postfix/qmgr[29021]: 35F755E3F4: removed
the email was delivered to yahoo mailbox.. but.. it was detected as spam... any idea why?
__________________
Best regards,
Raduta Alex-Radu

Last edited by matrixn; 23rd December 2009 at 11:59.
Reply With Quote
Sponsored Links
  #12  
Old 23rd December 2009, 12:23
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
Default

Make sure that you have a correct reverse dns record for the IP address of your server. Additionally, you can add SPF records for your domain.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 23rd December 2009, 13:31
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

You can tail -f /var/log/mail then

(I'm using debian, there i have a /var/log/mail.log .. opensuse probably has a /var/log/mail)

Code:
Dec 23 12:53:27 deviantway postfix/smtpd[31537]: 35F755E3F4: client=unknown[86.126.112.22], sasl_method=PLAIN, sasl_username=webmaster@deviantway.ro
Dec 23 12:53:27 deviantway postfix/cleanup[31558]: 35F755E3F4: message-id=<4B31F695.4060401@deviantway.ro>
Dec 23 12:53:27 deviantway postfix/qmgr[29021]: 35F755E3F4: from=<webmaster@deviantway.ro>, size=638998, nrcpt=1 (queue active)
Dec 23 12:53:27 deviantway postfix/smtpd[31537]: disconnect from unknown[86.126.112.22]
Looking good!

Code:
Dec 23 12:53:28 deviantway amavis[12812]: (12812-05) (!!)WARN: all primary virus scanners failed, considering backups
Dec 23 12:53:44 deviantway postfix/smtpd[31568]: connect from unknown[127.0.0.1]
Next step is fixing your amavisd ;-)
Reply With Quote
  #14  
Old 23rd December 2009, 20:41
matrixn matrixn is offline
Member
 
Join Date: Jul 2008
Location: Ramnicu Valcea, Valcea, Romania
Posts: 47
Thanks: 6
Thanked 2 Times in 2 Posts
Send a message via Yahoo to matrixn
Default

how to fix amavisd? i don`t know anything about amavisd.. totally n00b in this section.
__________________
Best regards,
Raduta Alex-Radu
Reply With Quote
  #15  
Old 24th December 2009, 14:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Is ClamAV installed? Make sure the ClamAV section in your amavisd configuration is correct (paths, etc.).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SMTP not working: connection refused schildhans Installation/Configuration 1 9th May 2009 18:12
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Postfix issues NewMee Installation/Configuration 7 20th April 2009 18:52
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Can't seem to get SMTP AUTH working.. ralexpdx HOWTO-Related Questions 3 3rd June 2006 14:20


All times are GMT +2. The time now is 21:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.