Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Technical

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th December 2009, 23:51
nabcoengineer nabcoengineer is offline
Junior Member
 
Join Date: Mar 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Too much disk activity

I have a strange problem.
I am running Ubuntu 8.1 server as a WEB Server(php5, mysql etc) with postfix and proftp. All seems to be running smoothly until the main drive of my raid (2-250 gb IDEs, raid 1-mirror) just goes nuts with reads, I know it is reads since the secondary drive does absolutely nothing while this is happening (I did break the raid and tried it with just the secondary, same thing). The disk activity is so much that it brings the machine to its knees and I can't even reboot the thing without waiting for at least 10 minutes for the prompt. The logs seem to keep writing and I can not see any unusual logging. I have an external USB drive (250 gb) for nightly backups in a cron job but that does not seem to correspond to the problem. The only thing that even comes close to looking like it might be something is quota doing its thing but I do not have any quotas set up so I do not see how that would effect it.
The server is not too busy and as it is a 2.8 gig p4 with 2 gigs of ram running a server without even a desktop installed I would think it would handle it ok.
Any ideas. I hope so since I am going blind reading through all those logs every time it misbehaves (about once a week or so).
Thanks
Dave
Reply With Quote
Sponsored Links
  #2  
Old 15th December 2009, 11:02
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Do you have a swap file setup?

see:
Code:
top
Reply With Quote
  #3  
Old 15th December 2009, 16:40
nabcoengineer nabcoengineer is offline
Junior Member
 
Join Date: Mar 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I have the normal swap partition and I recently added a 512 mb swap file which is working.
Reply With Quote
Reply

Bookmarks

Tags
disk activity, server, ubuntu

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing Devices from Inside VPS i need help! swap-as Installation/Configuration 2 8th May 2009 15:45
Undelivered Mail Returned to Sender - Disk quota problems Mole Installation/Configuration 1 14th January 2009 19:00
chgrp error new user DKA General 15 28th July 2008 18:45
Saving data on other disk with “Virtual Hosting With PureFTPd And MySQL Ubuntu 7.10" yoyoman HOWTO-Related Questions 1 19th February 2008 07:45
SCO OpenServer Error - there are not enough disk resources ghimanshu Server Operation 1 28th July 2007 11:06


All times are GMT +2. The time now is 19:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.