Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th November 2009, 19:29
jdurand jdurand is offline
Junior Member
 
Join Date: Nov 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Porting Squirrelmail to Ubuntu 9.10

This has got to have a simple answer but so far I've got nothing...

I've had Squirrelmail running on a Ubuntu for a few years and under OS X before that. I just upgraded the server from 7.10 by installing 9.10 on a new hard disk on spare hardware, copied web, shared files and other configurations over, then moved the disk onto server hardware.

I had to edit a script (not related to squirrelmail) that didn't work under the new BASH version, but everything else except Squirrelmail works. I installed the LAMP-SERVER^ package, but when I try to access Squirrelmail I get:
ERROR: Config file "config/config.php" not found. You need to configure SquirrelMail before you can use it.

Ok, time to run configtest. I get:
Fatal error: Call to undefined function get_location() in /usr/share/squirrelmail/src/configtest.php on line 46

It would seem a module isn't loaded or properly configured, but I haven't been able to find anything. It's obviously got the right path since it found the configtest.php file.

Any ideas? I will except that I am missing something very obvious, wouldn't be the first time.
Reply With Quote
Sponsored Links
  #2  
Old 21st November 2009, 19:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Are you sure you copied all files over to the new HDD?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 21st November 2009, 21:47
jdurand jdurand is offline
Junior Member
 
Join Date: Nov 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I think so. First I installed Squirrelmail from scratch with Synaptic Package Manager and then copied over the user data files and the config files...after renaming the default files that the install put there. I would think as long as the config files are there it should work.

That's the theory, but in practice it doesn't.
Reply With Quote
  #4  
Old 25th November 2009, 02:32
jdurand jdurand is offline
Junior Member
 
Join Date: Nov 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I found the problem, it was a permissions error. Works fine now but my desk has a dent where I was bashing my head.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
"It works!" and Ubuntu 9.10 demortes Installation/Configuration 15 11th November 2009 23:36
ispconfig2 and ubuntu 9.04 respository squirrelmail bramint Installation/Configuration 1 16th July 2009 12:16
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 14:49
Virtual Users And ... And SquirrelMail (Ubuntu 8.04 LTS) WaveQam HOWTO-Related Questions 2 18th July 2008 08:28
Problem on restart bind9 satimis Server Operation 6 30th October 2007 03:01


All times are GMT +2. The time now is 18:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.