#1  
Old 19th November 2009, 00:11
centoos centoos is offline
Junior Member
 
Join Date: Nov 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mydns problem

Hi Friends:

I followed step by step the perfect setup guide on centos and ipconfig 3.
everything is working but mydns
i used the same mydns version as the tutorial

i tried to validate the server configuration using this online tool

http://www.intodns.com/agwmhosting.com but it says the dns server is down


when i restart mydns it does not throw errors. but when i ran version this is what i get

[root@centos001 ~]# mydns -v
mydns[4108]: optional 'active' column found in 'dns_soa' table
mydns[4108]: optional 'xfer' column found in 'dns_soa' table
mydns[4108]: optional 'active' column found in 'dns_rr' table
mydns[4108]: bind (TCP): 127.0.0.1:53: Address already in use


here is my ipconfig info



i have been trying to fix it myself with no luck so far
can you give some help?

thanks in advance
Reply With Quote
Sponsored Links
  #2  
Old 19th November 2009, 08:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,044
Thanks: 841
Thanked 5,661 Times in 4,468 Posts
Default

Looks as if you have another dns daemon beside mydns installed. Post the output of:

netstat -tap | grep dns

to verify if your dns server works, run this command on the shell:

dig @localhost agwmhosting.com
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 19th November 2009, 17:01
centoos centoos is offline
Junior Member
 
Join Date: Nov 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Till, this is the output of both commands


[root@centos001 ~]# netstat -tap | grep dns
tcp 0 0 centos001.agwmhostin:domain *:* LISTEN 2761/mydns
tcp 0 0 localhost.localdomai:domain *:* LISTEN 2761/mydns




[root@centos001 ~]# dig @localhost agwmhosting.com

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5 <<>> @localhost agwmhosting.com
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27555
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;agwmhosting.com. IN A

;; ANSWER SECTION:
agwmhosting.com. 86400 IN A 64.214.202.99

;; AUTHORITY SECTION:
agwmhosting.com. 86400 IN NS ns1.agwmhosting.com.
agwmhosting.com. 86400 IN NS ns2.agwmhosting.com.

;; Query time: 3 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Thu Nov 19 09:59:11 2009
;; MSG SIZE rcvd: 85
Reply With Quote
  #4  
Old 20th November 2009, 00:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Is your server the authoritative nameserver for agwmhosting.com? You can find that out by running
Code:
dig ns agwmhosting.com
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 20th November 2009, 16:39
centoos centoos is offline
Junior Member
 
Join Date: Nov 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Falko:
this is the output

[root@centos001 ~]# dig ns agwmhosting.com

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5 <<>> ns agwmhosting.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 45340
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;agwmhosting.com. IN NS

;; Query time: 137 msec
;; SERVER: 10.10.1.12#53(10.10.1.12)
;; WHEN: Fri Nov 20 09:34:03 2009
;; MSG SIZE rcvd: 33
Reply With Quote
  #6  
Old 21st November 2009, 19:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
 
Default

It seems as if there are no ns records for agwmhosting.com. Did you create ns records for agwmhosting.com?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mydns installation problem Lewis Installation/Configuration 3 29th October 2013 15:28
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 15:15
Mydns starting problem richardson Installation/Configuration 3 19th November 2009 08:29
Mydns Problem rodrigoespino Installation/Configuration 1 6th October 2009 14:37
MyDNS ? Why ? bl4ckb1rd General 24 4th April 2009 03:23


All times are GMT +2. The time now is 19:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.