Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 1st November 2009, 20:06
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Hi Falko,

thanks for your reply. I have already installed it:

Package php-pecl-imagick-2.2.1-3.el5.i386 already installed and latest version

thanks
Reply With Quote
Sponsored Links
  #12  
Old 6th November 2009, 08:08
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Question

Quote:
Originally Posted by falko View Post
What's the output of
Code:
yum search imagick
?
I have already reply it.

how can I hide the response of the execution of the php file?

Is this correct?
/usr/bin/php /var/www/web1/web/schedule.php >/dev/null

Thanks
Reply With Quote
  #13  
Old 6th November 2009, 12:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,678
Thanks: 819
Thanked 5,318 Times in 4,171 Posts
Default

Yes, thats correct. It redirects the std out to /dev/null
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #14  
Old 9th November 2009, 13:41
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Nothing to do!
Every time that the cron starts I get an email with the following strings:

Code:
PHP Warning: PHP Startup: imagick: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=0
PHP compiled with module API=20060613, debug=0, thread-safety=0
These options need to match
 in Unknown on line 0
any idea?
Reply With Quote
  #15  
Old 9th November 2009, 13:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,678
Thanks: 819
Thanked 5,318 Times in 4,171 Posts
Default

The imagick module that you have installed now is not the correct one for the php version that you use. This is a general installation problem and not related to ispconfig or the cron feature.

You should try to remove the imagick module and then install it again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 9th November 2009, 13:46
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

So, if the imagick problem will be solved the email message is not sent anymore?
Reply With Quote
  #17  
Old 9th November 2009, 13:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,678
Thanks: 819
Thanked 5,318 Times in 4,171 Posts
Default

Your linux distribution (and not ispconfig) is sending you this message as the cronjob could not be executed caused by the imagick problem. So if you solve the problem, there is no error and then there is no reason for your system to send you a email.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
mturillo (9th November 2009)
  #18  
Old 9th November 2009, 16:26
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
 
Default

Solved reinstalling the imagick packets by hand!
Thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.