Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th October 2009, 12:05
magenbrot magenbrot is offline
Junior Member
 
Join Date: May 2009
Location: Fuerth / Bavaria / Germany
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to magenbrot
Default Bug when creating very long domains

I recently registered the following domain:
14159265358979323846264338327950288419716939937510 5820974944592.de

Setting it up under sites was no problem, but if I want to add a subdomain like 3.141592653589793238462643383279502884197169399375 105820974944592.de it shows "Domain name invalid".

The regex used to check these domainnames isn't working correctly. I manually changed it, now it is working. Maybe the limit to 63 signs should be removed. I think that this limit is already clear to everybody.

regards,
Oliver
Reply With Quote
Sponsored Links
  #2  
Old 28th October 2009, 15:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Can you post the regex that you're uisng now?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th October 2009, 16:06
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,176
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

http://bugtracker.ispconfig.org/inde...ls&task_id=947
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 28th October 2009, 16:46
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,035
Thanks: 267
Thanked 153 Times in 133 Posts
Default

off topic, but you should have registered www.π.de (xn--1xa.de)
Try it.. www.π.de will showup as xn--1xa.de
Reply With Quote
  #5  
Old 28th October 2009, 18:06
magenbrot magenbrot is offline
Junior Member
 
Join Date: May 2009
Location: Fuerth / Bavaria / Germany
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to magenbrot
 
Default

Quote:
Originally Posted by falko View Post
Can you post the regex that you're uisng now?
I just extended it to 70 chars as this was enough to configure the url with ispconfig:

Code:
/^[\w\.\-]{2,70}\.[a-zA-Z]{2,10}$/
@edge: nice idea, but with the german registry DENIC not possible, see http://www.denic.de/en/faq-single/34...ash=dee610e72e
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 8th May 2009 23:00
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
ServerAlias line too long - Bug? Feature? concept Developers' Forum 3 18th September 2008 15:05
ISPConfig 2.2.14 released till General 48 19th July 2007 23:46
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48


All times are GMT +2. The time now is 19:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.