Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd October 2009, 15:12
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Question Updated to 3.0.1.6: Squirrelmail 403 Forbidden Access

Hi guys,
I am no longer able to access webmail (squirrelmail) from any of my domains:
eg. http://www.example.com/webmail

I get the custom ispconfig 403 Forbidden Page.
This just started to happen right after I updated from ISPCONFIG 3.0.1.4 to 3.0.1.6.

I have verified that the webmail Symlink still exists in /var/www/ and the apache file for squirrelmail has not changed either.

Permissions / User issue?

Does anyone have any ideas why this is happening now and what I might be able to try to get webmail working again?

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 22nd October 2009, 17:50
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,170
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

http://bugtracker.ispconfig.org/inde...ls&task_id=937

Not sure when you updated as this has fixed in ISPConfig some days ago in the version used by the ispconfig_update.sh script.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 22nd October 2009, 20:10
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Default

I updated last night by simply running 'ispconfig_update.sh' from the command line.
I updated from version 3.0.1.4 to 3.0.1.6.

It shows I'm running the latest version as well.



Should I try a manual update this time?
Reply With Quote
  #4  
Old 22nd October 2009, 20:12
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,170
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

No, not nescessary. Where exactly are the source files of squirrelmail located in your installation?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 23rd October 2009, 15:38
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Default

Quote:
Originally Posted by till View Post
No, not nescessary. Where exactly are the source files of squirrelmail located in your installation?
The squirrelmail source files are all located in:
/usr/share/webmail
Reply With Quote
  #6  
Old 23rd October 2009, 19:27
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Default

Just to add, I have tried renaming the .htaccess just to see if that was causing the problem on one of my sites but no difference.

The following symlink is also created in /var/www/
Quote:
webmail -> /usr/share/webmail/
Here is the squirrelmail vhost info:
Quote:
Alias /webmail /usr/share/webmail

<Directory /usr/share/webmail>
Options Indexes FollowSymLinks
<IfModule mod_php4.c>
php_flag register_globals off
</IfModule>
<IfModule mod_php5.c>
php_flag register_globals off
</IfModule>
<IfModule mod_dir.c>
DirectoryIndex index.php
</IfModule>

# access to configtest is limited by default to prevent information leak
<Files configtest.php>
order deny,allow
deny from all
allow from 127.0.0.1
</Files>
</Directory>
I have no idea why this update would break this.
Any ideas?

Last edited by astewart; 23rd October 2009 at 19:31.
Reply With Quote
  #7  
Old 23rd October 2009, 20:58
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Default

Here is a snip from the error.log file from one of my Domains:
Quote:
[Fri Oct 23 14:32:03 2009] [error] [client 192.168.2.5] client denied by server configuration: /usr/share/webmail/
[Fri Oct 23 15:52:51 2009] [error] [client 192.168.2.*] client denied by server configuration: /usr/share/webmail/
[Fri Oct 23 15:52:52 2009] [error] [client 192.168.2.*] client denied by server configuration: /usr/share/webmail/
[Fri Oct 23 15:52:53 2009] [error] [client 192.168.2.*] client denied by server configuration: /usr/share/webmail/
Reply With Quote
  #8  
Old 23rd October 2009, 21:23
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
 
Default

I fixed the issue!
Previously, I've always had my custom squirrelmail source code in '/usr/share/webmail' and it has always worked like this.

I verified the 'ispconfig.conf' and it shows the following:
Quote:
<Directory /usr/share/squirrelmail>
Order allow,deny
Allow from all
</Directory>
I know ISPCONFIG would over-write my changes if I modified that, so I just made a copy of the webmail directory and called it squirrelmail, reloaded apache and now everything works.

Reply With Quote
The Following User Says Thank You to astewart For This Useful Post:
falko (24th October 2009)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
yum issues el-sid Installation/Configuration 4 10th August 2011 11:01
Mac4Lin ver.0.2 - Mac OS X Leopard Transformation pack infra_red_dude Desktop Operation 77 12th September 2010 22:21
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
Postfix problem vaio1 General 4 17th October 2007 10:27
IMAP doesn't work..as i followed the Perfect Setup for Fedora 4 asokaajay Server Operation 11 10th June 2007 14:57


All times are GMT +2. The time now is 12:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.