Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 16th October 2009, 22:42
KaiserGimmel KaiserGimmel is offline
Junior Member
 
Join Date: Oct 2009
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
Default Amavis: DENIED ISPCONFIG: ACCESS from IP x.x.x.x DENIED / cant recieve emails

Hello guys,

i googled a lot and apparently i cant find a solution for my problem.
I installed ispconfig the 3rd time today (ISPConfig 3.0.1.5 and .6) - even set up my vserver again.

I did everything like in the tutorial for debian lenny - but i cant receive emails. Something is wrong with amavis:

Code:
root@torchwood:~$ tail /var/log/mail.log
Oct 16 20:23:06 torchwood postfix/smtpd[16182]: connect from moutng.kundenserver.de[212.227.17.8]
Oct 16 20:23:06 torchwood postfix/smtpd[16182]: 6D60667CA42: client=moutng.kundenserver.de[212.227.17.8]
Oct 16 20:23:06 torchwood postfix/cleanup[16189]: 6D60667CA42: message-id=<4AD8D626.1020007@sender.de>
Oct 16 20:23:06 torchwood postfix/qmgr[12030]: 6D60667CA42: from=<me@sender.de>, size=8269, nrcpt=1 (queue active)
Oct 16 20:23:06 torchwood postfix/smtpd[16182]: disconnect from moutng.kundenserver.de[212.227.17.8]
Oct 16 20:23:06 torchwood amavis[31237]: (!)DENIED ACCESS from IP 77.237.241.239, policy bank ''
Oct 16 20:23:06 torchwood postfix/smtp[16190]: 6D60667CA42: to=<max@reciever.de>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.04, delays=0.03/0.01/0/0, dsn=4.4.2, status=deferred (lost connection with 127.0.0.1[127.0.0.1] while receiving the initial server greeting)
at first i had the problem that postfix couldnt connect to the mysql because of permission problems. I fixed that after i copied the ispconfig user and added it to connect from my hostname. Im wondering what went wrong in the install.php - there was the correct hostname entered. Google said i should modify the amavis 50-user config and add an my ip there - but that didnt helped me...

In the case its related to the amavis problem:
Code:
root@torchwood:~# cat /etc/hosts
77.237.241.239  torchwood.melcher.it torchwood
127.0.0.1 localhost.localdomain localhost
Code:
root@torchwood:/home# hostname -f
torchwood.melcher.it
root@torchwood:/home# hostname
torchwood.melcher.it
what i tried:
Code:
telnet localhost 10024 => Connection closed by foreign host.
Code:
netstat -tulpn | grep 10024 => tcp        0      0 127.0.0.1:10024         0.0.0.0:*               LISTEN      30817/amavisd (mast
if i try to send an email the same happens:
Code:
Oct 16 20:35:32 torchwood postfix/smtpd[21268]: connect from ppp-93-104-79-85.dynamic.mnet-online.de[93.104.79.85]
Oct 16 20:35:32 torchwood postfix/smtpd[21268]: 810A067CA47: client=ppp-93-104-79-85.dynamic.mnet-online.de[93.104.79.85], sasl_method=PLAIN, sasl_username=max@melcher.it
Oct 16 20:35:32 torchwood postfix/cleanup[21475]: 810A067CA47: message-id=<4AD8D912.5080801@melcher.it>
Oct 16 20:35:32 torchwood postfix/qmgr[21072]: 810A067CA47: from=<max@melcher.it>, size=664, nrcpt=1 (queue active)
Oct 16 20:35:32 torchwood amavis[31240]: (!)DENIED ACCESS from IP 77.237.241.239, policy bank ''
Oct 16 20:35:32 torchwood postfix/smtp[21073]: 810A067CA47: to=<me@maxmelcher.de>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.17, delays=0.17/0/0/0, dsn=4.4.2, status=deferred (lost connection with 127.0.0.1[127.0.0.1] while receiving the initial server greeting)

Please help me - its urgent!
many thanks in advance
Max
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay access denied when using SMTP to external recipients Kamran Shah Installation/Configuration 111 14th May 2014 18:10
ISPconfig setup - DNS, router and general access problems ingvar Installation/Configuration 6 31st July 2010 13:13
MySQL5 client access to ISPConfig box vs plain centos5 pakogah Installation/Configuration 1 5th August 2008 18:47
Can Send Email, But Not Recieve; Relay access denied jazzgillum Installation/Configuration 21 31st May 2007 12:46
ERROR: The PHP binary coming with ISPConfig does not work properly on your system W1SKCC Installation/Configuration 2 2nd February 2007 13:55


All times are GMT +2. The time now is 23:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.