Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 21st March 2006, 19:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Please put

Code:
local_umask=022
chroot_local_user=YES
into /etc/vsftpd.conf and restart vsftpd:
Code:
/etc/init./vsftpd restart
Quote:
I always get this when I restart vsftpd and did some searching but really didn't see where it was a problem but I dont have enough experience yet to say it is not the problem
Code:
server1:~ # /usr/sbin/vsftpd &
500 OOPS: could not bind listening IPv4 socket
[1] 885
[1]   Exit 1                  /usr/sbin/vsftpd
server1:~ #
Better yet... is "&" Start or Restart, and what is Stop!?

(Up to now I have used Gnome but majority seems to think KDE is better so I went with it when I reloaded SuSe)
Please use the vsftpd init script in /etc/init.d to start/stop/restart vsftpd.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #22  
Old 22nd March 2006, 02:40
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
Please put

Code:
local_umask=022
chroot_local_user=YES
into /etc/vsftpd.conf and restart vsftpd:
Code:
/etc/init./vsftpd restart
Please use the vsftpd init script in /etc/init.d to start/stop/restart vsftpd.
I changed the config file as you asked. The problem is I do not have a /etc/init./vsftpd file! A search for "vsftpd" got this
Code:
file:///etc/logrotate.d/vsftpd
file:///etc/pam.d/vsftpd
file:///etc/xinetd.d/vsftpd
file:///usr/sbin/vsftpd Indicates this is an Executable file
file:///usr/share/doc/packages/vsftpd
The intersting thing is that in file:///usr/share/doc/packages/vsftpd I read that I do not need inted or xinted. There are various configs available so I selected the one I need (standalone), followed the instructions and it worked, almost. I still could not do an anonymous upload so I went back and changed the Write lines from NO to YES.
The second issue came in then, Stop, Start, and Restart are not being recognized by Konsole. This is the responses I get
Code:
server1:~ # vsftpd stop
500 OOPS: vsftpd: cannot open config file:stop
server1:~ # vsftpd start
500 OOPS: vsftpd: cannot open config file:start
server1:~ # vsftpd restart
500 OOPS: vsftpd: cannot open config file:restart
server1:~ # vsftpd &
[1] 6542
500 OOPS: could not bind listening IPv4 socket
server1:~ #
All the documentation I find points to using "&" to start the service but I am beginning to think this is not used to Stop or Restart the service. I am beginning to think that "&" is for start only and I keep getting
Code:
[B]500 OOPS: could not bind listening IPv4 socket
because it is already running and I need to restart it for changes to take effect. I have Googled myself silly trying to find "&" and what stop and restart might be but I am having no luck
Reply With Quote
  #23  
Old 22nd March 2006, 18:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

It seems your vsftpd was run by xinetd, so you should have restarted xinetd.

But now that you want to run it with an init script, you should check if /etc/init.d/vsftpd uses the correct config file (I guess it looks for /etc/vsftpd.conf instead of /etc/vsftpd/vsftpd.conf).

You can kill the running vsftpd process with

Code:
kill -9 27830
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #24  
Old 23rd March 2006, 03:26
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Thumbs up

Quote:
Originally Posted by falko
It seems your vsftpd was run by xinetd, so you should have restarted xinetd.

But now that you want to run it with an init script, you should check if /etc/init.d/vsftpd uses the correct config file (I guess it looks for /etc/vsftpd.conf instead of /etc/vsftpd/vsftpd.conf).

You can kill the running vsftpd process with

Code:
kill -9 27830
Ya Hoo! I finally got it up and running!!

It was not running in xinted (I disabled that 2 days ago) and for some reason it never existed in init.

The kill command was the key.
Code:
vsftpd &
was not stoping or restarting the service. After initial use if I changed the config file and run it again it would just return
Code:
500 OOPS: could not bind listening IPv4 socket
because it was already running.

I finally found /usr/share/doc/packages/vsftpd and there was a folder called EXAMPLES. It gives several set-ups with the config files. I used INTERNET_SITE_NOINETD, changed a couple setting to YES and that did it!

I need to figure out why commands (Start, Stop, Restart, nmap) don't seem to be working in my Konsole. Or is that a Gnome thing? I went KDE this time and while I like it better so far there are differences I am still adjusting too.

thanks for the help falco!
Reply With Quote
  #25  
Old 23rd March 2006, 09:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by latcarf
I need to figure out why commands (Start, Stop, Restart, nmap) don't seem to be working in my Konsole. Or is that a Gnome thing?
It has nothing to do with your desktop.
Maybe the init script wasn't made for SuSE. Might be worth a try to switch vsftpd back to xinetd.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #26  
Old 24th March 2006, 00:02
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
It has nothing to do with your desktop.
Maybe the init script wasn't made for SuSE.
That makes sense and is something I will research. If I find an answer I will post it here so others can will have an answer if they run into the same problem. I also had a thought last night (and it didn't even hurt!) after I posted, I have only seen "&" in the vsftpd documentation so it must be something basically exclusive to vsftpd.
Quote:
Originally Posted by falko
Might be worth a try to switch vsftpd back to xinetd.
lol! no way!! its working the way I need it now... just a simple anonymous site for people to upload and download files for fractal programs.
Reply With Quote
  #27  
Old 28th March 2006, 04:23
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
 
Default better called "vsftpd and SuSe 10"

as promised... what I learned! For some reason when the vsftpd rpm package supplied with SuSe 10 is installed it does not automatically create an init.d vsftpd script. After searching, trying, succeeding these are the steps to accomplish this on your own...

1. vim or kwrite /etc/init.d/vsftpd (we are creating this as a new file)
2. Copy and paste this into the file, then save and close:
Code:
#!/bin/sh
case "$1" in
start)
    echo "Starting vsftpd ..."
    /usr/sbin/vsftpd &
    ;;
stop)
    echo "Stopping vsftpd ..."
    killall vsftpd
    ;;
*)
    echo "Usage: 'basename $0' {start|stop}" >&2
    exit 64
    ;;
esac
exit 0
3. From terminal run:
Code:
chmod +x /etc/init.d/vsftpd
4. Open YaST, System, System Services (Runlevel).
5. Select Expert Mode.
6. Scroll down to vsftpd, highlight it and select the 3 and 5 runlevels, then Finish.
7. Restart machine, from terminal run
Code:
 ps aux | grep vsftp
You should see something to the effect of
Code:
server1:~ # ps aux | grep vsftp
root      3639  0.0  0.2   1828   536 ?        S    19:54   0:00 /usr/sbin/vsftpd
root      3642  0.0  0.1   1520   448 ?        Ss   19:54   0:00 startpar -f -- vsftpd
root      6005  0.0  0.2   1828   604 pts/1    R+   20:19   0:00 grep vsftp
server1:~ #
(note if run as user the last line will more than likely start with user name, shown as root above.)

Hope this helps others in the future.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Updating of the SUSE 9.3 system bogdinator Installation/Configuration 1 7th March 2006 14:45
Is there also a Perfect Setup for SuSE 9.1 bluegrass Installation/Configuration 7 18th January 2006 18:16
The Perfect Setup - SUSE 9.3 (firewall?!) bogdinator HOWTO-Related Questions 7 12th December 2005 13:31
Suse 9.3 - Setting up the basics (File and Print Services) creativehook Suggest HOWTO 1 16th October 2005 21:50
Upgrading from SUSE 9.3 to 10.0 dlplnx Installation/Configuration 1 6th October 2005 11:37


All times are GMT +2. The time now is 03:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.