Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 26th June 2009, 18:04
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 77
Thanks: 12
Thanked 4 Times in 4 Posts
Send a message via Skype™ to Stown
Default

Yes, it works! Thank you all.

I nano'd my /etc/httpd/conf/sites-available/eertwegh.nl.vhost first and added multiviews for the symlink location: /var/www/eertwegh.nl/web and that didnt worked.

Now i added multiviews to the second directory path what is a full path. /var/www/clients/client2/web1/web. And that worked for me!

See:

<Directory /var/www/eertwegh.nl>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost 213.163.64.99:80>
DocumentRoot /var/www/clients/client2/web1/web

ServerName eertwegh.nl
ServerAlias *.eertwegh.nl
ServerAdmin webmaster@eertwegh.nl

ErrorLog /var/log/ispconfig/httpd/eertwegh.nl/error.log

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /var/www/eertwegh.nl/web>
Options FollowSymLinks MultiViews
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client2/web1/web>
Options FollowSymLinks MultiViews
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
</Directory>

# php as cgi enabled
ScriptAlias /php5-cgi /var/www/php-cgi-scripts/web1/php-cgi-starter
Action php5-cgi /php5-cgi
AddHandler php5-cgi .php .php3 .php4 .php5
<Directory /var/www/php-cgi-scripts/web1/>
Order allow,deny
Allow from all
</Directory>


</VirtualHost>
Reply With Quote
Sponsored Links
  #12  
Old 26th June 2009, 18:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Never edit this file manually, all manual changes will be remove. Instead add your changes to the apache directives filed of the site in ISPConfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 26th June 2009, 18:13
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 77
Thanks: 12
Thanked 4 Times in 4 Posts
Send a message via Skype™ to Stown
Default

You mean this file? /usr/local/ispconfig/server/conf/vhost.conf.master
Reply With Quote
  #14  
Old 27th June 2009, 19:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

There's a field called "Apache Directives" for each web site in ISPConfig. Use this to add your custom directives - don't edit any files.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Stown (27th June 2009)
  #15  
Old 27th June 2009, 20:42
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 77
Thanks: 12
Thanked 4 Times in 4 Posts
Send a message via Skype™ to Stown
Default

i placed followed into ispconfig site configuration and it works:

<Directory /var/www/clients/client2/web1/web>
Options MultiViews All
</Directory>

This is the right structure to solve this problem?
Reply With Quote
  #16  
Old 28th June 2009, 13:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Should be ok.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 30th September 2009, 22:07
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 77
Thanks: 12
Thanked 4 Times in 4 Posts
Send a message via Skype™ to Stown
Default

Why does this solution not work anymore with the latest svn installation? I must have MultiViews on
Reply With Quote
  #18  
Old 1st October 2009, 10:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

There has nothing been changed in SVN lately. Most likely you used a wrong path in the directory staement. Take a look at the vhost file and make sure that the path you use is identical with the path of the vhost.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #19  
Old 3rd October 2009, 10:05
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 77
Thanks: 12
Thanked 4 Times in 4 Posts
Send a message via Skype™ to Stown
 
Default

EDIT: Solved! I had to chmod the web dir to 777 and then the 403 errors went away.

Look at my vhost: I've tried everything.. It loads the defaut index.php but when i go to eertwegh.nl/index/algemeen it says 403 forbidden.

<Directory /var/www/eertwegh.nl>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost 213.163.64.99:80>
DocumentRoot /var/www/clients/client1/web1/web

ServerName eertwegh.nl
ServerAlias *.eertwegh.nl
ServerAdmin webmaster@eertwegh.nl

ErrorLog /var/log/ispconfig/httpd/eertwegh.nl/error.log

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /var/www/eertwegh.nl/web>
Options FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client1/web1/web>
Options FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>

# php as cgi enabled
ScriptAlias /php5-cgi /var/www/php-cgi-scripts/web1/php-cgi-starter
Action php5-cgi /php5-cgi
AddHandler php5-cgi .php .php3 .php4 .php5
<Directory /var/www/php-cgi-scripts/web1/>
Order allow,deny
Allow from all
</Directory>


</VirtualHost>

Last edited by Stown; 4th October 2009 at 13:30.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fail2ban not working linuxwannabe Installation/Configuration 1 25th January 2009 06:09
su not working KenKnight HOWTO-Related Questions 9 17th September 2008 14:36
DNS stop working MZH General 3 22nd February 2008 11:10
1 email working, but others arent? lipp9000 Installation/Configuration 8 22nd July 2006 16:35
ftp not working pesja Installation/Configuration 3 17th July 2006 12:37


All times are GMT +2. The time now is 23:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.