Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > MyDNSConfig > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 29th September 2009, 16:46
torusturtle torusturtle is offline
Senior Member
 
Join Date: Apr 2006
Posts: 296
Thanks: 21
Thanked 24 Times in 16 Posts
Send a message via ICQ to torusturtle Send a message via AIM to torusturtle
Question MyDNSConfig does not replicate master -> slave

I installed MyDNSConfig on 2 servers.

On the second installation I entered these values:
Quote:
Select language (en,de) [en]:

Installation mode (standard,expert) [standard]: expert

Full qualified hostname (FQDN) of the server, eg server1.domain.tld [ns2.domain.tld]:

MySQL server hostname [localhost]:

MySQL root username [root]:

MySQL root password []: PASSWORD

MySQL database to create [dbmydnsconfig]:

MySQL charset [utf8]:

Shall this server join an existing MyDNSConfig multiserver setup (y,n) [n]: y

MySQL master server hostname []: ns1.domain.tld

MySQL master server root username [root]:

MySQL master server root password []: PASSWORD

MySQL master server database name [dbmydnsconfig]:

Adding MyDNSConfig server record to database.

Configure DNS Server (y,n) [y]:

Configuring MyDNS

Hint: If this server shall run the MyDNSConfig interface, select 'y' in the next option.

Configure Apache Server (y,n) [y]:

Configuring Apache
Configure Firewall Server (y,n) [y]:

Configuring Firewall
Install MyDNSConfig Web-Interface (y,n) [y]:

Installing MyDNSConfig
MyDNSConfig Port [8080]:

Installing Crontab
Restarting web server: apache2 ... waiting .
Installation completed.
I have now a working MyDNSConfig installation on the second (slave) server but the data from the master is not replicated.

/var/log/ispconfig/ispconfig.log:
Quote:
29.09.2009-17:10 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
29.09.2009-17:10 - DEBUG - No Updated records found, starting only the core.
29.09.2009-17:10 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
29.09.2009-17:11 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
29.09.2009-17:11 - DEBUG - No Updated records found, starting only the core.
29.09.2009-17:11 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
I also changed modules.inc.php like desribed in slave dns picking up on the master dns

What else do I have to configure/execute to trigger a replication?

Last edited by torusturtle; 29th September 2009 at 17:12.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
slave dns picking up on the master dns HooGLaNDeR General 17 4th January 2010 14:00
master myDNS and slave bind9 acumen Installation/Configuration 3 9th July 2009 10:20
DNS views with Master and Slave servers howto guytools Server Operation 0 24th May 2009 00:19
offsite DNS (master and slave) solution jorizzzz Tips/Tricks/Mods 1 9th March 2009 16:04
MyDNS (Master) -> Bind (Slave) Support todgerme General 4 4th September 2007 14:45


All times are GMT +2. The time now is 18:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.