Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th March 2006, 23:09
Guido64 Guido64 is offline
Junior Member
 
Join Date: Jan 2006
Location: Maastricht
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem occurs after installing postfix into a VPS

I installed this tutorial "Building A Virtual Server (VPS) With Debian 3.1 (Sarge) And OpenVZ" on a Athlon 1GHZ system with 385MB of ram.

In total i have 5 VPS systems with Bind9 in the first VPS, Apache in the second VPS, and MySQL in the thirth VPS.

Now i installed Postfix the way Falko explained in his "The Perfect Setup - Debian Sarge (3.1)" Howto into VPS number 4.

I didn't install the total howto in one VPS ofcourse just only the postfix part.
After installing i checked the /etc/postfix/main.cf and changed some parameters. When i save the main.cf WinSCP gives an error:

***
Authenticatielogboek (bekijk het sessielogboek voor meer gegevens):
Using username "root".
Authenticating with public key "***************"

Server sent disconnect message
type 2 (SSH_DISCONNECT_PROTOCOL_ERROR):
"Could not create socket pairs: Cannot allocate memory"
***

It is partly in dutch but the most important lines are the last 3 wich are in english.

I tried if google could find something about this error, just one site popped up with no solution. I really don't know where to look to fix this.

I configured WinSCP to save a session.log i could paste it in here but that might be big. Maybe somebody already knows whats wrong from seeing the WinSCP error text?

Last edited by Guido64; 26th March 2006 at 23:22.
Reply With Quote
Sponsored Links
  #2  
Old 26th March 2006, 23:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,170 Times in 4,054 Posts
Default

I have not seen the errot message yet.

In the configuration file of the vps in /etc/vz you can configure quotas, memory quotas and inode limits. Maybe you have to set them to a higher limit. A good idea might be to have a look at the OpenVZ howto too.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th March 2006, 11:41
Guido64 Guido64 is offline
Junior Member
 
Join Date: Jan 2006
Location: Maastricht
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Till,

Quote:
Originally Posted by till
I have not seen the errot message yet.

In the configuration file of the vps in /etc/vz you can configure quotas, memory quotas and inode limits. Maybe you have to set them to a higher limit. A good idea might be to have a look at the OpenVZ howto too.
I not only looked at the howto of Openvz on this site but i also used it to install openvz on my system. I also know about /etv/vz/*.conf config files. What i don't know is how to change the parameters for the better.

I also downloaded the documentation.pdf from the Openvz website and read most of it and searched inside of it for memory settings and other settings that might solve this WinSCP/SSH problem.

I wil paste the content of /proc/meminfo of the VPS 105 and i wil paste the /etc/vz/105.conf maybe you can see something that might not be right or have some suggestions i could try.

*** Start /proc/meminfo of VPS 105 ***
MemTotal: 384228 kB
MemFree: 270784 kB
Buffers: 6736 kB
Cached: 70480 kB
SwapCached: 0 kB
Active: 61748 kB
Inactive: 37180 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 384228 kB
LowFree: 270784 kB
SwapTotal: 979924 kB
SwapFree: 979924 kB
Dirty: 108 kB
Writeback: 0 kB
Mapped: 41960 kB
Slab: 10496 kB
Committed_AS: 176784 kB
PageTables: 808 kB
VmallocTotal: 630776 kB
VmallocUsed: 2256 kB
VmallocChunk: 628456 kB
*** End /proc/meminfo of VPS 105 ***

*** Start /etc/vz/105.conf ***
ONBOOT="yes"

# UBC parameters (in form of barrier:limit)
# Primary parameters
AVNUMPROC="40:40"
NUMPROC="65:65"
NUMTCPSOCK="80:80"
NUMOTHERSOCK="80:80"
VMGUARPAGES="6144:2147483647"
# Secondary parameters
KMEMSIZE="2752512:2936012"
TCPSNDBUF="319488:524288"
TCPRCVBUF="319488:524288"
OTHERSOCKBUF="132096:336896"
DGRAMRCVBUF="132096:132096"
OOMGUARPAGES="6144:2147483647"
# Auxiliary parameters
LOCKEDPAGES="32:32"
SHMPAGES="8192:8192"
PRIVVMPAGES="49152:53575"
NUMFILE="2048:2048"
NUMFLOCK="100:110"
NUMPTY="16:16"
NUMSIGINFO="256:256"
DCACHESIZE="1048576:1097728"

PHYSPAGES="0:2147483647"
NUMIPTENT="128:128"

# Disk quota parameters (in form of softlimit:hardlimit)
DISKSPACE="1048576:1153434"
# DISKINODES="200000:220000"
DISKINODES="800000:880000"
QUOTATIME="0"

# CPU fair sheduler parameter
CPUUNITS="1000"
VE_ROOT="/vz/root/$VEID"
VE_PRIVATE="/vz/private/$VEID"
OSTEMPLATE="debian-3.1-i386-minimal"
ORIGIN_SAMPLE="vps.basic"
HOSTNAME="mail2.******.lan"
IP_ADDRESS="192.168.166.9"
NAMESERVER="192.168.166.1"
*** End /etc/vz/105.conf ***

As you can see i already increased the DISKINODES number.
I'm not sure what else to change.
The memory parameters i'm not sure about if i should change them?
And in what should i change what?

The strange thing is each VPS config file gives each VPS 384mb ram while the hardware node has 384mb ram. Maybe i should change each VPS config to give each VPS 1/5 of the node ram?

Thanks in advance for looking at this.

Last edited by Guido64; 27th March 2006 at 12:00.
Reply With Quote
  #4  
Old 27th March 2006, 12:47
Guido64 Guido64 is offline
Junior Member
 
Join Date: Jan 2006
Location: Maastricht
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Update

After reading the OpenVZ-Users-Guide.pdf a little better
I needed the look into VPS 105 /proc/user_beancounters
I saw in there:

--------------------------
Version: 2.5
uid resource held maxheld barrier limit failcnt
105: kmemsize 483368 749935 2752512 2936012 0
lockedpages 0 0 32 32 0
privvmpages 1993 3359 49152 53575 0
shmpages 640 1296 8192 8192 0
dummy 0 0 0 0 0
numproc 9 16 65 65 0
physpages 922 1412 0 2147483647 0
vmguarpages 0 0 6144 2147483647 0
oomguarpages 922 1412 6144 2147483647 0
numtcpsock 3 4 80 80 0
numflock 2 3 100 110 0
numpty 0 0 16 16 0
numsiginfo 0 8 256 256 0
tcpsndbuf 2228 20052 319488 524288 0
tcprcvbuf 0 2228 319488 524288 0
othersockbuf 111400 130192 132096 336896 0
dgramrcvbuf 0 692 132096 132096 0
numothersock 77 84 80 80 25
dcachesize 104607 114696 1048576 1097728 0
numfile 215 286 2048 2048 0
dummy 0 0 0 0 0
dummy 0 0 0 0 0
dummy 0 0 0 0 0
numiptent 10 10 128 128 0
--------------------------

as you can see failcnt of numothersock is 25 so i increased numothersock from 80:80 to 160:160.
Now the Winscp/ssh error is gone.
I don't know exactly what i did but it kind of solved the problem.

Maybe Till or somebody can say something about this.
Like what to keep in mind wen adjusting the VPS config parameters as you go with setting up more VPS.

Last edited by Guido64; 27th March 2006 at 13:51.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix - MySQL connection problem epo Installation/Configuration 7 4th August 2006 20:49
problem: cannot retrieve mail from postfix cliang Server Operation 4 16th March 2006 23:38
Problem installing on CentOS 4.2 bokko Installation/Configuration 4 1st March 2006 17:14
postfix problem flourishing General 1 7th December 2005 17:39
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37


All times are GMT +2. The time now is 03:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.