#1  
Old 19th September 2009, 01:53
chicagowebdev chicagowebdev is offline
Junior Member
 
Join Date: Sep 2009
Posts: 6
Thanks: 4
Thanked 0 Times in 0 Posts
Default FTP Login problem

First I couldn't see directories, now I can't login.

I tried to reinstall pure-ftpd, but that messed it up more :P

I've check my mysql logs and there are no queries being generated.

So then I ran the update script from ispconfig's install directory, and it prompted me to reconfiguew services, which i did.

I still don't see any SQL queries being generated however.

Great software so far though, thanks for all the hard work, and how to forge is great!
Reply With Quote
Sponsored Links
  #2  
Old 19th September 2009, 02:05
chicagowebdev chicagowebdev is offline
Junior Member
 
Join Date: Sep 2009
Posts: 6
Thanks: 4
Thanked 0 Times in 0 Posts
Default

I've also just updated from SVN and it's still not letting me login or show any mysql queries.
Reply With Quote
  #3  
Old 19th September 2009, 11:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Your problem is most liekly not realted to ISPConfig, its a problem with your FTP daemon. Please post the output of:

netstat -tap | grep FTP

and check in ispconfig in the jobqueue if all jobs had been processed.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
chicagowebdev (23rd September 2009)
  #4  
Old 19th September 2009, 22:06
chicagowebdev chicagowebdev is offline
Junior Member
 
Join Date: Sep 2009
Posts: 6
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Indeed, thanks for your reply.

I got a blank screen from

Code:
netstat -tap | grep FTP
Reply With Quote
  #5  
Old 21st September 2009, 10:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Please make sure that you installed pure-ftpd as installed in the perfect setup guide for ispconfig 3 and that pure-ftpd is started.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
chicagowebdev (21st September 2009)
  #6  
Old 21st September 2009, 23:11
chicagowebdev chicagowebdev is offline
Junior Member
 
Join Date: Sep 2009
Posts: 6
Thanks: 4
Thanked 0 Times in 0 Posts
Default

The reason nothing was showing up is because of the uppercase FTP.

Below is what I see now if i change the netstat switch:
Code:
tcp        0      0 *:ftp                   *:*                     LISTEN      11394/pure-ftpd (SE
tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      11394/pure-ftpd (SE
I've installed everything according to the Pefect Server on Ubunty 9.04 w/ ISPConfig 3

Any idea why the ftp server won't connect to mysql?

All I see in mysql log is the moniter data being inserted/deleted
Reply With Quote
  #7  
Old 22nd September 2009, 11:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Please enable verbose logging in pure-ftpd and then check which error messages you get then:

http://www.faqforge.com/linux/contro...-debian-linux/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
chicagowebdev (23rd September 2009)
  #8  
Old 22nd September 2009, 21:28
chicagowebdev chicagowebdev is offline
Junior Member
 
Join Date: Sep 2009
Posts: 6
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Quote:
Sep 22 18:25:43 srvr pure-ftpd: (?@***.comcast.net) [INFO] New connection from ****.comcast.net
Sep 22 18:25:43 srvr pure-ftpd: (?@***.comcast.net) [INFO] PAM_RHOST enabled. Getting the peer address
Sep 22 18:25:45 srvr pure-ftpd: (?@***.comcast.net) [WARNING] Authentication failed for user [test]
Sep 22 18:25:51 srvr pure-ftpd: (?@***.comcast.net) [INFO] Logout.
I'm guessing it's because pure-ftp is using PAM for some reason...
Reply With Quote
  #9  
Old 23rd September 2009, 12:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

ubuntu offers more then one pure-ftpd pacakge. Please make sure that you installed the one with "mysql" in the name iand not the "normal" one which does not has mysql support.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
chicagowebdev (23rd September 2009)
  #10  
Old 23rd September 2009, 20:56
chicagowebdev chicagowebdev is offline
Junior Member
 
Join Date: Sep 2009
Posts: 6
Thanks: 4
Thanked 0 Times in 0 Posts
 
Default

YES!!!!

I removed the pure-ftpd package and installed the mysql version, and everything works!

Thanks so much!

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ftp is very slow and asks for user/passwd continuously chico58 Installation/Configuration 7 8th October 2008 13:43
Centos 5.2 FTP Problem colk Technical 4 20th August 2008 19:43
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 09:04
Perfect Setup Ubuntu Feisty Fawn 7.04 - Problem to login with IMAP and POP3 (failed) gbo HOWTO-Related Questions 3 10th April 2008 00:54
Unable to authenticate to SMTP server ashkev Installation/Configuration 15 6th February 2007 18:46


All times are GMT +2. The time now is 06:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.