Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th March 2006, 11:23
gymsmoke gymsmoke is offline
Junior Member
 
Join Date: Mar 2006
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default How To ISP Server setup with Ubuntu 5.10 (Breezy Badger)

I followed all of the steps here very carefully, save one. I went through the ispconfig installation with "standard" rather than "expert" mode. I'm hoping that this is the solution to the problem I'm having. Everything in the How To went very smoothly.
At the end. Since this is a test environment, the system has a hostname, but is setup as localhost.localdomain. After the completion of the install, I went to
"https://my_ip_address:81", and got this message (firefox 1.5)
"Could not establish an encrypted connection because certificate presented by 'my_ip_address' is invalid or corrupted. Error code: -8182 ...

Any input to this would be greatly appreciated. I'm sure I followed every step here quite carefully (with the noted exception above). This is my first server install, so I was really quite pleased with the progress I had made until this.
Reply With Quote
Sponsored Links
  #2  
Old 27th March 2006, 15:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by gymsmoke
"Could not establish an encrypted connection because certificate presented by 'my_ip_address' is invalid or corrupted. Error code: -8182 ...
You have a corrupt SSL certificate. Create a new one as outlined here: http://www.howtoforge.com/forums/sho...58&postcount=4
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 27th March 2006, 17:41
gymsmoke gymsmoke is offline
Junior Member
 
Join Date: Mar 2006
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default How To ISP Server setup with Ubuntu 5.10 (Breezy Badger)

fallko~
Thank you for the reply. That certainly helped. The keys now show up in the directory where they should have showed before (although for some reason I don't recall doing the steps you outlined as part of the how-to)...
Now, whether I use https://my_ip_address:81 or http , I get
"The connection was refused when attempting to contact my_ip_address:81"
the box is alive, and it can be ping-ed...
the logs don't have any strange entries in them, so according to the installation and setup, everything "looks" as though it went fine.

I appreciate your feedback.
Reply With Quote
  #4  
Old 27th March 2006, 17:59
gymsmoke gymsmoke is offline
Junior Member
 
Join Date: Mar 2006
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default How To ISP Server setup with Ubuntu 5.10 (Breezy Badger)

Falko~
I went back through all of my notes on the installation and found one deviation that I made - it seems relatively minor, but I'm wondering if this has anything to do with the problem of not being able to connect...
When installing ispconfig, i didn't choose "expert" mode. So, apache2 sees the doc root in /var/www , while ispconfig sees it in its default, which I believe is /home/www ...
/home/www is empty, and /var/www contains: apache2-default sharedip webalizer

Could this be the problem ?
Reply With Quote
  #5  
Old 27th March 2006, 18:11
gymsmoke gymsmoke is offline
Junior Member
 
Join Date: Mar 2006
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default How To ISP Server setup with Ubuntu 5.10 (Breezy Badger)

Falko~
ok... more good news. If I access the site by ip address (port 80), I get a directory listing as above (apache2-default sharedip webalizer). If I select apache2-default, I get the expected Apache default index.html . If I select sharedip, I get this:
"SharedIP"
This IP address is shared. For access to the web site which you look for, enter its address instead of its IP.
For questions or problems please contact the server administrator.
--------------------------------------
powered by ISPConfig

So, apparently I can see the server and at least get to the default page(s)...

It feels like a config problem to me.
Reply With Quote
  #6  
Old 28th March 2006, 08:53
Parcye Parcye is offline
Junior Member
 
Join Date: Mar 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am stuck in the same position. I have done a re-install, but still get stuck in the same position.

If I use lynx to view ispconfig on the ispconfig machine, I get want I want to see.
Reply With Quote
  #7  
Old 28th March 2006, 11:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by gymsmoke
fallko~
Thank you for the reply. That certainly helped. The keys now show up in the directory where they should have showed before (although for some reason I don't recall doing the steps you outlined as part of the how-to)...
The original certificate was generated during the ISPConfig installation. I guess you entered wrong values there.

Quote:
Originally Posted by gymsmoke
Now, whether I use https://my_ip_address:81 or http , I get
"The connection was refused when attempting to contact my_ip_address:81"
the box is alive, and it can be ping-ed...
the logs don't have any strange entries in them, so according to the installation and setup, everything "looks" as though it went fine.
Please post the output of
Code:
netstat -tap
Also make sure that no firewall blocks port 81.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 28th March 2006, 11:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by Parcye
If I use lynx to view ispconfig on the ispconfig machine, I get want I want to see.
Then I guess it's a firewall problem. Make sure your firewall doesn't block port 81.
Is your ISPConfig system inside a LAN, and you're trying to access it from the outside? Then the problem could be that some providers block port 81.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 28th March 2006, 18:40
gymsmoke gymsmoke is offline
Junior Member
 
Join Date: Mar 2006
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default How To ISP Server setup with Ubuntu 5.10 (Breezy Badger)

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost.localdo:mysql *:* LISTEN 7901/mysqld
tcp 0 0 *:ftp *:* LISTEN 14588/proftpd: (acc
tcp 0 0 216.215.55.21:domain *:* LISTEN 14574/named
tcp 0 0 localhost.locald:domain *:* LISTEN 14574/named
tcp 0 0 localhost.localdoma:953 *:* LISTEN 14574/named
tcp 0 0 *:smtp *:* LISTEN 14544/master
tcp6 0 0 *:imaps *:* LISTEN 9520/couriertcpd
tcp6 0 0 *op3s *:* LISTEN 9423/couriertcpd
tcp6 0 0 *op3 *:* LISTEN 9360/couriertcpd
tcp6 0 0 *:imap2 *:* LISTEN 9465/couriertcpd
tcp6 0 0 *:www *:* LISTEN 22114/apache2
tcp6 0 0 *:ssh *:* LISTEN 6915/sshd
tcp6 0 0 ip6-localhost:953 *:* LISTEN 14574/named
tcp6 0 0 *:https *:* LISTEN 22114/apache2
tcp6 0 352 ::ffff:216.215.55.2:ssh ::ffff:209.208.34:50709 ESTABLISHED21892/sshd: gymsmoke
Reply With Quote
  #10  
Old 28th March 2006, 20:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

ISPConfig isn't running at all. Please start it:
Code:
/etc/init.d/ispconfig_server start
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 19:26
SAMBA (Domaincontroller) Server For Small Workgroups With Ubuntu 5.10 Dagur Server Operation 15 16th February 2006 04:56
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 11:01
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 02:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.