#1  
Old 10th September 2009, 05:41
Rex Rex is offline
Junior Member
 
Join Date: Sep 2009
Posts: 24
Thanks: 2
Thanked 1 Time in 1 Post
Default Can not Install mod_ruby.

I'm install ISPConfig2 on CentOS 5.3 as instruction from howtoforge and stuck at "12.2 Installing mod_ruby" section.
http://www.howtoforge.com/perfect-se...ispconfig-2-p6


Code:
nano /etc/httpd/conf.d/ruby.conf

LoadModule ruby_module modules/mod_ruby.so
When I create ruby.conf file. httpd can not be started.
Reply With Quote
Sponsored Links
  #2  
Old 11th September 2009, 13:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Is SELinux disabled?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 16th September 2009, 05:37
Rex Rex is offline
Junior Member
 
Join Date: Sep 2009
Posts: 24
Thanks: 2
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko View Post
Is SELinux disabled?
It is me asking for help and it is me help myself.

To fix the problem edit apachelib.h inside the installation directory and add "#define OPT_INCNOEXEC 32" under #define section.

make clean
./configure.rb --with-apr-includes=/usr/include/apr-1
make
make install

It's too bad that I can't thank to myself.
Reply With Quote
The Following User Says Thank You to Rex For This Useful Post:
falko (17th September 2009)
  #4  
Old 19th September 2009, 16:32
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Rex View Post
It's too bad that I can't thank to myself.
I'll thank you. That helped me finish my install.
Reply With Quote
The Following User Says Thank You to fooboo For This Useful Post:
Rex (21st September 2009)
  #5  
Old 21st September 2009, 03:32
Rex Rex is offline
Junior Member
 
Join Date: Sep 2009
Posts: 24
Thanks: 2
Thanked 1 Time in 1 Post
 
Default

Thanks for your thank. Hope we can help each others.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 10:46
VMWare Server Free License - Invalid bardgd HOWTO-Related Questions 6 19th November 2006 17:50
install Net::DNS chrno Installation/Configuration 4 5th September 2006 17:01
Mandriva 10.2 Perfect Setup Install Problems... ctroyp Installation/Configuration 12 30th December 2005 16:04


All times are GMT +2. The time now is 06:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.