Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th March 2006, 03:34
mavgh1 mavgh1 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default problems sending mail() with php

I have a SuSE Server with a domain.ro and some subdomains.domain.ro
When I use function mail() to send emails from my domain and subdomains the From : looks like

From : www daemon apache <user@domain.ro>
From : www daemon apache <subdomain@domain.ro>

Does anyone now what changes to make to have only email address in header(I don't want to use from header in php script).
Thanks
Reply With Quote
Sponsored Links
  #2  
Old 25th March 2006, 12:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

PLease have a look here:

http://www.howtoforge.com/forums/sho...82&postcount=2
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 25th March 2006, 12:55
mavgh1 mavgh1 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default not from php script

I dont want to use php script .
Reply With Quote
  #4  
Old 25th March 2006, 13:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Quote:
Originally Posted by mavgh1
I dont want to use php script .
But your original question was "problems sending mail() with php".

Please explain what you want to do and in which programming language do you want to use the mail() function.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 25th March 2006, 19:41
mavgh1 mavgh1 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default maybe I was not very clear

I dont want to use From : in my php script
I put in php.ini sendmail_path = /usr/sbin/sendmail -t -i web@domain.ro
Or in main.conf in postfix i made a
sender_canonical_maps = hash:/etc/postfix/sender_canonical
In sender_canonical i put
wwwrun@domain.ro web@domain.ro

The result is the same the from looks like
From : www daemon apache <web@domain.ro>
I dont want to see www daemon apache only <web@domaim.ro>
Reply With Quote
  #6  
Old 26th March 2006, 03:53
mavgh1 mavgh1 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default solved

I solved my problem.Now default (without from in php script) from server configuration
From : web@domain.ro for my domain
From : user@domain.ro for my subdomains

Thanks anyway

Last edited by mavgh1; 26th March 2006 at 04:06.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 14:08
Downgrade php5 to php4.4.2 llizards Installation/Configuration 4 14th March 2006 00:58
problems sending receiving mail on Postfix mavgh1 HOWTO-Related Questions 17 10th March 2006 13:43
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 12:47
Installation Problems right after php building nagual Installation/Configuration 1 31st October 2005 09:30


All times are GMT +2. The time now is 05:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.