Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 2nd September 2009, 18:59
White White is offline
Member
 
Join Date: Apr 2008
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Im not placing any guarantee on this but i had a problem with this installation on debian etch which i cured and carried over to the perfect debian lenny install, im not using Ispconfig but i removed all instances of "proxy:" from the mysql statements in postfix/main.cf

virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf

so they look like this below and all has been fine from minute 1 of the servers life

virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailboxes.cf

but i hope you have correctly configured mail_admin and mail_admin_password in your 6 files aswell as mysql.

Have you tried to retrieve mails with Outlook? use the wizard and it will automatically test the settings and send the first email to create the users vmail folder

this is how i retrieve them and its fine

user = admin@yourdomain.com (set up in mysql mail db)
password = yourpassword (set up in mysql mail db)

POP3 = mail.mydomain.com
smtp = mail.mydomain.com

Secure Password Authentication (no)

but i have also added mydomain.com and mail.mydomain.com to my hosts file on my PC so it knows where to go inside my network

Last edited by White; 2nd September 2009 at 19:08. Reason: additional info
Reply With Quote
Sponsored Links
  #12  
Old 9th September 2009, 03:59
shayster01 shayster01 is offline
Member
 
Join Date: Jun 2007
Posts: 45
Thanks: 0
Thanked 1 Time in 1 Post
Default

White, Thanks I tried you solution but still no luck. What was it you were saying about mail_admin and mail_admin_password? I followed the directions from here http://www.howtoforge.com/perfect-se...-ispconfig3-p5 and it never mentioned anything about setting up passwords.
Reply With Quote
  #13  
Old 9th September 2009, 04:52
shayster01 shayster01 is offline
Member
 
Join Date: Jun 2007
Posts: 45
Thanks: 0
Thanked 1 Time in 1 Post
Default

Okay I am on to something. I had to change my hostname after the installation. I think I might have missed a few places. I sent an email from the server and was able to retrieve it but its from root@wronghostname.server.com instead of root@righthostname.server.com. Where is this stored on the mailserver and where can I change it? I checked /etc/courier/imapd.cnf and /etc/courier/pop3d.cnf.
Reply With Quote
  #14  
Old 9th September 2009, 05:34
shayster01 shayster01 is offline
Member
 
Join Date: Jun 2007
Posts: 45
Thanks: 0
Thanked 1 Time in 1 Post
Default

Okay I played around and re-configured postfix and changed the hostname for the mailserver. Then I logged into squirrelmail using name@hostname.server.com. Now my next question is how do you change the server so the email address is just name@server.com like most emails???

Also it seems like my emails can't be received my squirrelmail. I can see I have mail when I login by ssh but I cant get to them by squirrelmail.

Last edited by shayster01; 9th September 2009 at 05:51.
Reply With Quote
  #15  
Old 9th September 2009, 15:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by shayster01 View Post
Okay I played around and re-configured postfix and changed the hostname for the mailserver. Then I logged into squirrelmail using name@hostname.server.com. Now my next question is how do you change the server so the email address is just name@server.com like most emails???
You must set the correct sender address in your email client (e.g. SquirrelMail, Outlook, Thunderbird, etc.).

Quote:
Originally Posted by shayster01 View Post
Also it seems like my emails can't be received my squirrelmail. I can see I have mail when I login by ssh but I cant get to them by squirrelmail.
Your SquirrelMail user is not your SSH user, that's why you cannot see the mails of your SSH user.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 10th September 2009, 01:49
shayster01 shayster01 is offline
Member
 
Join Date: Jun 2007
Posts: 45
Thanks: 0
Thanked 1 Time in 1 Post
Default

Falko,

I thought it setup email accounts based on the system users? Can you explain this then.... I send an email from squirrelmail with address name@host.server.com to address name@yahoo.com. I then reply back to name@host.server.com from name@yahoo.com but I can't retrieve it in squirrelmail. But when I log into server via ssh it says I have email. When I look at it through MAIL for user name@host.server.com it shows up.
Reply With Quote
  #17  
Old 10th September 2009, 18:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

In the "Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Debian Lenny)" tutorial, we use virtual users, not system users.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 11th September 2009, 01:17
shayster01 shayster01 is offline
Member
 
Join Date: Jun 2007
Posts: 45
Thanks: 0
Thanked 1 Time in 1 Post
Default

Sorry for not understanding there just wasn't any explanation on how to create an email user or how to login to squirrelmail. I think I figured it out but i can only send emails from squirrelmail. Any ideas where to look for that. Or is that tied into the fact I have a mailbox setup in ISPconfig3 and a system user with the same name?

One more thing how exactly would I change the email address to user@server.host.com to just user@host.com?

I tried to create an email in ISPCONFIG that isnt a system user and when I login i log ing I get this:

ERROR:
ERROR: Connection dropped by IMAP server.
Query: SUBSCRIBE "INBOX.Sent"

ERROR: Could not complete request.
Query: SELECT "INBOX"
Reason Given: Unable to open this mailbox.

But I can login to the system users that I created emails for in ISPconfig.

Last edited by shayster01; 11th September 2009 at 02:23.
Reply With Quote
  #19  
Old 11th September 2009, 14:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by shayster01 View Post
but i can only send emails from squirrelmail. Any ideas where to look for that.
What errors do you get in email clients such as Outlook or Thunderbird? Any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 14th September 2009, 17:16
shayster01 shayster01 is offline
Member
 
Join Date: Jun 2007
Posts: 45
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Falko,

As I said before that is the weird thing. If I send an email from the working squirrelmail account to say a yahoo email, it works. When I send an email from the yahoo email account to my squirrelmail account. I can't view it in squirrelmail but I can see it in my ssh. Does creating a virtual email and a system email with the same name cause problems??

Also as mentioned, I created a new virtual emails in ISPconfig3 and I can't login into it in squirrelmail. this user does not exist in the system. I just get error messages:

ERROR: Could not complete request.
Query: SELECT "INBOX"
Reason Given: Unable to open this mailbox.

and

ERROR: Connection dropped by IMAP server.
Query: SUBSCRIBE "INBOX.Sent"

Last edited by shayster01; 14th September 2009 at 17:18.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Debian Lenny ttd2340 HOWTO-Related Questions 5 23rd June 2009 16:21
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Debian Lenny jony127 HOWTO-Related Questions 1 27th May 2009 17:51
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Debian Lenny warpengi HOWTO-Related Questions 2 26th May 2009 00:49
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Debian Lenny warpengi HOWTO-Related Questions 3 29th April 2009 20:18
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Debian Lenny ChristianFe HOWTO-Related Questions 2 14th April 2009 15:14


All times are GMT +2. The time now is 17:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.