Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th August 2009, 11:32
Keeper Keeper is offline
Member
 
Join Date: Aug 2009
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig3 and FCGI wrapper

Hello,

I noticed that ISPConfig creates .php-fcgi-starter in /var/.../php-fcgi-scripts/ispconfig/ and /var/.../php-fcgi-scripts/webx/ folders. There are values called PHP_FCGI_CHILDREN and export PHP_FCGI_CHILDREN which shouldn't be used.

These values are meant for standalone fcgi server, not for mod_fastcgi or mod_fcgid which handle process creation by themselves. When used with mod_fastcgi or mod_fcgid, these values cause problems.

See http://wherethebitsroam.com/blogs/je...hpfcgichildren

Am I correct in assuming that editing /usr/local/ispconfig/server/conf/php-fcgi-starter.master would make these changes default?
Edit: Apparently I am.

Edit 2: And apparently PHP_FCGI_MAX_REQUESTS should be set to 500 to prevent a probable race condition.
See: http://redmine.lighttpd.net/projects...ormanceFastCGI

Last edited by Keeper; 30th August 2009 at 18:20.
Reply With Quote
Sponsored Links
  #2  
Old 31st August 2009, 10:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,647
Thanks: 794
Thanked 5,003 Times in 3,912 Posts
Default

Thanks for the info. I will take look into this.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 31st August 2009, 11:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,647
Thanks: 794
Thanked 5,003 Times in 3,912 Posts
Default

I commented out the PHP_FCGI_MAX_REQUESTS variable in the fcgi starter script and uploaded it to svn.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 1st September 2009, 20:45
Keeper Keeper is offline
Member
 
Join Date: Aug 2009
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Actually I believe it should be PHP_FCGI_CHILDREN that should be either commented out, or set to 1. And PHP_FCGI_MAX_REQUESTS should be set to 500.

After some tinkering I noted that it is probably easier to change existing settings this way:
Go to System / Server Config / FastCGI
FastCGI Children 1
FastCGI max. Requests 500

Not sure if /php-fcgi-scripts/ispconfig/.php-fcgi-starter is used for anything, but just to be on the safe side I edited it manually afterwards. And I left the master file alone since looks like editing System / Server Config / FastCGI is better place to edit the values. Apache probably needs to be restarted to let unnecessary fcgi processes die.
Reply With Quote
  #5  
Old 2nd September 2009, 09:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,647
Thanks: 794
Thanked 5,003 Times in 3,912 Posts
 
Default

You are right, I meant the PHP_FCGI_CHILDREN variable. I commented them out instead of setting it in server config as this will fix the problem also on existing systems and this setting in server config is not needed until we offer support for e.g. lighttpd.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error with suExec + FCGI jado Installation/Configuration 6 24th April 2009 12:43


All times are GMT +2. The time now is 05:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.