Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th August 2009, 22:26
kings kings is offline
Member
 
Join Date: Aug 2009
Location: Bulgaria
Posts: 40
Thanks: 4
Thanked 0 Times in 0 Posts
Send a message via Skype™ to kings
Default Problem with .htacess and web server

I'm administrator of web and e-mail server built on a Mandriva 2009.0( 64-bit) and ISPConfig 2.2.32
On this server is hosted sites built only based on Joomla 1.5. I can’t find where is the problem with the file named (.htaccess ). WEB server with this file stops working and ignore it. At the moment it was renamed .htaccess on htaccess.txt everything goes normally. But in this case the SEO Joomla optimization is lost. Please, help me to solve this problem.
Reply With Quote
Sponsored Links
  #2  
Old 27th August 2009, 13:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Any errors in the web site's error log or the overall Apache error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 27th August 2009, 14:04
madmucho madmucho is offline
Senior Member
 
Join Date: Oct 2006
Location: Czech republic, Karlovy Vary
Posts: 158
Thanks: 81
Thanked 11 Times in 11 Posts
Send a message via ICQ to madmucho
Default directive

For joomla sites i use this Apache Directive and they works ok.

Code:
<Directory /var/www/webxx/web/>  
Options +Includes +FollowSymlinks -Indexes  
AllowOverride All  
Order allow,deny  
Allow from all  
<Files ~ "^\.ht">  
Deny from all  
</Files>  
</Directory>
Your enviroment works ok and now you have this problem? Or this problem is after ISPConfig installation?
Reply With Quote
  #4  
Old 27th August 2009, 17:41
kings kings is offline
Member
 
Join Date: Aug 2009
Location: Bulgaria
Posts: 40
Thanks: 4
Thanked 0 Times in 0 Posts
Send a message via Skype™ to kings
Default Problem with .htaccess

Quote:
Originally Posted by madmucho View Post
For joomla sites i use this Apache Directive and they works ok.

Code:
<Directory /var/www/webxx/web/>  
Options +Includes +FollowSymlinks -Indexes  
AllowOverride All  
Order allow,deny  
Allow from all  
<Files ~ "^\.ht">  
Deny from all  
</Files>  
</Directory>
Your enviroment works ok and now you have this problem? Or this problem is after ISPConfig installation?
Thank you! BUT I have new question:
Is necessary to make similar changes in remaining sections in httpd.conf such as <Directory /var/www/*/user/*/web> and <Directory /var/www/*/cgi-bin>?
Reply With Quote
  #5  
Old 27th August 2009, 21:45
madmucho madmucho is offline
Senior Member
 
Join Date: Oct 2006
Location: Czech republic, Karlovy Vary
Posts: 158
Thanks: 81
Thanked 11 Times in 11 Posts
Send a message via ICQ to madmucho
Default for all

as you want you can change global settings for vhosts to accept .htaccess directives or do it per site in ispconfig system, best practice is dont allow users .htaccess if they dont need it or dont know what that is :-) that is for security reason.

Global directive can be placed in..
Code:
/etc/httpd/conf/httpd.conf
at the end of file

Code:
<Directory /var/www/*/web>
    Options +Includes +FollowSymlinks -Indexes
    AllowOverride All
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
For Joomla that will be enough. But that is not recomended setting...
Reply With Quote
  #6  
Old 28th August 2009, 01:01
kings kings is offline
Member
 
Join Date: Aug 2009
Location: Bulgaria
Posts: 40
Thanks: 4
Thanked 0 Times in 0 Posts
Send a message via Skype™ to kings
Default Re broblem with .htaccess

Quote:
Originally Posted by madmucho View Post
as you want you can change global settings for vhosts to accept .htaccess directives or do it per site in ispconfig system, best practice is dont allow users .htaccess if they dont need it or dont know what that is :-) that is for security reason.

Global directive can be placed in..
Code:
/etc/httpd/conf/httpd.conf
at the end of file

Code:
<Directory /var/www/*/web>
    Options +Includes +FollowSymlinks -Indexes
    AllowOverride All
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
For Joomla that will be enough. But that is not recomended setting...
Special thanks!
When i make this chages in /etc/httpd/conf/httpd.conf result is FULL ZERO.Apache stoped imediately in log file - not eny trace for reason of stop. Falko sayd Quote"Any errors in the web site's error log or the overall Apache error log" end quote
When I put this <Directory /var/www/*/web>
Options +Includes +FollowSymlinks -Indexes
AllowOverride All
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>

in /etc/httpd/vhost/Vhosts_ispconfig.conf
Code:
###################################
#
# ISPConfig vHost Configuration File
# Version 1.0
#
###################################
#
NameVirtualHost 192.168.1.2:80
<VirtualHost 192.168.1.2:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
RewriteRule .* - [F]
</IfModule>
</VirtualHost>

<Directory /var/www/*/web>
Options +Includes +FollowSymlinks -Indexes
AllowOverride All
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>
#
#
######################################
# Vhost: www.example.com:80
######################################
#
#
<VirtualHost 192.168.1.2:80>
and etc code...

IT IS WORK FULL. APACHE DON"T STOP. YOU CAN TO CHANGE htaccess.txt
to .htaccess!

THANK YOU MADMUCHO
Reply With Quote
  #7  
Old 28th August 2009, 08:57
madmucho madmucho is offline
Senior Member
 
Join Date: Oct 2006
Location: Czech republic, Karlovy Vary
Posts: 158
Thanks: 81
Thanked 11 Times in 11 Posts
Send a message via ICQ to madmucho
Default

This location isnt good, this directive will be overwriten nextime when you make changes in ispconfig web managment. This vhost directives is generated.

Try put that directive at end of httpd.conf and then in console httpd -t for syntax check.
Reply With Quote
  #8  
Old 1st September 2009, 19:03
kings kings is offline
Member
 
Join Date: Aug 2009
Location: Bulgaria
Posts: 40
Thanks: 4
Thanked 0 Times in 0 Posts
Send a message via Skype™ to kings
 
Default

Quote:
Originally Posted by madmucho View Post
This location isnt good, this directive will be overwriten nextime when you make changes in ispconfig web managment. This vhost directives is generated.

Try put that directive at end of httpd.conf and then in console httpd -t for syntax check.
Ok
Thank you I put on httpd.conf
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 18:26
configuring web server , mysql server demirrt Installation/Configuration 5 27th May 2009 00:03
upgrading problem - web server can't start lexthoonen Installation/Configuration 8 15th November 2008 14:14
FTP cannot open remote folder!?! andysm849 Server Operation 23 17th October 2008 00:34
Can't start apache Musty Server Operation 12 9th March 2008 14:58


All times are GMT +2. The time now is 20:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.