Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 28th August 2009, 10:49
all all is offline
Member
 
Join Date: Jul 2009
Posts: 41
Thanks: 7
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by bajodel View Post
ISPConfig3 is different from ISPCOnfig2 .. it's normal you canot find service
[ /etc/init.d/ispconfig_server start/stop/restart ].

But take a look at your crontab ..
# crontab -l


The ISPConfig3 login page is available ?


Bye..

bajodel.
No ispconfig page available,

nmap localhost shows no 8080 port open

that means no ispconfig server running?

i am lost , i hope you will help me.

Thank you so much for your time.
Reply With Quote
Sponsored Links
  #12  
Old 28th August 2009, 10:52
bajodel bajodel is offline
Member
 
Join Date: Jul 2007
Location: Italy
Posts: 63
Thanks: 26
Thanked 12 Times in 11 Posts
Default

Quote:
Originally Posted by SamTzu View Post
I noticed the "/usr/bin/php ..[cut]..server.php" processes increasing also if u don't install squirrelmail at all ( i hate squirrelmail ) ..so i think is not related.



Bye..

bajodel.
Reply With Quote
  #13  
Old 28th August 2009, 10:55
all all is offline
Member
 
Join Date: Jul 2009
Posts: 41
Thanks: 7
Thanked 0 Times in 0 Posts
Default

root@srv1 web]# /etc/init.d/httpd start
Starting httpd: [Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost 78.47.177.89:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost .90:80 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost 90:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost 91:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost 2:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost 93:80 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost .93:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost .94:80 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost 4:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost *:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
[ OK ]
[root@srv1 web]# nmap localhost

Starting Nmap 5.00 ( http://nmap.org ) at 2009-08-28 09:51 CEST
Interesting ports on localhost (127.0.0.1):
Not shown: 987 closed ports
PORT STATE SERVICE
21/tcp open ftp
25/tcp open smtp
53/tcp open domain
80/tcp filtered http
110/tcp open pop3
143/tcp open imap
631/tcp open ipp
993/tcp open imaps
995/tcp open pop3s
3306/tcp open mysql
8080/tcp open http-proxy
10024/tcp open unknown
10025/tcp open unknown



i have hide the ip's this is what i get after starting up httpd, but as soon as i start httpd server load started increasing too much

from 0.05 to 15 in just 10 seconds
Reply With Quote
  #14  
Old 28th August 2009, 10:56
all all is offline
Member
 
Join Date: Jul 2009
Posts: 41
Thanks: 7
Thanked 0 Times in 0 Posts
Default

top - 09:55:19 up 1:20, 1 user, load average: 32.92, 18.08, 7.51
Tasks: 129 total, 1 running, 128 sleeping, 0 stopped, 0 zombie
Cpu(s): 5.3%us, 1.8%sy, 0.0%ni, 91.7%id, 0.5%wa, 0.0%hi, 0.7%si, 0.0%st
Mem: 2026544k total, 734740k used, 1291804k free, 63832k buffers


see in 20 seconds
Reply With Quote
  #15  
Old 28th August 2009, 10:59
bajodel bajodel is offline
Member
 
Join Date: Jul 2007
Location: Italy
Posts: 63
Thanks: 26
Thanked 12 Times in 11 Posts
Default

Quote:
Originally Posted by all View Post
No ispconfig page available..
If you have stopped apache2 ..it's normal you cannot see login page
So restart apache2 [ /etc/init.d/apache2 start ].

If not .. post the output of these:

# ls -sal /etc/apache2/sites-enabled/

# ls -sal /etc/apache2/sites-available/

# cat /etc/apache2/sites-available/ispconfig.vhost

(hide your private data)

Bye..

bajodel.
Reply With Quote
The Following User Says Thank You to bajodel For This Useful Post:
all (28th August 2009)
  #16  
Old 28th August 2009, 11:15
bajodel bajodel is offline
Member
 
Join Date: Jul 2007
Location: Italy
Posts: 63
Thanks: 26
Thanked 12 Times in 11 Posts
Default

Quote:
Originally Posted by all View Post
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost XX.XX.XX.XX:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost .90:80 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost 90:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost 91:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost 2:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost 93:80 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost .93:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost .94:80 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost 4:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost *:443 has no VirtualHosts
[Fri Aug 28 09:51:19 2009] [warn] NameVirtualHost *:80 has no VirtualHosts

I think something is wrong here! ..

? -> .. 91:443 ..
? -> .. 90:443 ..
..and so on..

Check your IP(s) configuration in ISPConfig ..
( i hope u are not on production env .. .. )


Bye..

bajodel.
Reply With Quote
  #17  
Old 28th August 2009, 13:44
all all is offline
Member
 
Join Date: Jul 2009
Posts: 41
Thanks: 7
Thanked 0 Times in 0 Posts
Default

Thank God it is fixed now i installed dos deflate mod.

But is there any light way on resources to ban ip's which are causing ddos?

it was ddos, now server load is stable again back to 1.00

if possible , tell me about a permanent fix

Regards
All
Reply With Quote
  #18  
Old 28th August 2009, 14:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by all View Post
But is there any light way on resources to ban ip's which are causing ddos?
http://www.howtoforge.com/forums/sho...t=route+reject
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
all (28th August 2009)
  #19  
Old 28th August 2009, 14:32
all all is offline
Member
 
Join Date: Jul 2009
Posts: 41
Thanks: 7
Thanked 0 Times in 0 Posts
 
Default

thanks falko most of the problems i am trying to fix, and with help of you guys. i did 80%


now i want to protect directory is it in ispconfig 3? where can i find, or do i have to do that manually.

Second, i am not able to setup error documents , i ticked own error pages while creating website and a folder got created in the root of website. but still

this is in error log.

[Fri Aug 28 11:01:13 2009] [error] [client 125.62.116.227] File does not exist: /var/www/error/500.html, referer: http://****/forum/
[Fri Aug 28 11:01:15 2009] [alert] [client 202.63.127.26] /var/www/****.com/web/.htaccess: Invalid command 'uthType', perhaps misspelled or defined by a module not included in the server configuration, referer: http://*****/forum/index.php
[Fri Aug 28 11:01:15 2009] [error] [client 202.63.127.26] File does not exist: /var/www/error/500.html, referer: http://****/forum/index.php
[Fri Aug 28 11:01:15 2009] [alert] [client 122.163.80.62] /var/www/8***.com/web/.htaccess: Invalid command 'uthType', perhaps misspelled or defined by a module not included in the server configuration, referer: http://****/forum/index.php
[Fri Aug 28 11:01:15 2009] [error] [client 122.163.80.62] File does not exist: /var/www/error/500.html, referer: http://****/index.php
[Fri Aug 28 11:01:16 2009] [alert] [client 112.201.124.84] /var/www/****/web/.htaccess: Invalid command 'uthType', perhaps misspelled or defined by a module not included in the server configuration, referer: http://****/forum/index.php
[Fri Aug 28 11:01:16 2009] [error] [client 112.201.124.84] File does not exist: /var/www/error/500.html, referer: *******x.php

Thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Out of memory errors pan69 General 9 13th April 2010 08:10
Problems with my 'Perfect Server' chillifire Server Operation 3 6th January 2010 13:26
Apache not starting up after installing ispconfig3 jamesls Installation/Configuration 5 11th April 2009 19:08
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 20:51
Apache stopped mccharlet General 6 15th August 2007 16:27


All times are GMT +2. The time now is 03:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.