Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th August 2009, 13:30
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 263
Thanks: 32
Thanked 6 Times in 5 Posts
Default Problem with sending mails from ISPC3 server

I run a server with Debian 5, ISPC3 and Postfix.

I have an OSCommerce installation that sends emails either by mail() or sendmail (it doesn't matter how).

The mail gets rejected by the mailservice gmx.net

here is the log:
Quote:
Aug 16 13:21:59 server2 postfix/smtp[13640]: A28214E805F: to=, relay=mx0.gmx.net[213.165.64.100]:25, delay=0.32, delays=0.01/0.01/0.11/0.2, dsn=5.1.8, status=bounced (host mx0.gmx.net[213.165.64.100] said: 550 5.1.8 Cannot resolve your domain {mx056} (in reply to MAIL FROM command))
who can please help me diagnose this problem?
Reply With Quote
Sponsored Links
  #2  
Old 16th August 2009, 15:54
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,402
Thanks: 834
Thanked 5,494 Times in 4,325 Posts
Default

Looks as if you dont have a fully qualified domain name in your postfix configuration. Check postfix main.cf and /etc/mailname that they contain a fqdn for example mail.yourserver.com and not just mx056
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 16th August 2009, 15:57
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 263
Thanks: 32
Thanked 6 Times in 5 Posts
 
Default

thank you - I rummaged everywhere on the server and saw a faulty MX entry in the DNS.
Somehow it had two trailing points instead of one.
Inexplicably, the domain was working fine inspite of faulty DNS entries.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't start apache Musty Server Operation 12 9th March 2008 13:58
mail delivered in mbox patfee Installation/Configuration 8 11th December 2007 13:58
Problem with keeping Apache alive bobeq Server Operation 3 29th November 2007 16:11
two-in-one DNS server - problem with views sPENKMAN HOWTO-Related Questions 5 20th February 2007 17:32
Problem sending mails to server from extern server Mathias Server Operation 10 29th November 2006 16:30


All times are GMT +2. The time now is 16:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.