Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 15th August 2009, 14:25
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default

the clamav update tells me to make changes to the files /etc/clamav/clamav-milter.conf and /etc/default/clamav-milter

but there are no such files.
Reply With Quote
Sponsored Links
  #12  
Old 15th August 2009, 14:39
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,201
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Quote:
Originally Posted by manarak View Post
the clamav update tells me to make changes to the files /etc/clamav/clamav-milter.conf and /etc/default/clamav-milter

but there are no such files.
There ahs nothing to be changed as milter is not installed and not used.

Is this as virtual server?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 15th August 2009, 14:41
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default

no, it is not a virtual server.
if clamav is not installed, why is it getting updated?
Reply With Quote
  #14  
Old 15th August 2009, 14:44
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,201
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

You mix up clamav and clamav milter. Clamav is installed and used but clamav milter is not used.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #15  
Old 15th August 2009, 14:45
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default

oh, sorry.
but... do you have an idea why my updates are stuck?
Reply With Quote
  #16  
Old 15th August 2009, 18:21
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default

ok, the contents of the updates have changed, and now there is more stuff that needs updating, but my server won't let me update.

I attach a screenshot of the packages apt-get wants to upgrade, as well as the list of outdated packages from ISPC.

Quote:
Reading package lists...
Building dependency tree...
Reading state information...
The following packages will be upgraded:
apache2 apache2-doc apache2-mpm-prefork apache2-suexec apache2-threaded-dev
apache2-utils apache2.2-common bind9-host clamav clamav-base clamav-daemon
clamav-docs clamav-freshclam dhcp3-client dhcp3-common dnsutils imagemagick
libapr1 libapr1-dev libaprutil1 libaprutil1-dev libbind9-40 libclamav6
libdns45 libisc45 libisccc40 libisccfg40 liblwres40 libmagick10 libopenexr6
libtiff4 libxml2 libxml2-dev linux-image-2.6.26-2-amd64 linux-libc-dev
35 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Inst linux-image-2.6.26-2-amd64 [2.6.26-17] (2.6.26-17lenny2 Debian-Security:5.0/stable)
Inst dhcp3-client [3.1.1-6] (3.1.1-6+lenny2 Debian-Security:5.0/stable) []
Inst dhcp3-common [3.1.1-6] (3.1.1-6+lenny2 Debian-Security:5.0/stable)
Inst libxml2-dev [2.6.32.dfsg-5] (2.6.32.dfsg-5+lenny1 Debian-Security:5.0/stable) []
Inst libxml2 [2.6.32.dfsg-5] (2.6.32.dfsg-5+lenny1 Debian-Security:5.0/stable)
Inst dnsutils [1:9.5.1.dfsg.P2-1+lenny1] (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable) []
Inst bind9-host [1:9.5.1.dfsg.P2-1+lenny1] (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable) []
Inst libbind9-40 [1:9.5.1.dfsg.P2-1+lenny1] (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable) []
Inst libisccfg40 [1:9.5.1.dfsg.P2-1+lenny1] (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable) []
Inst libisccc40 [1:9.5.1.dfsg.P2-1+lenny1] (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable) []
Inst libdns45 [1:9.5.1.dfsg.P2-1+lenny1] (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable) []
Inst libisc45 [1:9.5.1.dfsg.P2-1+lenny1] (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable) []
Inst liblwres40 [1:9.5.1.dfsg.P2-1+lenny1] (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable)
Inst libapr1-dev [1.2.12-5] (1.2.12-5+lenny1 Debian-Security:5.0/stable) []
Inst libapr1 [1.2.12-5] (1.2.12-5+lenny1 Debian-Security:5.0/stable)
Inst libaprutil1-dev [1.2.12+dfsg-8+lenny3] (1.2.12+dfsg-8+lenny4 Debian-Security:5.0/stable) []
Inst libaprutil1 [1.2.12+dfsg-8+lenny3] (1.2.12+dfsg-8+lenny4 Debian-Security:5.0/stable)
Inst apache2-threaded-dev [2.2.9-10+lenny3] (2.2.9-10+lenny4 Debian-Security:5.0/stable) []
Inst apache2-utils [2.2.9-10+lenny3] (2.2.9-10+lenny4 Debian-Security:5.0/stable) []
Inst apache2-mpm-prefork [2.2.9-10+lenny3] (2.2.9-10+lenny4 Debian-Security:5.0/stable) []
Inst apache2.2-common [2.2.9-10+lenny3] (2.2.9-10+lenny4 Debian-Security:5.0/stable)
Inst apache2 [2.2.9-10+lenny3] (2.2.9-10+lenny4 Debian-Security:5.0/stable)
Inst apache2-doc [2.2.9-10+lenny3] (2.2.9-10+lenny4 Debian-Security:5.0/stable)
Inst apache2-suexec [2.2.9-10+lenny3] (2.2.9-10+lenny4 Debian-Security:5.0/stable)
Inst libclamav6 [0.95.1+dfsg-1volatile2] (0.95.2+dfsg-1~volatile1 debian-volatile:stable)
Inst clamav-daemon [0.95.1+dfsg-1volatile2] (0.95.2+dfsg-1~volatile1 debian-volatile:stable) []
Inst clamav-base [0.95.1+dfsg-1volatile2] (0.95.2+dfsg-1~volatile1 debian-volatile:stable)
Inst clamav-freshclam [0.95.1+dfsg-1volatile2] (0.95.2+dfsg-1~volatile1 debian-volatile:stable)
Inst clamav [0.95.1+dfsg-1volatile2] (0.95.2+dfsg-1~volatile1 debian-volatile:stable)
Inst clamav-docs [0.95.1+dfsg-1volatile2] (0.95.2+dfsg-1~volatile1 debian-volatile:stable)
Inst libopenexr6 [1.6.1-3] (1.6.1-3+lenny3 Debian-Security:5.0/stable)
Inst libtiff4 [3.8.2-11] (3.8.2-11.2 Debian-Security:5.0/stable)
Inst libmagick10 [7:6.3.7.9.dfsg2-1~lenny1] (7:6.3.7.9.dfsg2-1~lenny3 Debian-Security:5.0/stable)
Inst imagemagick [7:6.3.7.9.dfsg2-1~lenny1] (7:6.3.7.9.dfsg2-1~lenny3 Debian-Security:5.0/stable)
Inst linux-libc-dev [2.6.26-17] (2.6.26-17lenny2 Debian-Security:5.0/stable)
Conf linux-image-2.6.26-2-amd64 (2.6.26-17lenny2 Debian-Security:5.0/stable)
Conf dhcp3-common (3.1.1-6+lenny2 Debian-Security:5.0/stable)
Conf dhcp3-client (3.1.1-6+lenny2 Debian-Security:5.0/stable)
Conf libxml2 (2.6.32.dfsg-5+lenny1 Debian-Security:5.0/stable)
Conf libxml2-dev (2.6.32.dfsg-5+lenny1 Debian-Security:5.0/stable)
Conf libisc45 (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable)
Conf libdns45 (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable)
Conf libisccc40 (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable)
Conf libisccfg40 (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable)
Conf libbind9-40 (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable)
Conf liblwres40 (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable)
Conf bind9-host (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable)
Conf dnsutils (1:9.5.1.dfsg.P3-1 Debian-Security:5.0/stable)
Conf libapr1 (1.2.12-5+lenny1 Debian-Security:5.0/stable)
Conf libapr1-dev (1.2.12-5+lenny1 Debian-Security:5.0/stable)
Conf libaprutil1 (1.2.12+dfsg-8+lenny4 Debian-Security:5.0/stable)
Conf libaprutil1-dev (1.2.12+dfsg-8+lenny4 Debian-Security:5.0/stable)
Conf apache2-utils (2.2.9-10+lenny4 Debian-Security:5.0/stable)
Conf apache2.2-common (2.2.9-10+lenny4 Debian-Security:5.0/stable)
Conf apache2-threaded-dev (2.2.9-10+lenny4 Debian-Security:5.0/stable)
Conf apache2-mpm-prefork (2.2.9-10+lenny4 Debian-Security:5.0/stable)
Conf apache2 (2.2.9-10+lenny4 Debian-Security:5.0/stable)
Conf apache2-doc (2.2.9-10+lenny4 Debian-Security:5.0/stable)
Conf apache2-suexec (2.2.9-10+lenny4 Debian-Security:5.0/stable)
Conf libclamav6 (0.95.2+dfsg-1~volatile1 debian-volatile:stable)
Conf clamav-base (0.95.2+dfsg-1~volatile1 debian-volatile:stable)
Conf clamav-freshclam (0.95.2+dfsg-1~volatile1 debian-volatile:stable)
Conf clamav-daemon (0.95.2+dfsg-1~volatile1 debian-volatile:stable)
Conf clamav (0.95.2+dfsg-1~volatile1 debian-volatile:stable)
Conf clamav-docs (0.95.2+dfsg-1~volatile1 debian-volatile:stable)
Conf libopenexr6 (1.6.1-3+lenny3 Debian-Security:5.0/stable)
Conf libtiff4 (3.8.2-11.2 Debian-Security:5.0/stable)
Conf libmagick10 (7:6.3.7.9.dfsg2-1~lenny3 Debian-Security:5.0/stable)
Conf imagemagick (7:6.3.7.9.dfsg2-1~lenny3 Debian-Security:5.0/stable)
Conf linux-libc-dev (2.6.26-17lenny2 Debian-Security:5.0/stable)
Attached Images
 
Reply With Quote
  #17  
Old 15th August 2009, 18:26
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default

what is irritating, is that it says I need to get 0B of 60.8MB of archives.

do I need to force-reinstall something?
Reply With Quote
  #18  
Old 15th August 2009, 18:33
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
 
Default

SOLVED

I didn't think of pressing Q to make the clamAV message go away.
Instead, I CTRL-C'ed my way out, effectively canceling the upgrade.

How was I supposed to know it is Q ?

Lucky I saw this post:
http://www.howtoforge.com/forums/sho...d.php?p=199211
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig3 overview...warning...updates gjcomputer Developers' Forum 10 26th January 2009 11:36
I need some advice on migrating from PHP4 to PHP5. thinktink Installation/Configuration 3 4th December 2007 20:43
Transaction error Perfect FC6 setup ACDII HOWTO-Related Questions 1 6th July 2007 14:56
updating with yum igongora Technical 2 21st May 2007 03:11
RHEL 3 Updates lawson HOWTO-Related Questions 4 22nd January 2006 06:57


All times are GMT +2. The time now is 21:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.