Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 30th July 2009, 11:17
wiewioor wiewioor is offline
Junior Member
 
Join Date: Jul 2009
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Thanks for spotting this Mark_NL!
It was right in front of my eyes! Silly mistake. Need better optics!

But anyway, it got rid off one problem just to make room for another

This time around ERROR: Connection dropped by IMAP server. comes up!

mail.log states:
Code:
[...]
Jul 30 09:45:50 serwer2slt authdaemond: modules="authmysql", daemons=5
Jul 30 09:45:50 serwer2slt authdaemond: Installing libauthmysql
Jul 30 09:45:50 serwer2slt authdaemond: Installation complete: authmysql
Jul 30 09:45:52 serwer2slt postfix/master[2797]: daemon started -- version 2.5.5, configuration /etc/postfix
Jul 30 09:47:52 serwer2slt imapd: Connection, ip=[::ffff:127.0.0.1]
Jul 30 09:47:52 serwer2slt imapd: LOGIN FAILED, user=webm2slt@serwer2slt.lan, ip=[::ffff:127.0.0.1]
Jul 30 09:47:52 serwer2slt imapd: authentication error: Input/output error
[...]
Where is this coming from? ( my keyboard and screen seem to be working just fine )

I've checked some other posts related to "dropped by IMAP server" but haven't found anything that would match my case.
Any suggestions?
Reply With Quote
Sponsored Links
  #12  
Old 30th July 2009, 12:00
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 99 Times in 95 Posts
Default

Ah we're getting closer!

Your /etc/courier/authmysqlrc is not correct ..

You've ADDED the lines specified in the how-to .. instead of replaced them (lazy ass! ;-))

they (for example) read:
MYSQL_DATABASE mail

then about 40-50 lines lower there's another line that looks pretty familiar ;-)
MYSQL_DATABASE mysql

so i'd say it overrides the previous, thus checking the wrong db .. that also counts for passwd crypt field etc ..

so do what the how-to tells you (and you probably didn't do 1on1 :P):

1. cp /etc/courier/authmysqlrc /etc/courier/authmysqlrc_orig
2. cat /dev/null > /etc/courier/authmysqlrc

Then open /etc/courier/authmysqlrc and put the following lines into it:
Code:
MYSQL_SERVER localhost
MYSQL_USERNAME webm2slt
MYSQL_PASSWORD webmaster2slt
MYSQL_PORT 0
MYSQL_DATABASE mail
MYSQL_USER_TABLE users
MYSQL_CRYPT_PWFIELD password
#MYSQL_CLEAR_PWFIELD password
MYSQL_UID_FIELD 5000
MYSQL_GID_FIELD 5000
MYSQL_LOGIN_FIELD email
MYSQL_HOME_FIELD "/home/vmail"
MYSQL_MAILDIR_FIELD CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/')
#MYSQL_NAME_FIELD
MYSQL_QUOTA_FIELD quota
and for the hell of it, restart all related services:
Code:
/etc/init.d/courier-authdaemon restart
/etc/init.d/courier-imap restart
/etc/init.d/courier-imap-ssl restart
/etc/init.d/courier-pop restart
/etc/init.d/courier-pop-ssl restart
the cool thing about the how-to's on this site, is that when you follow them EXACTLY .. in every letter, it'll always work.
If you skip / slack on one part .. you're asking for problems (UNLESS you really know what you're doing ;-))
Reply With Quote
  #13  
Old 30th July 2009, 14:07
wiewioor wiewioor is offline
Junior Member
 
Join Date: Jul 2009
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Point taken. Thanks It is a great learning curve for me.

I've re-done authmysqlrc (no ctrl+v this time ) and can now successfully login into both webm2slt@serwer2slt.lan and admin@serwer2slt.lan (made this account for testing).

But...

I can't send or receive emails on any of the accounts! The only emails present in the mailbox were ones crated using mailx during testing. Now when I send new mail it doesn't reach its recipient ( even when using mailx ).
The /home/vmail/serwer2slt.lan/webm2slt/new directory is empty.

I've found however a file in /var/mail/ called webm2slt:
Code:
From MAILER-DAEMON  Thu Jul 30 13:14:07 2009
Return-Path: <>
X-Original-To: webm2slt@serwer2slt.lan
Delivered-To: webm2slt@serwer2slt.lan
Received: by serwer2slt.lan (Postfix)
	id DDCE829691F; Thu, 30 Jul 2009 13:14:07 +0200 (CEST)
Date: Thu, 30 Jul 2009 13:14:07 +0200 (CEST)
From: MAILER-DAEMON@serwer2slt.lan (Mail Delivery System)
Subject: Undelivered Mail Returned to Sender
To: webm2slt@serwer2slt.lan
Auto-Submitted: auto-replied
MIME-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status;
	boundary="C9231296917.1248952447/serwer2slt.lan"
Content-Transfer-Encoding: 8bit
Message-Id: <20090730111407.DDCE829691F@serwer2slt.lan>

This is a MIME-encapsulated message.

--C9231296917.1248952447/serwer2slt.lan
Content-Description: Notification
Content-Type: text/plain; charset=us-ascii

This is the mail system at host serwer2slt.lan.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<admin@aerwer2slt.lan>: Host or domain name not found. Name service error for
    name=aerwer2slt.lan type=A: Host not found

--C9231296917.1248952447/serwer2slt.lan
Content-Description: Delivery report
Content-Type: message/delivery-status

Reporting-MTA: dns; serwer2slt.lan
X-Postfix-Queue-ID: C9231296917
X-Postfix-Sender: rfc822; webm2slt@serwer2slt.lan
Arrival-Date: Thu, 30 Jul 2009 13:14:06 +0200 (CEST)

Final-Recipient: rfc822; admin@aerwer2slt.lan
Original-Recipient: rfc822;admin@aerwer2slt.lan
Action: failed
Status: 5.4.4
Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error
    for name=aerwer2slt.lan type=A: Host not found

--C9231296917.1248952447/serwer2slt.lan
Content-Description: Undelivered Message
Content-Type: message/rfc822
Content-Transfer-Encoding: 8bit

Received: from serwer2slt (localhost.localdomain [127.0.0.1])
	by serwer2slt.lan (Postfix) with ESMTP id C9231296917
	for <admin@aerwer2slt.lan>; Thu, 30 Jul 2009 13:14:06 +0200 (CEST)
Received: from 192.168.5.200
        (SquirrelMail authenticated user webm2slt@serwer2slt.lan)
        by serwer2slt with HTTP;
        Thu, 30 Jul 2009 13:14:06 +0200 (CEST)
Message-ID: <fda2e61d0d1f2ce1d33082feff59656d.squirrel@serwer2slt>
Date: Thu, 30 Jul 2009 13:14:06 +0200 (CEST)
Subject: test1
From: webm2slt@serwer2slt.lan
To: admin@aerwer2slt.lan
User-Agent: SquirrelMail/1.4.15
MIME-Version: 1.0
Content-Type: text/plain;charset=iso-8859-1
Content-Transfer-Encoding: 8bit
X-Priority: 3 (Normal)
Importance: Normal

chyba nie ma polskich liter ąćżśźęńł


--C9231296917.1248952447/serwer2slt.lan--

From MAILER-DAEMON  Thu Jul 30 13:14:51 2009
Return-Path: <>
X-Original-To: webm2slt@serwer2slt.lan
Delivered-To: webm2slt@serwer2slt.lan
Received: by serwer2slt.lan (Postfix)
	id AABC0296920; Thu, 30 Jul 2009 13:14:51 +0200 (CEST)
Date: Thu, 30 Jul 2009 13:14:51 +0200 (CEST)
From: MAILER-DAEMON@serwer2slt.lan (Mail Delivery System)
Subject: Undelivered Mail Returned to Sender
To: webm2slt@serwer2slt.lan
Auto-Submitted: auto-replied
MIME-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status;
	boundary="9C64F29691A.1248952491/serwer2slt.lan"
Content-Transfer-Encoding: 8bit
Message-Id: <20090730111451.AABC0296920@serwer2slt.lan>

This is a MIME-encapsulated message.

--9C64F29691A.1248952491/serwer2slt.lan
Content-Description: Notification
Content-Type: text/plain; charset=us-ascii

This is the mail system at host serwer2slt.lan.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<admin@serwer2slt.lan>: unknown user: "admin"

--9C64F29691A.1248952491/serwer2slt.lan
Content-Description: Delivery report
Content-Type: message/delivery-status

Reporting-MTA: dns; serwer2slt.lan
X-Postfix-Queue-ID: 9C64F29691A
X-Postfix-Sender: rfc822; webm2slt@serwer2slt.lan
Arrival-Date: Thu, 30 Jul 2009 13:14:51 +0200 (CEST)

Final-Recipient: rfc822; admin@serwer2slt.lan
Original-Recipient: rfc822;admin@serwer2slt.lan
Action: failed
Status: 5.1.1
Diagnostic-Code: X-Postfix; unknown user: "admin"

--9C64F29691A.1248952491/serwer2slt.lan
Content-Description: Undelivered Message
Content-Type: message/rfc822
Content-Transfer-Encoding: 8bit

Received: from serwer2slt (localhost.localdomain [127.0.0.1])
	by serwer2slt.lan (Postfix) with ESMTP id 9C64F29691A
	for <admin@serwer2slt.lan>; Thu, 30 Jul 2009 13:14:51 +0200 (CEST)
Received: from 192.168.5.200
        (SquirrelMail authenticated user webm2slt@serwer2slt.lan)
        by serwer2slt with HTTP;
        Thu, 30 Jul 2009 13:14:51 +0200 (CEST)
Message-ID: <ca5207327aa40eaa5127ec22542943f6.squirrel@serwer2slt>
Date: Thu, 30 Jul 2009 13:14:51 +0200 (CEST)
Subject: test1
From: webm2slt@serwer2slt.lan
To: admin@serwer2slt.lan
User-Agent: SquirrelMail/1.4.15
MIME-Version: 1.0
Content-Type: text/plain;charset=iso-8859-1
Content-Transfer-Encoding: 8bit
X-Priority: 3 (Normal)
Importance: Normal

Nie ma polskich liter? ążśćźęńł


--9C64F29691A.1248952491/serwer2slt.lan--

From admin@serwer2slt.lan  Thu Jul 30 13:16:10 2009
Return-Path: <admin@serwer2slt.lan>
X-Original-To: webm2slt@serwer2slt.lan
Delivered-To: webm2slt@serwer2slt.lan
Received: from serwer2slt (localhost.localdomain [127.0.0.1])
	by serwer2slt.lan (Postfix) with ESMTP id C9CBD296920
	for <webm2slt@serwer2slt.lan>; Thu, 30 Jul 2009 13:16:10 +0200 (CEST)
Received: from 192.168.5.200
        (SquirrelMail authenticated user admin@serwer2slt.lan)
        by serwer2slt with HTTP;
        Thu, 30 Jul 2009 13:16:10 +0200 (CEST)
Message-ID: <9f4a2065626110f451c59289fe1ea383.squirrel@serwer2slt>
Date: Thu, 30 Jul 2009 13:16:10 +0200 (CEST)
Subject: test4
From: admin@serwer2slt.lan
To: webm2slt@serwer2slt.lan
User-Agent: SquirrelMail/1.4.15
MIME-Version: 1.0
Content-Type: text/plain;charset=iso-8859-1
Content-Transfer-Encoding: 8bit
X-Priority: 3 (Normal)
Importance: Normal

chyba coś nie działa?

From webm2slt@serwer2slt.lan  Thu Jul 30 13:25:40 2009
Return-Path: <webm2slt@serwer2slt.lan>
X-Original-To: webm2slt@serwer2slt.lan
Delivered-To: webm2slt@serwer2slt.lan
Received: from serwer2slt (localhost.localdomain [127.0.0.1])
	by serwer2slt.lan (Postfix) with ESMTP id 7ADED296920
	for <webm2slt@serwer2slt.lan>; Thu, 30 Jul 2009 13:25:40 +0200 (CEST)
Received: from 192.168.5.200
        (SquirrelMail authenticated user webm2slt@serwer2slt.lan)
        by serwer2slt with HTTP;
        Thu, 30 Jul 2009 13:25:40 +0200 (CEST)
Message-ID: <918d3248f64c4838401dd5e51c7818ac.squirrel@serwer2slt>
Date: Thu, 30 Jul 2009 13:25:40 +0200 (CEST)
Subject: test5
From: webm2slt@serwer2slt.lan
To: webm2slt@serwer2slt.lan
User-Agent: SquirrelMail/1.4.15
MIME-Version: 1.0
Content-Type: text/plain;charset=iso-8859-2
Content-Transfer-Encoding: 8bit
X-Priority: 3 (Normal)
Importance: Normal

chyba nie dochopdzi

From root@serwer2slt.lan  Thu Jul 30 13:32:56 2009
Return-Path: <root@serwer2slt.lan>
X-Original-To: webm2slt@serwer2slt.lan
Delivered-To: webm2slt@serwer2slt.lan
Received: by serwer2slt.lan (Postfix, from userid 0)
	id 65697296921; Thu, 30 Jul 2009 13:32:56 +0200 (CEST)
To: webm2slt@serwer2slt.lan
Subject: test6
Message-Id: <20090730113256.65697296921@serwer2slt.lan>
Date: Thu, 30 Jul 2009 13:32:56 +0200 (CEST)
From: root@serwer2slt.lan (root)

jakaĹ tam treĹć

From root@serwer2slt.lan  Thu Jul 30 13:41:28 2009
Return-Path: <root@serwer2slt.lan>
X-Original-To: webm2slt@serwer2slt.lan
Delivered-To: webm2slt@serwer2slt.lan
Received: by serwer2slt.lan (Postfix, from userid 0)
	id CB504296921; Thu, 30 Jul 2009 13:41:28 +0200 (CEST)
To: webm2slt@serwer2slt.lan
Subject: tetst test
Message-Id: <20090730114128.CB504296921@serwer2slt.lan>
Date: Thu, 30 Jul 2009 13:41:28 +0200 (CEST)
From: root@serwer2slt.lan (root)

moĹźe to w koĹcu zacznie dzialać?!
I've also found this in my mail.log:
Code:
Jul 30 13:41:28 serwer2slt postfix/trivial-rewrite[3861]: warning: do not list domain serwer2slt.lan in BOTH mydestination and virtual_mailbox_domains
but in main.cf i have this:
Code:
[...]
mydestination = serwer2slt.lan, localhost, localhost.localdomain
[...]
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
[...]
so I guess it is all right.

I know it is a pain but what might be wrong?

Are there any steps I have to take in order to re-do this HowTo (ie. anything I should remove/uninstall first)?

BIG Thanks for putting up with me.
Reply With Quote
  #14  
Old 30th July 2009, 14:18
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 99 Times in 95 Posts
Default

Code:
<admin@aerwer2slt.lan>: Host or domain name not found. Name service error for
    name=aerwer2slt.lan type=A: Host not found
stop making typo's :P
Reply With Quote
  #15  
Old 31st July 2009, 09:21
wiewioor wiewioor is offline
Junior Member
 
Join Date: Jul 2009
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I've noticed that typo and sent email to the right user straight after that. Same result.

Code:
Content-Description: Delivery report
Content-Type: message/delivery-status

Reporting-MTA: dns; serwer2slt.lan
X-Postfix-Queue-ID: 9C64F29691A
X-Postfix-Sender: rfc822; webm2slt@serwer2slt.lan
Arrival-Date: Thu, 30 Jul 2009 13:14:51 +0200 (CEST)

Final-Recipient: rfc822; admin@serwer2slt.lan
Original-Recipient: rfc822;admin@serwer2slt.lan
Action: failed
Status: 5.1.1
Diagnostic-Code: X-Postfix; unknown user: "admin"
What do you think aboaut the last line?
Reply With Quote
  #16  
Old 31st July 2009, 09:46
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 99 Times in 95 Posts
Default

pretty clear eh

Diagnostic-Code: X-Postfix; unknown user: "admin"

there is no user "admin" or an alias "admin" that points to an existing user
Reply With Quote
  #17  
Old 31st July 2009, 10:25
wiewioor wiewioor is offline
Junior Member
 
Join Date: Jul 2009
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Well yes but why is Postfix looking for 'admin' instead of 'admin@serwer2slt.lan'?

This is getting way over my head!

Think I will start it all over on monday. Anything I should do (uninstall/remove) before so that I don't mix up old (failed!) setup with the new one?
Reply With Quote
  #18  
Old 31st July 2009, 11:03
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 99 Times in 95 Posts
 
Default

It's looking for admin, because that is the user you're sending the email to!

user@domain.tld
Reply With Quote
Reply

Bookmarks

Tags
login error, squirrelmail, virtual users

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 14:42
Problem installing ISPConfig on Suse10.1 nliebherr Installation/Configuration 18 14th September 2007 00:30
ADSL PCI Modems alexillsley Server Operation 5 9th May 2007 19:32
Relay access denied brainz Installation/Configuration 27 8th March 2007 08:21
Error on install igbe Installation/Configuration 7 28th February 2007 22:55


All times are GMT +2. The time now is 18:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.