Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd July 2009, 20:33
gjcomputer gjcomputer is offline
Member
 
Join Date: Jan 2006
Location: missouri, USA
Posts: 91
Thanks: 15
Thanked 2 Times in 2 Posts
Default CLAM AV upgrade failed (nothing will apt-get upgrade)

debian 5.0.1, running ispconfig 3, apt-get upgrade pulls this...
Code:
clamav (0.95.2+dfsg-1~volatile1) unstable; urgency=low

  This release of clamav-milter requires you to amend your configuration.
  It's against the Debian volatile policy, but due to upstream changes, we
  decided that it was the best way forward, rather than maintaining an
  outdated version.

  Here is a summary of the required changes:

  * clamav-milter configuration has been moved from
    command-line options to the file /etc/clamav/clamav-milter.conf. The
    following is a map of commonly used options:

      -l                LocalNet
      -o                No longer needed/supported
      -q                No longer needed/supported
      --noreject        OnInfected (Blackhole|Accept|Quarantine)
      --dont-wait       No longer needed/supported
      --max-children    No longer needed/supported

  * While at it, /etc/default/clamav-milter was reworked. If you've previously
    set $USE_POSTFIX in that file, please make sure to set the new option
    SOCKET_RWGROUP=postfix now.

    Also, ensure that the MilterSocket setting in
    /etc/clamav/clamav-milter.conf includes /var/spool/postfix, if you are
    using a chroot'ed smtpd instance (which is the default).

 -- martin f. krafft <madduck@debian.org>  Mon, 15 Jun 2009 08:20:10 +0200
i then have to break the upgrade and nothing is changed, any ideas?
__________________
6r36.com
Reply With Quote
Sponsored Links
  #2  
Old 23rd July 2009, 13:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,716 Times in 2,558 Posts
Default

On ISPConfig 3 systems, ClamAV is invoked by amavisd, not clamav-milter, so you can ignore this message.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 23rd July 2009, 14:47
gjcomputer gjcomputer is offline
Member
 
Join Date: Jan 2006
Location: missouri, USA
Posts: 91
Thanks: 15
Thanked 2 Times in 2 Posts
Default

understandable, but i have the break the operation, and that kills the upgrade, how can i run the upgrade without upgrading the clam?
__________________
6r36.com
Reply With Quote
  #4  
Old 24th July 2009, 23:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,716 Times in 2,558 Posts
Default

Is there no option to accept what apt proposes?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 25th July 2009, 16:10
lano lano is offline
Member
 
Join Date: May 2007
Posts: 94
Thanks: 10
Thanked 8 Times in 7 Posts
 
Default

Quote:
Originally Posted by gjcomputer View Post
debian 5.0.1, running ispconfig 3, apt-get upgrade pulls this...
Code:
clamav (0.95.2+dfsg-1~volatile1) unstable; urgency=low

  This release of clamav-milter requires you to amend your configuration.
  It's against the Debian volatile policy, but due to upstream changes, we
  decided that it was the best way forward, rather than maintaining an
  outdated version.

  Here is a summary of the required changes:

  * clamav-milter configuration has been moved from
    command-line options to the file /etc/clamav/clamav-milter.conf. The
    following is a map of commonly used options:

      -l                LocalNet
      -o                No longer needed/supported
      -q                No longer needed/supported
      --noreject        OnInfected (Blackhole|Accept|Quarantine)
      --dont-wait       No longer needed/supported
      --max-children    No longer needed/supported

  * While at it, /etc/default/clamav-milter was reworked. If you've previously
    set $USE_POSTFIX in that file, please make sure to set the new option
    SOCKET_RWGROUP=postfix now.

    Also, ensure that the MilterSocket setting in
    /etc/clamav/clamav-milter.conf includes /var/spool/postfix, if you are
    using a chroot'ed smtpd instance (which is the default).

 -- martin f. krafft <madduck@debian.org>  Mon, 15 Jun 2009 08:20:10 +0200
i then have to break the upgrade and nothing is changed, any ideas?
Just press "q" , and it should proceed with upgrade.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is my postfix is hacked? bzzik Server Operation 21 15th July 2009 14:13
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
Anyone figured out to integrate FuzzyOCR into ISPConfig on Ubuntu? friday Installation/Configuration 16 10th May 2007 16:25
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40


All times are GMT +2. The time now is 03:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.