#1  
Old 11th June 2009, 13:06
pat pat is offline
Junior Member
 
Join Date: Jan 2009
Posts: 9
Thanks: 2
Thanked 3 Times in 2 Posts
Default Webalizer incremental parsing

I have an ISPConfig 3.0.1.3 on Debian Lenny (perfect setup) and just realized that webalizer stats only showed 24 hours worth of data at any given time.

By looking in /usr/local/ispconfig/server/cron_daily.php I came to the conclusion that only the last archived log file is being parsed and the default setting in /etc/wealizer/webalizer.conf for Lenny is to not run in incremental mode (not saving state between runs).

I began by turning on incremental mode in /etc/webalizer/webalizer.conf

I then cleared the stats dir (apart from .htaccess), merged all logfiles into one and ran webalizer manually with the same flags as found in /usr/local/ispconfig/server/cron_daily.php with the exception of the path of the logfile, for which I used my manually merged log file.

I suppose adding the -p flag to the webalizer invocation in cron_daily.php would have been the better solution, but I would rather have my ISPConfig as vanilla as possible.

Cheers,
Pat
Reply With Quote
Sponsored Links
  #2  
Old 11th June 2009, 19:47
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,745
Thanks: 840
Thanked 5,598 Times in 4,409 Posts
Default

Just enable incremental parsing in /etc/webalizer/webalizer.conf, there is nothing else to do.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 11th June 2009, 21:52
pat pat is offline
Junior Member
 
Join Date: Jan 2009
Posts: 9
Thanks: 2
Thanked 3 Times in 2 Posts
Default

Perhaps it would be nice if it worked out of the box instead of having every user figuring out this for themselves. What is the benefit of not using the -p flag with webalizer?

Cheers,
Pat
Reply With Quote
  #4  
Old 12th June 2009, 09:34
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,745
Thanks: 840
Thanked 5,598 Times in 4,409 Posts
Default

The latest ISPConfig versions are configuring that automatically in wevalizer conf, so there is no need to add any flags.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
pat (12th June 2009)
  #5  
Old 12th June 2009, 12:06
pat pat is offline
Junior Member
 
Join Date: Jan 2009
Posts: 9
Thanks: 2
Thanked 3 Times in 2 Posts
Default

Actually, it is not handled automatically, but I saw that it is part of the manual installation instructions in the docs since May 23. That should teach me to read the docs instead of using outdated install guides from some dubious forum on the interweb (nudge-nudge Falco)

Last edited by pat; 12th June 2009 at 12:08.
Reply With Quote
  #6  
Old 24th July 2009, 05:03
asticot asticot is offline
Junior Member
 
Join Date: Jul 2009
Posts: 10
Thanks: 1
Thanked 3 Times in 3 Posts
 
Default incremental webalizer quite not working

Hi,

I set a week ago the incremental webalizer tag to yes and it's working quite fine.

The only problem is that now, when I looked at webalizer report, for all my websites, the hour statistics show me that all log between 1 and 2 hours have been ignored.

For ie:

0 57 289 2,39% 54 270 2,63% 22 112 2,22% 408 2042 2,27% 23 113 2,39% 427 2137 2,32%

1 0 0 0,00% 0 0 0,00% 0 0 0,00% 0 0 0,00% 0 0 0,00% 0 0 0,00%

2 113 569 4,71% 82 411 4,00% 43 218 4,33% 566 2832 3,15% 30 152 3,20% 447 2235 2,42%

Am I the only one who have this problem ?

Sincerely
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
missing webalizer stats bolero Installation/Configuration 15 12th November 2008 17:28
Incremental Webalizer Logs on ISPConfig antun Installation/Configuration 3 21st February 2008 18:46
Howto: Make Webalizer show full QueryString!! Zoon Tips/Tricks/Mods 1 5th November 2007 03:12
Apache2 Freezes celtic Server Operation 31 28th May 2007 18:18
Webalizer problem MacPC Server Operation 3 15th May 2007 14:53


All times are GMT +2. The time now is 11:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.