Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th July 2009, 11:54
p.a p.a is offline
Junior Member
 
Join Date: Jul 2008
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default How to create a website test.example.com

Hello,

Previously I used ISPConfig 2.
I just installed the new version (ISPConfig 3.0.1.3 on OpenSuse 11.1) and I am kind of lost.

I use ISPConfig as an internal webserver.
With ISPConfig 2 resellers created sites with domain example.com and host as the site's name : for example test --> test.example.com. They just had to tick create DNS and it was ok.

I'd just like to do this with ISPConfig 3 but as I only see site domain name when I create a site I can't.

Do you know how i should proceed ?
Reply With Quote
Sponsored Links
  #2  
Old 16th July 2009, 12:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Your resellers can create DNS Records in the dns manager module. The website module is not conected with the dns manager, so it doies not craete dns records when you add a website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 16th July 2009, 14:53
p.a p.a is offline
Junior Member
 
Join Date: Jul 2008
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok thanks. I just added an a record for the website test

When I go to test.example.com I get an error 403.

I think I have a bigger problem.
I can't access the website I just created, I don't have a /srv/www/clients directory and I don't see any website symlinks in /srv/www
Maybe my ISPConfig is not well loaded but I can't find the script to restart it.

ISPConfig 3 beginner needs help.
Reply With Quote
  #4  
Old 17th July 2009, 11:21
p.a p.a is offline
Junior Member
 
Join Date: Jul 2008
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello again,

Hope my questions are not too weird.
I just can't create a website. I go to site - Add new website - Save
Then when I go to /srv/www I don't see any new directory. I tried to look at the log but can't see any error.

I'd like to reinstall ISPConfig 3.0.1.3 : what script should I use (uninstall.php than install.php or update.php)

Thanks in advance
Reply With Quote
  #5  
Old 17th July 2009, 13:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

What's the output of
Code:
crontab -l
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 17th July 2009, 14:47
p.a p.a is offline
Junior Member
 
Join Date: Jul 2008
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I just ran the update script :
cd ispconfig3_install/install/
php -q update.php

And now all seems to be working !

I have my client directories, I can create sites and I can also see monitoring information correctly on the ISPConfig control panel.

I will test a bit more to see if all is ok.

Don't know what happened during the installation I didn't notice errors.

Thanks for the reply and thanks for your great job with ISPConfig.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Where do I create a website for a client? Doomster General 1 21st October 2008 08:30
Don't create stats folder when create a website quannv Server Operation 3 12th July 2008 12:36
Chroot SSH + ISPConfig Norman Installation/Configuration 27 26th March 2007 04:40
cannot create website guidovanh Installation/Configuration 1 5th March 2007 01:27
Verify email setup meekish Installation/Configuration 28 27th October 2006 16:36


All times are GMT +2. The time now is 09:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.