Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 14th July 2009, 22:44
AlyK AlyK is offline
Junior Member
 
Join Date: Jan 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual User CentOS Postfix & Courier w/ mailstore on SMB Share(NAS) fetch failure...

Sorry This is re-post. I would really appreciate some assistance. I didn't get to many replies and this project was put on the back burner - its now back on my plate. I have make all sorts of adjustments to the fstab mount line so no improvement. Anyone's assistance is greatly appreciated

I have successfully followed the howto for Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (CentOS 5.3 x86_64) (but for x86) and I have implemented this system successfully a few times. However I seem to have hit a issue. I have a situation where i have to place the mailstore on a windows NAS. I can sucessfully mounted the share with the correct gid/uid and i can get postfix to delivery mail to it properly however i can't seem to get courier to fetch the mail / display mail in any app (squirrel for example).

It shows that there is in new messages eg: [Inbox (2)] but isn't able to display the mail itself.

I have also attempted to maually telnet into the imap server and fetch mail and recieved the following error:
a fetch 2 body[text]
* 2 FETCH ()
* NO Cannot open message 2
a OK FETCH completed.
a fetch 1 body[text]
* 1 FETCH ()
* NO Cannot open message 1
a OK FETCH completed.

After trying manually or via an mail app i see the following errors in the /var/log/maillog:
Jun 18 09:33:48 mail01 imapd: rename(./new/1245268538.V17I22ed9bM285388.mail01.company.net,S= 1034,./cur/1245268538.V17I22ed9bM285388.mail01.company.net,S= 1034:2,)
failed: No such file or directory


fstab:
//192.168.0.50/linuxmail /MailStoreAmun cifs username=net/linuxmail,password=Password1,uid=vmail,gid=vmail 0 0
I have also tried modes 0777 just to test with no change in results.

authmysql(key parts for this issue):
MYSQL_UID_FIELD 5000
MYSQL_GID_FIELD 5000
MYSQL_HOME_FIELD "/MailStoreAmun"
MYSQL_MAILDIR_FIELD CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/')
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier And MySQL - CentOS spyda46 HOWTO-Related Questions 5 21st May 2009 16:38
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
Help configure Postfix to use alt port 465 or 587 BoloMarkIII Installation/Configuration 10 16th March 2009 17:57
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
Another Problem: Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP bluegrass Installation/Configuration 24 8th March 2006 01:41


All times are GMT +2. The time now is 17:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.