Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 30th June 2009, 01:00
bazza bazza is offline
Junior Member
 
Join Date: Feb 2006
Posts: 13
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by TokyNET View Post
Did you read and see what I pasted?

Assumption correct, however your post does not help the situation...

Besides changing the path (changing /etc/apache2/ to /etc/httpd/)

Edit: "a2enmod" seems to be for debian based systems...
When I find someone asking for help in a thread about a howto written for Ubuntu I naturally assume that person is running Ubuntu or Debian or another Debian derivative. However now that you have stated that you have been changing apache2 to read httpd then you are probably running Centos or Fedora and those distros store the keys in a different location /etc/pki/ not /etc/apache2/ssl. If you read /etc/httpd/conf.d/ssl.conf you will find out exactly where your httpd expects to find the keys.
Reply With Quote
Sponsored Links
  #12  
Old 8th July 2009, 01:48
TokyNET TokyNET is offline
Junior Member
 
Join Date: Jun 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the reply, I'm looking at this thread since this is the only one i've found that had a "how-to" to get ssl working on the control panel. I however, have no ssl.conf on /etc/http/conf.d (or under any directory under /etc/http/ )

So, it looks like that is part of my probelm, also like I mentioned before, im not sure where I'm supposed to add the content stated on this how-to about the ispconfig.vhost. I have pasted my vhost file.

I have added the extralines in a bunch of places and it does not work (only 1 at a time though) this is what I get when I have the lines enabled on my conf:

Code:
|root@cornpops|____|Tue Jul 07|____|19:44:50|____| jobs:0/pts:1/users:2/sites-available/ 
# -->/etc/init.d/httpd start
Starting httpd: Syntax error on line 14 of /etc/httpd/conf/sites-enabled/000-ispconfig.vhost:
Invalid command 'SSLEngine', perhaps misspelled or defined by a module not included in the server configuration
                                                           [FAILED]
This is the current state of my ispconfig.vhost:
Code:
Listen 8080
NameVirtualHost *:8080

<VirtualHost _default_:8080>
ServerAdmin webmaster@localhost
  <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    SSLEngine On
    SSLCertificateFile /etc/httpd/ssl/server.crt
    SSLCertificateKeyFile /etc/httpd/ssl/server.key
    <Directory /var/www/ispconfig/>
      Options Indexes FollowSymLinks MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
      AddHandler fcgid-script .php
      FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
      Order allow,deny
      Allow from all
    </Directory>
  </IfModule>

  <IfModule mod_php5.c>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
      php_value magic_quotes_gpc        0
    </Directory>
  </IfModule>
  <IfModule mod_php5.c>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
      php_value magic_quotes_gpc        0
    </Directory>
  </IfModule>

  # ErrorLog /var/log/apache2/error.log
  # CustomLog /var/log/apache2/access.log combined
  ServerSignature Off

</VirtualHost>

<Directory /var/www/php-cgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<Directory /var/www/php-fcgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>
I will look into creating the ssl.conf file, but that error when I try to start apache when the conf file is edited makes me believe that even once I get the file created, its not going to work.

Last edited by TokyNET; 8th July 2009 at 02:12. Reason: fixing pasted code
Reply With Quote
  #13  
Old 8th July 2009, 02:19
TokyNET TokyNET is offline
Junior Member
 
Join Date: Jun 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I got it working!!!!!!!!!!!!!!

I turns out that I did have the ssl.conf file (I was looking on a diff server when I was not able to find ssl.conf before... )

So, my problem was that there were duplicate directives on httpd.conf and ssl.conf, so httpd.conf would load mod_ssl and then ssl.conf would try to do the same (the same with the listening port)

All I had to do was to fix the path on ssl.conf (for where it expected to find the certs to the one I created while doing this how-to) and comment out the duplicate directives ( I opted to comment out on httpd.conf anything that had to do with ssl and leave ssl.conf as the ruler of all ssl-related configs)

Now I have https on control-panel!!!!

Thanks for the how-to and my apologies if I seemed like an ass... I just get upset when I see replies to questions that do not really help the situation (not only when its on questions posted by me... )
Reply With Quote
  #14  
Old 9th July 2009, 23:23
bazza bazza is offline
Junior Member
 
Join Date: Feb 2006
Posts: 13
Thanks: 4
Thanked 0 Times in 0 Posts
 
Default

Glad to hear you've got it working.

There's an old saying that goes 'ask a stupid question and you'll get a stupid answer'.

Next time you feel yourself getting upset check your question before you start venting your frustration on people who are trying to help you.
Reply With Quote
Reply

Bookmarks

Tags
https v3beta ssl cert gen

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail Question: installed smf forum on centos perfect server setup with ispconfig happz Installation/Configuration 7 22nd August 2008 13:15
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
ISP Blocking port 80 & 8080 grandpagenocide Installation/Configuration 4 18th June 2007 11:48
http to https redirection for port 81 - ISPConfig TheMaximumWeasel Installation/Configuration 6 30th May 2007 23:30
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40


All times are GMT +2. The time now is 01:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.