Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th July 2009, 21:10
pwcr pwcr is offline
Junior Member
 
Join Date: Jul 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem with alias/forward to multiple addresses

Hi,

like the person in this topic: http://www.howtoforge.com/forums/showthread.php?t=34447 I'm trying to create alias/forward which would deliver emails to two local mailboxes.

I tried:
- adding 2 aliases with same source address and different destination addresses
- adding a forward with multiple addresses in destination field, separated by whitespace

Test mails to alias address are not delivered to mailboxes.
Mail log shows no problems.

After I send the test email, a new folder appears in /var/vmail, named like the first destination address, for example testuser@example.com.
This doesn't seem right.

The system is Debian Lenny, ISPConfig 3.0.1.3. Mail is setup using this how-to: http://www.howtoforge.com/perfect-se...nny-ispconfig3

Mail server is ISPConfig *slave* server, the web interface is hosted elsewhere. Mail works ok otherwise, even forwards/aliases to one destination email work ok.

Any ideas?

Regards,
Peter
Reply With Quote
Sponsored Links
  #2  
Old 8th July 2009, 01:23
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,995
Thanks: 840
Thanked 5,649 Times in 4,459 Posts
Default

Make sure that the alias address is not the sma ethen the mailbox address.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 8th July 2009, 02:58
pwcr pwcr is offline
Junior Member
 
Join Date: Jul 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Alias address in not the same as any of mailbox addresses.
I did some more testing, interesting results.

If I create (in ISPConfig) aliases testusers@domain1.com > testuser@domain1.com and testusers@domain1.com > someuser@domain2.com, the mail sent to testusers@domain1.com is delivered to both mailboxes.

However, if I create aliases testusers@domain1.com > testuser@domain1.com and testusers@domain1.com > someuser@domain1.com, the mail sent to testusers@domain1.com is not delivered to these mailboxes. Instead, the folder /var/vmail/testuser@domain1.com is automatically created, and inside it another folder someuser@domain1.com, and inside that folder the usual "cur" and "new" subfolders.

Apparently there is a problem with 2 aliases with the same name pointing to 2 different mailboxes in same domain.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 18:58
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 11:49
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 13:20
Multiple email addresses in forwards toolz HOWTO-Related Questions 2 22nd March 2009 00:02
horde/imp - multiple addresses single login falcon5 Installation/Configuration 9 7th June 2008 17:48


All times are GMT +2. The time now is 15:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.