#1  
Old 1st July 2009, 11:56
gzero gzero is offline
Junior Member
 
Join Date: Oct 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default php segfault

Hi,

After a crash of my previous ispconfig install i decided to go the ispconfig3 path. After install the server and some hickups I managed to get my server going smoothly. But now after 2 weeks my server is experiencing issues. All of a sudden my php sites cannot connect to the mysql database anymore and the following is displayed in the log files. I have to restart mysql to get it working again. I guess this means there is something wrong with my mysql but why do i receive php messages? because it cannot connect to mysql anymore? i guess it shouldn't segfault because of that right?

I also looked for mysql errors but could not find any. Could this be a tuning issue, where php is requesting to many connections?

Code:
[17546.670984] php[23330]: segfault at 7fff69c21dc0 ip 000000000062844d sp 00007fff69c21da0 error 6 in php5[400000+519000]
[17606.986485] php[23404]: segfault at 7ffffd34bdc0 ip 000000000062844d sp 00007ffffd34bda0 error 6 in php5[400000+519000]
[17666.397216] php[23507]: segfault at 7fff71a33bd0 ip 000000000062844d sp 00007fff71a33bb0 error 6 in php5[400000+519000]
[17726.683409] php[23542]: segfault at 7fff1510db80 ip 000000000062844d sp 00007fff1510db60 error 6 in php5[400000+519000]
[17786.976288] php[23579]: segfault at 7fffc6f0dfc0 ip 00007fbabc648798 sp 00007fffc6f0df80 error 6 in libc-2.9.so[7fbabc5ce000+168000]
[17847.269009] php[23617]: segfault at 7fff71433eb0 ip 000000000062844d sp 00007fff71433e90 error 6 in php5[400000+519000]
[17906.571567] php[23665]: segfault at 7fffe9fb2150 ip 000000000062844d sp 00007fffe9fb2130 error 6 in php5[400000+519000]
[17966.860766] php[23706]: segfault at 7fff9ccd1e60 ip 000000000062844d sp 00007fff9ccd1e40 error 6 in php5[400000+519000]
Reply With Quote
Sponsored Links
  #2  
Old 1st July 2009, 16:40
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,490 Times in 4,322 Posts
Default

Quote:
i guess it shouldn't segfault because of that right?
Yes, php does normally not segfault on connection problems.

In most cases, segfaults are caused by hardware problems. You should check your server with e.g. memcheck.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd July 2009, 20:18
marciliomcm marciliomcm is offline
Junior Member
 
Join Date: May 2009
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
Default

same my..

[ 48.371022] lp0: using parport0 (interrupt-driven).
[ 48.387023] ppdev: user-space parallel port driver
[ 50.562891] warning: `pure-ftpd-mysql' uses 32-bit capabilities (legacy support in use)
[ 1407.341122] php[5492]: segfault at 7f02ab471ed0 ip 7f02ab471ed0 sp 427d1128 error 14 in libkeyutils-1.2.so[7f02b0baf000+2000]
[63952.120462] php[7626]: segfault at 7f4555476ed0 ip 7f4555476ed0 sp 41add128 error 14 in libkeyutils-1.2.so[7f455abb4000+2000]
[83375.543714] php[27941]: segfault at 7f83e3daaed0 ip 7f83e3daaed0 sp 41ba1128 error 14 in libkeyutils-1.2.so[7f83e94e8000+2000]
[91271.377232] php[8165]: segfault at 7f5aa1e5dedb ip 7f5aa73941af sp 41869c90 error 4 in libgcc_s.so.1[7f5aa7384000+16000]
[135370.614981] php[7124]: segfault at 7fde541a7ed0 ip 7fde541a7ed0 sp 415ef128 error 14 in libXdmcp.so.6.0.0[7fde579bd000+5000]



Linux norris 2.6.26-2-amd64 #1 SMP Sun Jun 21 04:47:08 UTC 2009 x86_64 GNU/Linux

PHP 5.2.6-1+lenny3 with Suhosin-Patch 0.9.6.2 (cli) (built: Apr 26 2009 20:09:03)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
Reply With Quote
  #4  
Old 3rd July 2009, 16:36
gzero gzero is offline
Junior Member
 
Join Date: Oct 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by till View Post
In most cases, segfaults are caused by hardware problems.
I thought segfaults are caused by bad programming? Maybe there is a bug in the mysql module in php?

After thinking about it again and searching the forum I have set the following:

max_connections = 500
max_user_connections = 500

This seems to fix the issues and it runs now without problems. Mysql only allows 151 connections by default which is to limited for my implementation (it seems).

Thx,

gzero.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
ispconfig php 5 errors itamarjp Installation/Configuration 8 25th April 2008 10:20
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 08:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.