Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 27th June 2009, 12:40
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
In the log directory of the website.
Log directory? I have only log file there. But it is empty
Reply With Quote
Sponsored Links
  #12  
Old 27th June 2009, 12:41
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,014
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

If the error.log file is empty then there are no errors. Check on the shell with the "ls -la" command if you placed the .htaccess file in the correct directory, the "web" directory.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 27th June 2009, 12:47
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
If the error.log file is empty then there are no errors. Check on the shell with the "ls -la" command if you placed the .htaccess file in the correct directory, the "web" directory.
Yes. It is in the correct "web" directory. i can access it with command
nano /var/www/client/client0/web10/web/.htaccess
Reply With Quote
  #14  
Old 27th June 2009, 12:56
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
If the error.log file is empty then there are no errors. Check on the shell with the "ls -la" command if you placed the .htaccess file in the correct directory, the "web" directory.
And it isn't "error.log" file but only "log" file in the /var/www/clients/client0/web10/log
Reply With Quote
  #15  
Old 27th June 2009, 12:57
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,014
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

And you are sure that this .htaccess works? Have you tested it on another server successfully. In most scripts you have something like "RewriteCond ...." before the rules.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 27th June 2009, 12:58
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,014
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Quote:
Originally Posted by Skprorok View Post
And it isn't "error.log" file but only "log" file in the /var/www/clients/client0/web10/log
log is a directory and not a file. Go into the log directory, there is the error.log file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #17  
Old 27th June 2009, 13:04
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
log is a directory and not a file. Go into the log directory, there is the error.log file.
.htaccess works on another servers.

I went to "error.log" file and i found errors:
"RewriteEngine is not allowed here"

What now?
Reply With Quote
  #18  
Old 27th June 2009, 13:06
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,014
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Remove the rewrite engine line as the rwrite engine is enabled already. If this wont work, simply copy the whole content of the .htaccess file into the apache directives field of the site and then delete the .htaccess file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #19  
Old 27th June 2009, 13:10
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Remove the rewrite engine line as the rwrite engine is enabled already. If this wont work, simply copy the whole content of the .htaccess file into the apache directives field of the site and then delete the .htaccess file.
What if it still doesn't work?
Reply With Quote
  #20  
Old 27th June 2009, 13:14
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,014
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
 
Default

And you have tested this exact .htaccess file on another server without doing any modifications in it and you do not receibve any error messages in the error log anymore?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
.htaccess

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 21:17
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 14:21
Chroot SSH + ISPConfig Norman Installation/Configuration 27 26th March 2007 04:40
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 06:19
jamed up my table borders?? Boon-Dog-Danny Installation/Configuration 5 23rd September 2006 17:12


All times are GMT +2. The time now is 19:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.