Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th June 2009, 20:37
dodimar dodimar is offline
Junior Member
 
Join Date: Feb 2009
Location: Philippines
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Default Permission error installing Wordpress

I have setup ISPconfig.. created a site...
I uploaded Wordpress via FireFTP.. when I tried configuring Wordpress (creation of config.php), I got this error

Quote:
Sorry, I can't write to the directory. You'll have to either change the permissions on your WordPress directory or create your wp-config.php manually.
Any idea how to fix this... I checked the file permission on the /web folder and it's 775.
Reply With Quote
Sponsored Links
  #2  
Old 25th June 2009, 16:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Are you using some kind of web-based installer? In that case you must use 777 permissions or chwon the folder to the Apache user (www-data on Debian/Ubuntu).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 25th June 2009, 19:07
dodimar dodimar is offline
Junior Member
 
Join Date: Feb 2009
Location: Philippines
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I see.. cause the current ownership of the folder is with the web#_user that was created by ISPconfig.... I'll change the ownership then... giving 777 permission is a bit risky... thanks..
Reply With Quote
  #4  
Old 25th June 2009, 19:14
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,752
Thanks: 821
Thanked 5,330 Times in 4,182 Posts
Default

The only alternative is to use suphp as the mod_php that you currently use does not support scripts to be run under different users. There is a ispconfig with suphp tutorial here on howtoforge that explains the installation.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 25th June 2009, 19:20
dodimar dodimar is offline
Junior Member
 
Join Date: Feb 2009
Location: Philippines
Posts: 24
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

Thanks till, will check on that also...

I am starting to get a hang of ISPconfig... it becomes clearer as I go by...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rsync: opendir "/var/www/web44/web" failed: Permission denied (13) adrenalinic HOWTO-Related Questions 7 4th August 2009 13:16
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
Security issue bernholdt General 3 5th November 2008 13:04
Apache Ownership cybereatl General 2 26th March 2008 12:25
very slow domain setting loading Hellbound General 8 2nd January 2008 22:17


All times are GMT +2. The time now is 15:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.