Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th May 2009, 10:35
martin1977 martin1977 is offline
Junior Member
 
Join Date: May 2009
Posts: 20
Thanks: 0
Thanked 3 Times in 3 Posts
Default how to show per domain statistics with webalizer

Hello,

maybe nobody else has this problem as I haven't found anything regarding this issue in the forum.

I have several virtual domains running on the server and the access logs for each domain are available via a symlink in /var/www/domain.com/log/ .

How can I request statistics via webalizer for a virtual domain?
Webalizer can be run for the global server domain in /var/www/webalizer and uses then the access log from /var/log/apache2/access.log.1, but how to run for the virtual domains in /var/www/domain.com/web/ ?

Or, should the access data be shown in ISPconfig in the Statistics tab? - because it is not listed there.

Best regards,
Martin

Last edited by martin1977; 9th May 2009 at 10:43.
Reply With Quote
Sponsored Links
  #2  
Old 9th May 2009, 18:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
Default

The statistics are generated automatically every night and you can access them like this:

http:://www.domain.tld/stats/

with user admin and the password that you entered on the statitics tab.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 10th May 2009, 10:36
martin1977 martin1977 is offline
Junior Member
 
Join Date: May 2009
Posts: 20
Thanks: 0
Thanked 3 Times in 3 Posts
Default

Alright, that works. Thank you for your support.

Cheers
Martin
Reply With Quote
  #4  
Old 22nd June 2009, 14:59
KillerSneak KillerSneak is offline
Junior Member
 
Join Date: Jul 2008
Posts: 17
Thanks: 3
Thanked 0 Times in 0 Posts
Default

I have the same problem, no matter what site i look at it will show the statistics from my whole server (all hosted sites) How can i fix this? i have followed the SuSe 11.1 + ISPConfig3 tutorial.
Reply With Quote
  #5  
Old 22nd June 2009, 15:02
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
 
Default

Please do not post into x threads that you have the same problem!

http://www.howtoforge.com/forums/showthread.php?t=34753
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
webalizer ispconfig3

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 16:54
Configuring webalizer per domain pjdevries Installation/Configuration 6 13th September 2008 11:24
Howto: Make Webalizer show full QueryString!! Zoon Tips/Tricks/Mods 1 5th November 2007 02:12
No statistics - Webalizer Hans Server Operation 6 6th April 2006 06:54
Webalizer - Usage by Country statistics leno Installation/Configuration 3 28th April 2005 18:12


All times are GMT +2. The time now is 01:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.