Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 19th June 2009, 16:55
wxman wxman is offline
Senior Member
 
Join Date: May 2007
Posts: 189
Thanks: 11
Thanked 2 Times in 2 Posts
Default Public and private IP address confusion

I was going to ask this in an earlier post (http://www.howtoforge.com/forums/sho...404#post195404) but this really is a separate question.

I'm adding SSL to a few sites that will be running in Ispconfig. The server is behind a router/firewall that now has a single public IP routed to the server's private IP of 192.168.31.202. That private IP is also the one I set as the "default" server IP in ISPConfig. I have 5 public IP's that I can use. I know I need a separate public IP for each certificate.

When you use the System>Edit server IP>Add new IP address, do you add a new private IP, then I'd use the router to point the public IP to it, or just add the public IP directly to ISPConfig?

I've tried to experiment with it, but so far it hasn't worked. I tried adding a new public IP address in ISPC, then switched one site to use that IP instead of the *. I made sure the DNS entries reflected the change, but I could never access the site after making the change. I don't know if I'm missing a step somewhere, or there are other changes that have to be done manually.

Also, when setting up a site that will use SSL, do you need to set up two seperate entries in the Sites section, one for HTTP and one for HTTPS?
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
BIND configuration for Public and Private IP Address joel_griego Installation/Configuration 1 18th March 2009 11:39
Public and private network + High Availability Apache Cluster teleted HOWTO-Related Questions 11 28th January 2008 14:29
Postfix + VDA patch (doesn't build RPM on server) VelhaChica Server Operation 5 18th October 2007 16:50
Private or Public IP settings kyriakos Installation/Configuration 1 20th February 2006 13:24


All times are GMT +2. The time now is 06:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.