Prev Previous Post   Next Post Next
  #1  
Old 16th June 2009, 07:20
punto punto is offline
Member
 
Join Date: Jul 2006
Posts: 84
Thanks: 12
Thanked 2 Times in 1 Post
Default Creating SSL crashed apache

Hi,

I am trying to create an SSL certificate for a domain I am hosting and everytime I enter the certificate sent to me from Commodo and click save under ISPCONFIG it causes httpd to stop and I cannot restart it. This is from the error_log:

[Tue Jun 16 15:01:02 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Jun 16 15:01:04 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Jun 16 15:01:05 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Jun 16 15:01:06 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
[Tue Jun 16 15:01:08 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Jun 16 15:02:55 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)

Once I delete the SSL certificate for the domain, httpd restarts instantly and we are all okay again.

I can confirm the following files are created in the SSL data directory once I input the certificate file received from Commodo and upload the bundle.

www_domain.com.ca-bundle www_domain.com.csr
www_domain.com.crt www_domain.com.key
www_domain.com.key.org


Any advice on how to get this working will be appreciated as the site is due to go live immediately.

The domain is on its own dedicated, routable IP address.

Thanks in advance
Matt

Last edited by punto; 16th June 2009 at 13:47.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with suexec gobokster Installation/Configuration 7 7th May 2009 13:33
SSL "connection interrupted" apache not listening on 443 yuro Installation/Configuration 10 28th October 2008 14:42
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58
ISPConfig 2.2.14 released till General 48 19th July 2007 23:46
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 00:45


All times are GMT +2. The time now is 02:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.