Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th March 2006, 19:37
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default Sending email problems: Relay access denied

Falko/Till,

Me and my clients are having problems sending email to say, gmail and yahoo.
Also a few other email address:

salleh@matrade.gov.my
cmkasule@nssfug.org
mfaicsl@yahoo.com


Tried to send a test email to my gmail account (jaffaizal@gmail.com ). Got the following error message:

Sending failed:
Message sending failed since the following recipients were rejected by the server:
jaffaizal@gmail.com (The server responded: "<jaffaizal@gmail.com>: Recipient address rejected: Relay access denied")
The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
The following transport protocol was used:
PLANIMA

Your help is appreciated.
JafFaizal
Reply With Quote
Sponsored Links
  #2  
Old 15th March 2006, 20:17
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,380
Thanks: 833
Thanked 5,481 Times in 4,315 Posts
Default

You will have to check "Server needs authentication" in the smtp settings of your email client.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 15th March 2006, 20:52
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Did what you requested.

Got following error msg popup:

----------------------------------------------------------------
Sending failed:
Unknown error code 50
Your SMTP server does not support TLS. Disable TLS, if you want to connect without encryption.
Please send a full bug report at http://bugs.kde.org.
The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
The following transport protocol was used:
PLANIMA
----------------------------------------------------------------

This is what I did:

Check what the server support click in KMAIL for receiving email from pop.planima.com.

KMAIL do the setting as:

Use TLS for secure mail download
&
Authentication method as : Clear text.

Therefore I set the sending account (using smtp.planima.com:25) accordingly as:

Encryption : TLS
Authentication method : PLAIN

Set server requires authentication and used the login/password as created in ISPconfig.

What is wrong?

Thanks,
JafFaizal
Reply With Quote
  #4  
Old 15th March 2006, 22:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Please disable TLS in your email client and try again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 16th March 2006, 03:51
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Disabled the TLS in KMail.
Current setting in KMail for, Accounts->Sending->Transport:SMTP->General Tab. I checked the Server requires authentication and use,

Login->web???? (ie. the same UID setup in ISPConfig. This is the same UID for my pop.planima.com)

Password->******** (ie. the same PWD setup in ISPConfig. This is the same UID for my pop.planima.com)

Setting for Accounts->Sending->Transport:SMTP->Security Tab: Encryption->None Authentication Method->LOGIN (other options are, PLAIN, CRAM-MD5, DIGEST-MD5, NTLM, GSSAPI)

Are the above setting correct?

Now receive this popup error message: ----------------------------------------------------------
Sending failed: Authentication failed.
Most likely the password is wrong.
The server responded: "Error: authentication failed" The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
The following transport protocol was used: PLANIMA ----------------------------------------------------------

If I used PLAIN, got following error msg: ----------------------------------------------------------
Sending failed: Your SMTP server does not support PLAIN.
Choose a different authentication method.
The server responded: "Error: authentication failed" The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
The following transport protocol was used:PLANIMA ----------------------------------------------------------

BTW, following is the ehlo localhost output:
----------------------------------------------------------
suse1:~ # telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 suse1.mileswork.com ESMTP Postfix
ehlo localhost
250-suse1.mileswork.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
--------------------------------------------------------

Any other setting I need to setup at the Server or KMail?

Thank
JafFaizal

Last edited by jaffaizal; 16th March 2006 at 04:20.
Reply With Quote
  #6  
Old 16th March 2006, 05:22
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Falko/Till,

BTW, I was informed by my client that those email that bounce now, he could sent emails to them before.

Now, I'm curious that maybe external parties is using my ISPConfig email server to relay SPAM. Therefore it is blacklisted now.

How can I confirm this?
If YES, what is the remedy (how to stop this)?

But, the gmail and yahoomail is a separate issues.

Thanks,
JafFaizal
Reply With Quote
  #7  
Old 16th March 2006, 11:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Make sure you use the correct usernames. For the ISPConfig webmail package, you must use an email address as username, but for an email client like KMail, it's the real username (e.g. web1_someuser) that you must use.

Can you send emails eithout authentication? What's in /etc/postfix/main.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 16th March 2006, 18:34
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default

This is what pop up if no authentication:

------------------------------------------------------------
Sending failed:
Message sending failed since the following recipients were rejected by the server:
jaffaizal@gmail.com (The server responded: "<jaffaizal@gmail.com>: Recipient address rejected: Relay access denied")
The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
The following transport protocol was used:
PLANIMA

------------------------------------------------------------
There is a lot in /etc/postfix/main.cf (which part do you want to know?)

JafFaizal
Reply With Quote
  #9  
Old 17th March 2006, 12:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by jaffaizal
This is what pop up if no authentication:

------------------------------------------------------------
Sending failed:
Message sending failed since the following recipients were rejected by the server:
jaffaizal@gmail.com (The server responded: "<jaffaizal@gmail.com>: Recipient address rejected: Relay access denied")
The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
The following transport protocol was used:
PLANIMA

------------------------------------------------------------
Then your server is not an open relay which is good.

Quote:
Originally Posted by jaffaizal
There is a lot in /etc/postfix/main.cf (which part do you want to know?)
Post the whole file without comments.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 17th March 2006, 21:04
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

The file as requested... appreciated the help.

JafFaizal

---------------------------------------------------

queue_directory = /var/spool/postfix

command_directory = /usr/sbin

daemon_directory = /usr/lib/postfix

mail_owner = postfix

unknown_local_recipient_reject_code = 550


debug_peer_level = 2

debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5

sendmail_path = /usr/sbin/sendmail

newaliases_path = /usr/bin/newaliases

mailq_path = /usr/bin/mailq

setgid_group = maildrop

html_directory = /usr/share/doc/packages/postfix/html

manpage_directory = /usr/share/man

sample_directory = /usr/share/doc/packages/postfix/samples

readme_directory = /usr/share/doc/packages/postfix/README_FILES
inet_protocols = all
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
#virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = suse1.$mydomain
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains =
#mydestination = $myhostname, localhost.$mydomain
defer_transports =
disable_dns_lookups = no
relayhost =
mailbox_command =
mailbox_transport =
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = yes
smtpd_use_tls = yes
smtp_use_tls = yes
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
mydomain = mileswork.com
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_tls_auth_only = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names

--------------------------------------------------------------
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay access denied when using SMTP to external recipients Kamran Shah Installation/Configuration 111 14th May 2014 18:10
Relay access denied maxx Installation/Configuration 17 4th April 2011 12:34
Can Send Email, But Not Recieve; Relay access denied jazzgillum Installation/Configuration 21 31st May 2007 12:46
relay access denied (i've readen the previous post about this ) jeanjacquesjeanjacques Installation/Configuration 5 21st April 2006 23:34
Relay access denied KamiTsunami Server Operation 6 7th March 2006 10:25


All times are GMT +2. The time now is 16:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.