#1  
Old 30th May 2009, 13:06
satimis satimis is offline
Senior Member
 
Join Date: Oct 2006
Posts: 533
Thanks: 4
Thanked 2 Times in 2 Posts
Default Fail to create KVM guest

Hi folks,

I was following;
http://howtoforge.com/virtualization...on-ubuntu-9.04

to create a KVM virtual machine running Ubuntu 9.04 32bit but failed creating guest.

# vmbuilder kvm ubuntu --suite=intrepid --flavour=virtual --arch=i386 --mirror=http://192.168.0.10:9999/ubuntu -o --libvirt=qemu:///system --tmpfs=- --ip=192.168.0.11 --part=vmbuilder.partition --templates=mytemplates --user=admin --name=Admin --pass=apassword --addpkg=vim-nox --addpkg=unattended-upgrades --addpkg=acpid --firstboot=boot.sh --mem=256 --hostname=vm1 --bridge=br0
Code:
.......
2009-05-30 17:31:28,302 INFO     Can not write log, openpty() failed (/dev/pts not mounted?)
2009-05-30 17:31:28,523 INFO     Can not write log, openpty() failed (/dev/pts not mounted?)
2009-05-30 17:31:28,554 INFO     Can not write log, openpty() failed (/dev/pts not mounted?)
2009-05-30 17:31:33,813 INFO     Can not write log, openpty() failed (/dev/pts not mounted?)
2009-05-30 17:31:35,302 INFO     addgroup: The group `admin' already exists and is not a system group. Exiting.
2009-05-30 17:31:35,303 INFO     Cleaning up
Traceback (most recent call last):
  File "/usr/bin/vmbuilder", line 29, in <module>
    VMBuilder.run()
  File "/usr/lib/python2.6/dist-packages/VMBuilder/__init__.py", line 66, in run
    frontend.run()
  File "/usr/lib/python2.6/dist-packages/VMBuilder/plugins/cli/__init__.py", line 67, in run
    vm.create()
  File "/usr/lib/python2.6/dist-packages/VMBuilder/vm.py", line 469, in create
    raise e
VMBuilder.exception.VMBuilderException: Process (['chroot', '/tmp/vmbuilderJ0sb_H/root', 'addgroup', '--system', 'admin']) returned 1. stdout: , stderr: addgroup: The group `admin' already exists and is not a system group. Exiting.
root@server1:~/vm1# ls -l /etc/libvirt/qemu/
Code:
total 4
drwxr-xr-x 3 root root 4096 2009-05-28 19:12 networks
root@server1:/home/satimis# virsh list
Code:
Connecting to uri: qemu:///system
 Id Name                 State
----------------------------------
Not guest created.

This seems a bug;
http://ubuntuforums.org/archive/inde...t-1056124.html

Is there a solution? Please advise. TIA

B.R.
satimis

Last edited by satimis; 30th May 2009 at 13:10.
Reply With Quote
Sponsored Links
  #2  
Old 24th June 2009, 22:07
heath heath is offline
Junior Member
 
Join Date: Jun 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default RE: Fail to create KVM guest

You must choose a different user name. admin is reserved in Ubuntu. Use administrator or something else for the --user
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to create a new guest by cloning existing guest satimis Server Operation 3 1st September 2008 18:28
Fail to create disk.img satimis Server Operation 1 5th August 2008 13:40
Create fedora guest on debian xabin Installation/Configuration 3 11th March 2008 21:40
Chroot SSH + ISPConfig Norman Installation/Configuration 27 26th March 2007 04:40
Verify email setup meekish Installation/Configuration 28 27th October 2006 16:36


All times are GMT +2. The time now is 09:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.