Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th May 2009, 13:11
bas bas is offline
Junior Member
 
Join Date: Jan 2008
Location: Amsterdam
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default cannot create db's for a site -and ISPconfig deletes existing db's

Hello

I have a bit of a problem right now.

Have been running ISPConfig quite some time. Always worked perfectly.
Some time ago it seemed someone hacked my system. So i took my backup and rebuild the system completely. Also immediately upgraded to the lastest OS version and the latest ISPConfig version.
I've followed the steps mentioned elsewhere on this forum. And got everything running again.

All seemed to be fine.
Except when i tried to create a new database for an existing site - the button isnt there anymore. In the site-definition is still shows that there were already multiple database, but if i then save the site ISPConfig will actually delete all those databases.

So i need to find a way to allow the creation of databaes again. And then i hope once that's fixed that the automatic removing of databases will stop too.
(right now i have to create my db backup - so that if by accident i make a change in a sitedefinition, i can instantly re-create and replace the database).

Hope someone can give me a hand.

I am running version 2.2.32, on ubuntu 9.04 (server)

Thanks
Bas
Reply With Quote
Sponsored Links
  #2  
Old 28th May 2009, 08:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,475
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
 
Default

The document type definitions in your database are not correct for the installed version. I guess you used the doctype table from your old version as you restored the backup. To fix this, download the latest ispconfig 2 version again and run the setup script to update your installations. It is ok if its the same version that you have currently installed.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 installed on Debian Lenny... and now... how to create a site? manarak General 6 19th May 2009 16:34
cannot access ispconfig site Nu2Linux Installation/Configuration 13 3rd January 2009 15:29
Importing existing ssl key/cert into ISPConfig site zetnsh Installation/Configuration 14 8th February 2008 10:25
ISPConfig 2.3.2-dev released till General 9 4th June 2007 10:46
ISPConfig stop working after i add a new site xTiNcTion Installation/Configuration 4 5th January 2007 23:55


All times are GMT +2. The time now is 19:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.