Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st May 2009, 18:53
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
Default Ipplan moved from ispconfig 2 to ispconfig 3 login problem

I have a working installation of ipplan on a ispconfig 2 system (opensuse 10.0).

I have moved the installation to a newly created ispconfig 3 system (opensuse 11.1). I moved the files and export-import the database.

All seems well and when i access the home page of ipplan (http://www.mydomain/ipplan) everything looks normal.

The problem is that i cannot login to ipplan neither with the accounts created in the database or the admin account that exists in the config.php file of ipplan.

From the faq of ipplan:

Quote:
* Q: I have another .htaccess file higher up in my web server tree which confuses IPplans authentication - how can I use both?

A: Use external authentication to obtain the previous login credentials of the superior directory - see the documentation.

A: Create an .htaccess file in the IPplan subdirectory consisting of only one line:

Order Deny,Allow

This will make the authentication that was made by a superior-directory .htaccess gone.
It seems that something is confusing ipplan's authentication although i have made an .htaccess file in the ipplan's folder as stated in the faq.

Any help is appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 22nd May 2009, 17:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Can you post the vhost configuration?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd May 2009, 18:49
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
Default

Sure. Here is the requested vhost configuration:

Quote:
<Directory /srv/www/cywn.gr>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost *:80>
DocumentRoot /srv/www/cywn.gr/web

ServerName cywn.gr
ServerAdmin webmaster@cywn.gr

ErrorLog /var/log/ispconfig/httpd/cywn.gr/error.log

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /srv/www/cywn.gr/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>
<Directory /srv/www/clients/client2/web4/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>

# cgi enabled
<Directory /srv/www/clients/client2/web4/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ /srv/www/clients/client2/web4/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
# suexec enabled
SuexecUserGroup web4 client2
# php as fast-cgi enabled
<Directory /srv/www/cywn.gr/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /srv/www/php-fcgi-scripts/web4/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride all
Order allow,deny
Allow from all
</Directory>


</VirtualHost>
Reply With Quote
  #4  
Old 23rd May 2009, 14:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Can you change all
Code:
AllowOverride Indexes AuthConfig Limit
lines to
Code:
AllowOverride All
and restart Apache? Does it work then?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 25th May 2009, 21:07
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
Default

Sorry for the late reply, i was away from civilization.

No is not working. I have the same behavior as before. It keeps asking for username and password.

Last edited by baskin; 25th May 2009 at 21:46.
Reply With Quote
  #6  
Old 27th May 2009, 20:27
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
 
Default

After the latest update (3.0.1.3) my vhost configuration is:

Quote:
<Directory /srv/www/cywn.gr>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost *:80>
DocumentRoot /srv/www/cywn.gr/web

ServerName cywn.gr
ServerAdmin webmaster@cywn.gr

ErrorLog /var/log/ispconfig/httpd/cywn.gr/error.log

Alias /error/ "/srv/www/cywn.gr/error/"

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /srv/www/cywn.gr/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>
<Directory /srv/www/clients/client2/web4/web>
Options FollowSymLinks
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>

# cgi enabled
<Directory /srv/www/clients/client2/web4/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ /srv/www/clients/client2/web4/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
# suexec enabled
SuexecUserGroup web4 client2
# php as fast-cgi enabled
<Directory /srv/www/cywn.gr/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /srv/www/php-fcgi-scripts/web4/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride all
Order allow,deny
Allow from all
</Directory>

</VirtualHost>
I have also tried to change all

Quote:
AllowOverride Indexes AuthConfig Limit FileInfo
to

Quote:
AllowOverride All
with no luck.

I have also checked that ipplan is working when i moved it to a test server without ispconfig and vhosts (just one site).
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to authenticate to SMTP server ashkev Installation/Configuration 15 6th February 2007 18:46
site works but ISPConfig login gone? Boon-Dog-Danny Installation/Configuration 6 4th August 2006 14:01
User Login to ISPConfig DiOmega General 7 7th March 2006 20:44
Details on problem /mailuser login and more (long) linutzy Installation/Configuration 11 15th February 2006 19:45
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 18:28


All times are GMT +2. The time now is 03:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.