#1  
Old 17th May 2009, 00:44
estebanmora estebanmora is offline
Junior Member
 
Join Date: May 2009
Posts: 21
Thanks: 1
Thanked 1 Time in 1 Post
Unhappy PHP Not working

I don't know what is happening what suddenly the PHP of my ISPConfig box stop working. If I create a file named index.php with:

<?php
phpinfo();
?>

I only receive this on my browser:

<?php
phpinfo();
?>

Only the contents of the file appears. I search in this forum for someone having the same problem with no one with the same exactly. The only way in which I can make the script work is enabling php globally. The strange part is that PHP was working on the server last week without problems. No updates have been made. The websites are created with PHP scripts checked but not with Secure PHP.

There has to be something wrong with the server because now, when I create a new website, when I type the domain address in my browser I end in the /var/www forlder instead of the domain folder.

I need some help here.
Reply With Quote
Sponsored Links
  #2  
Old 17th May 2009, 09:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,678
Thanks: 819
Thanked 5,318 Times in 4,171 Posts
 
Default

Quote:
There has to be something wrong with the server because now, when I create a new website, when I type the domain address in my browser I end in the /var/www forlder instead of the domain folder.
Ok, then you dont have a problem with php, you access your sites not trogh their vhosts. Instead you access them now trogh the global vhost.

Either you installed any software package which chnaged the global vhost of your linux distribution or something in dns has been changed.

To fix this, make sure that you selected the correct IP addresses for the websites in ispconfig instead of *
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
ispconfig2

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
ispconfig php 5 errors itamarjp Installation/Configuration 8 25th April 2008 10:20
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 22:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.