Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th May 2009, 10:29
tio289 tio289 is offline
Member
 
Join Date: Mar 2009
Posts: 70
Thanks: 2
Thanked 14 Times in 9 Posts
Default Alias domain 301 redirect

hi. its simply, just edit file /usr/local/ispconfig/interface/web/sites/form/web_aliasdomain.tform.php

this lines
Code:
...
'redirect_type' => array (
			'datatype'	=> 'VARCHAR',
			'formtype'	=> 'SELECT',
			'default'	=> 'y',
			'value'		=> array('' => 'No redirect', 'no' => 'No flag', 'R' => 'R', 'L' => 'L', 'R,L' => 'R,L')
		),
...
to this

Code:
...
'redirect_type' => array (
			'datatype'	=> 'VARCHAR',
			'formtype'	=> 'SELECT',
			'default'	=> 'y',
			'value'		=> array('' => 'No redirect', 'no' => 'No flag', 'R=301,NC' => 'R=301,NC', 'L' => 'L', 'R,L' => 'R,L')
		),
...
you can add your own options, for example
Code:
...
'redirect_type' => array (
			'datatype'	=> 'VARCHAR',
			'formtype'	=> 'SELECT',
			'default'	=> 'y',
			'value'		=> array('' => 'No redirect', 'no' => 'No flag', 'R=301,NC' => 'R=301,NC', 'R=302,NC' => 'R=302,NC', 'L' => 'L', 'R,L' => 'R,L')
		),
...
Reply With Quote
The Following User Says Thank You to tio289 For This Useful Post:
oncletom (18th May 2009)
Sponsored Links
  #2  
Old 14th July 2010, 13:16
math math is offline
Junior Member
 
Join Date: Apr 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I don't know why (not a redirect specialist ) but it didn't worked for me.. (redirect was not effective)
I had to replace 'R=301,NC' with 'L,R=301'

regards,
Reply With Quote
  #3  
Old 16th July 2010, 07:25
thesslstore thesslstore is offline
Junior Member
 
Join Date: Jul 2010
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Hello friends,

Hey I am doing the same but it is not working.. Can you please tell me what can be the issue??

Thanks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 20:17
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 16:54
Postfix not responding to telnet CarbonCopy Server Operation 6 8th May 2009 05:39
post fix error after a year aberrio Server Operation 5 5th May 2009 21:33
CentoS doesn't send the emails vaio1 Installation/Configuration 18 5th November 2008 17:51


All times are GMT +2. The time now is 00:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.