Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th April 2009, 21:39
redeprotegida redeprotegida is offline
Junior Member
 
Join Date: Apr 2009
Posts: 23
Thanks: 9
Thanked 1 Time in 1 Post
Default Auto responder empty "FROM:"

Hello,

The messages comming from the ispconfig3's are without the "From:"

look on this header:

From:
Message-Id: <200904271825.n3RIPZ9t031468@xxx.xxx.xxxx>
X-Authentication-Warning: xxxxx.xxx.xxxxxxx: vmail set sender to <> using -f
Subject: Auto Response: from
To: diego@xxxxxx.com.br
Precedence: junk
Auto-Submitted: auto-replied
Mime-Version: 1.0
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain; charset="iso-8859-1"


is it a bug or have something that I can do to fix it?

thanks.

Diego
Reply With Quote
Sponsored Links
  #2  
Old 28th April 2009, 18:25
redeprotegida redeprotegida is offline
Junior Member
 
Join Date: Apr 2009
Posts: 23
Thanks: 9
Thanked 1 Time in 1 Post
Default

Can you please give me some way to place something on the from:
if i cant place the real sender i can place something like

autoreply@mydomain.com

just to fill the From:
i need something there if i leave it in blank the antispam will move it to junk.

thanks.
Reply With Quote
  #3  
Old 5th May 2009, 15:52
redeprotegida redeprotegida is offline
Junior Member
 
Join Date: Apr 2009
Posts: 23
Thanks: 9
Thanked 1 Time in 1 Post
Default

no one knows how to place something on the From: ???

it´s causing bulk mail
Reply With Quote
  #4  
Old 5th May 2009, 15:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

You can take a look at the maildrop script in /var/vmail/mailfilters/.... which handle the autoresponder.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
redeprotegida (6th May 2009)
  #5  
Old 5th May 2009, 17:01
redeprotegida redeprotegida is offline
Junior Member
 
Join Date: Apr 2009
Posts: 23
Thanks: 9
Thanked 1 Time in 1 Post
Default

i fixed it changing the .autoresponder file

`test -f /var/vmail/mailfilters/$HOST/$USER/.vacation.msg && exit 1 || exit 0`
if ($RETURNCODE==1)
{
{
if (!/^List-Unsubscribe:.*/:h )
{
if (!/^X-Spam-Flag: YES/:h )
{
RESPOND="/var/vmail/mailfilters/$HOST/$USER/.vacation.msg"
RESPONDDB="/var/vmail/mailfilters/$HOST/$USER/.vacation.lst"

# The following must be one contiguous line
cc "| mailbot -t $RESPOND -d $RESPONDDB -D 1 \
-A 'From: diego@redeprotegida.com.br' -s 'Auto Response: from $RECIPIENT' \
/usr/sbin/sendmail -t -f ''"
}
}
}
}


i found a bug...
the From: was $RECIPIENT, so this variable is imput...

please tellme wich php file generate this .autoresponder then ill edit it to generate a line like this:

-A 'From: vacation@redeprotegida.com.br' -s 'Auto Response: from Redeprotegida.com.br' \

cause i need smt automatic, i cant go there and edit the file for all clients that want to enable autoresponder..

thanks
Reply With Quote
  #6  
Old 5th May 2009, 17:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

But the variable $RECIPIENT contains normally the recipient of the email, so the script is correct. If $RECIPIENT is not set on your server then you can either check main.cf to make sure that the second parameter of the maildrop script returns the recipient or you use the $HOST and $USER variables to built the recipient like this:

-A 'From: $USER@$HOST' -s 'Auto Response: from $USER@$HOST' \
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
redeprotegida (6th May 2009)
  #7  
Old 5th May 2009, 17:47
redeprotegida redeprotegida is offline
Junior Member
 
Join Date: Apr 2009
Posts: 23
Thanks: 9
Thanked 1 Time in 1 Post
Default

i think it is a bug, im running ispconfig on 5 different servers...

2 running on fedora 8 (i know i cant do that, but i did)

3 running on fedora 10

all of my servers i tested autoresponder and it worx, but without the FROM, with the variable empty.

all of then i just found these infos on main.cf about maildrop

maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = maildrop


could you please tell me where is the file on ispconfig that generate the .autoresponder o i can edit it, then the next generations will be correct, maybe i can use the example that you gave me using $user@$host

or, maybe something that i can place on my main.cf to start filling the $RECIPIENT var.


thanks *again*
Reply With Quote
  #8  
Old 6th May 2009, 15:12
redeprotegida redeprotegida is offline
Junior Member
 
Join Date: Apr 2009
Posts: 23
Thanks: 9
Thanked 1 Time in 1 Post
Default

im still working on this, and not found nothing...
just work if i edit the .autoresponder file

someone give me a help please...

to help me:

what is the script that creates the .autoresponder file?

or

what i do to fill the $RECIPIENT that is empty?

thanks.
Reply With Quote
  #9  
Old 6th May 2009, 18:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Please try what I suggested to you in post #6 of this thread. All templates are in /usr/local/ispconfig/server/conf/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
redeprotegida (6th May 2009)
  #10  
Old 6th May 2009, 21:03
redeprotegida redeprotegida is offline
Junior Member
 
Join Date: Apr 2009
Posts: 23
Thanks: 9
Thanked 1 Time in 1 Post
 
Default

subject: Auto-resposta de diego@redeprotegida.com.br
from: diego@redeprotegida.com.br Add contact
to: teste@appsistemas.com.br Add contact
date: 06.05.2009 15:02


thanks very much till

i just changed the autoresponder script that you said
i changed the $RECIPIENT TO $USER@HOST
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu Hardy chrooted bind9 fails to start Djamu Server Operation 35 21st April 2010 09:28
PRO FTP log " Xferlog " empty romain33 Installation/Configuration 1 26th March 2009 18:27
vhcs2 auto responder not working Reptile Installation/Configuration 30 7th September 2007 07:39
Auto Whitelist chappy81 HOWTO-Related Questions 2 29th April 2007 21:31
Diagnostic-Code: X-Postfix; Host or domain name not found. Name service error Hellbound General 4 7th January 2007 12:50


All times are GMT +2. The time now is 03:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.