Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th February 2009, 16:54
anushanw anushanw is offline
Junior Member
 
Join Date: Jan 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default Debian 5.0 -ISPConfig 3 install - Unable to connect to mysql server

I have followed all the steps given in the manual and so far it was going well till i started installing ISPConfig 3
I started installing ISPConfig 3 with the SVN, selected the language and used the default (which are appropriate) values for the questions
when it try to connect to MySQL server or the database it asked me the questions to enter hostnamme, username, password, database to crease, charset.

Then it gave me an error saying:
"Unable to connect to mysql server Can't connect to local MySQL server through socket 'var/run/mysqld/mysqld.sock' (2)

Any idea what i should do?
Reply With Quote
Sponsored Links
  #2  
Old 17th February 2009, 17:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

This means that your mysql server is not correctly installed or running. Please redoo the mysql installation steps from the ispconfig 3 manual and make sure that you really started the mysql server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th February 2009, 17:27
anushanw anushanw is offline
Junior Member
 
Join Date: Jan 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i did install the mysql server and other things in step 1. howeever i re-did it right now and it gave me a sessage saying everything is uptodate.
when i type the command "/etc/init.d/mysql restart" it displayed the following

Stopping MySQL database server: mysqld.
Starting MySQL database server: mysqld.
Checking for corrupt, not cleanly closed and upgrade needing tables..

and for "/etc/init.d/mysql status" it gives
Server Version 5.0.51a-24
Protocol version 10
Connection Localhost via UNIX socket
UNIX socket /var/run/mysqld/mysqld.sock
uptime: 2 mins 2 sec

Threads: 1 Questions: 78 slow queries: 0 Opens: 23 Flush Tables: 1 Open tables: 17 Queries per second avg: 0.639

Any thing that you can think of???
Reply With Quote
  #4  
Old 17th February 2009, 17:34
anushanw anushanw is offline
Junior Member
 
Join Date: Jan 2009
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well it worked for one reason or the other when i asked for the status and re ran the installation process with the root password.

Thank you for your help.
Reply With Quote
  #5  
Old 4th May 2009, 22:59
RomaSvcs RomaSvcs is offline
Junior Member
 
Join Date: Apr 2009
Location: Vancouver,BC
Posts: 20
Thanks: 7
Thanked 0 Times in 0 Posts
Thumbs up Can't connect to mySQL to /var/lib/mySQL/mySQL.sock

I am using Centos 5.3 and I had the same problem, I solved this way...

Removed ISPCONFIG3
removed myDNS
using phpmyadmin removed all ispconfig or mydns DBs and users

then:

reinstall myDNS
reinstall ISPCONFIG3
problem solved

this steps should work on any linux distro.

hope this help

Carlos Barrera
Reply With Quote
  #6  
Old 21st November 2013, 21:50
conductive conductive is offline
Member
 
Join Date: Sep 2011
Posts: 90
Thanks: 3
Thanked 2 Times in 2 Posts
Default

I get the
Unable to connect to mysql server
During a Wheezy ispconfig3 multiserver install.

The Mysql server installation accepts special characters and passwords over 50 characters in length where ISSpconfig does not and may simply tuncate them.

I have kept my passwords below 49 but I ended up with the same error when attempting to install the secondary DNS server.

What are the ispconfig pw parameters?
Is there a limit on the total number of characters in a multi server environment?
Reply With Quote
  #7  
Old 24th November 2013, 17:41
conductive conductive is offline
Member
 
Join Date: Sep 2011
Posts: 90
Thanks: 3
Thanked 2 Times in 2 Posts
 
Default

The next server installed proverly so it appears that I improperly installed the DB credentials on one of the servers andd all is good if you keep passwords under 49
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
Connection dropped by IMAP server gublym Server Operation 5 23rd January 2009 09:47
Mail Question: installed smf forum on centos perfect server setup with ispconfig happz Installation/Configuration 7 22nd August 2008 13:15
What can be wrong martin_rudowicz Installation/Configuration 9 11th May 2008 19:42
subdomain and mail relay configuration aranthorn Installation/Configuration 24 3rd September 2007 22:53


All times are GMT +2. The time now is 01:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.